Jump to content

Viewer not working on ubuntu 12.10 64 bit


Mellissa Gothly
 Share

You are about to reply to a thread that has been inactive for 3662 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Hello everyone!

I recently swapped Linux distributions from Elementary OS Luna (ubuntu 12.04 variant) to Ubuntu 12.10, which had Firestorm installed on it. Firestorm ran fine, despite having a universal graphic driver installed (or at least it said 'graphics card - NA'). On Ubuntu 12.10 it now reports I have a graphic card, however I suspect that has nothing to do with the current problem.

When I try to run the secondlife file, I get this error pop up.

libGL error: failed to load driver: i965
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
libGL error: failed to load driver: swrast
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
The program 'do-not-directly-run-secondlife-bin' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
(Details: serial 30 error_code 11 request_code 154 minor_code 3)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)
*** Bad shutdown ($LL_RUN_ERR). ***

You are running the Second Life Viewer on a x86_64 platform. The
most common problems when launching the Viewer (particularly
'bin/do-not-directly-run-secondlife-bin: not found' and 'error while
loading shared libraries') may be solved by installing your Linux
distribution's 32-bit compatibility packages.
For example, on Ubuntu and other Debian-based Linuxes you might run:
$ sudo apt-get install ia32-libs ia32-libs-gtk ia32-libs-kde ia32-libs-sdl

*******************************************************
This is a BETA release of the Second Life linux client.
Thank you for testing!
Please see README-linux.txt before reporting problems.

(Firestorm shows its own variation on the error, with the same advice).

I have installed all the ia32 multiarch files, and tried various commands that resolved similar problems, however this error still comes up whenever I try to run it. I am using on a 64 bit version, with support for the i386 architecture. 

Does anyone else have this problem, or a solution? This can't be a hardware issue since nothing has been changed since the last operating system, and it runs perfectly fine in Windows 7 and XP.

Any help is appreciated, thank you!

Link to comment
Share on other sites

I'd recommend to install the following packages as  32 bit viewers need some 32 bit graphics libraries.

libgl1-mesa-dri:i386

libgl1-mesa-glx:i386

 

This command, executed in a terminal will install them

sudo apt-get install libgl1-mesa-dri:i386 libgl1-mesa-glx:i386

 

You could try a 64 bit viewer though, which does not  need 32 bit graphics libs

J.

Link to comment
Share on other sites


Jean Horten wrote:

I'd recommend to install the following packages as  32 bit viewers need some 32 bit graphics libraries.

libgl1-mesa-dri:i386

libgl1-mesa-glx:i386

 

This command, executed in a terminal will install them

sudo apt-get install libgl1-mesa-dri:i386 libgl1-mesa-glx:i386

 

You could try a 64 bit viewer though, which does not  need 32 bit graphics libs

J.

Thanks for your reply.

 

The terminal responded saying they were on their latest versions, and were set to manual installation. I would prefer to be able to use Firestorm viewer before resorting to a 64 bit OS, unusual why it plays up on 12.10 and not on 12.04. In theory there should be some solution, unless there is something wrong or depricated on the Second Life release, possibly trying to use outdated library functions. It is all I can think of since I have installed nearly every 32bit package relevant.

Link to comment
Share on other sites

The same: Viewer not working on Debian 7 Wheezy - 64

root@debsrv1:/home/trn/sl# ./secondlife

64-bit Linux detected.

Running from /home/trn/sl

32 bit acrhitecture was added:  dpkg --add-architecture i386

 (gconftool-2:17103): GConf-WARNING **: Client failed to connect to the D-BUS daemon:

Did not receive a reply. Error setting value: No D-BUS daemon running

 Warning: Did not register secondlife:// handler with GNOME: gconftool-2 failed.

Warning: Did not register secondlife:// handler with KDE: Directory /root/.kde/share/kde4/services/ does not exist.

- Installing menu entries in /usr/local/share/applications

bin/do-not-directly-run-secondlife-bin: error while loading shared libraries: libgobject-2.0.so.0: cannot open shared object file: No such file or directory

*** Bad shutdown ($LL_RUN_ERR). ***

 You are running the Second Life Viewer on a x86_64 platform. The most common problems when launching the Viewer (particularly 'bin/do-not-directly-run-secondlife-bin: not found' and 'error while loading shared libraries') may be solved by installing your Linux distribution's 32-bit compatibility packages.

For example, on Ubuntu and other Debian-based Linuxes you might run:

$ sudo apt-get install ia32-libs ia32-libs-gtk ia32-libs-kde ia32-libs-sdl

 root@debsrv1:/home/trn/sl# apt-get install ia32-libs

ia32-libs is already the newest version.

root@debsrv1:/home/trn/sl# apt-get install ia32-libs-gtk

0 upgraded, 36 newly installed,

 (gconftool-2:18017): GConf-WARNING **: Client failed to connect to the D-BUS daemon:

Error setting value: No D-BUS daemon running

 Warning: Did not register secondlife:// handler with GNOME: gconftool-2 failed.

Warning: Did not register secondlife:// handler with KDE: Directory /root/.kde/share/kde4/services/ does not exist.

- Installing menu entries in /usr/local/share/applications

bin/do-not-directly-run-secondlife-bin: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory

root@debsrv1:/home/trn/sl# apt-get install libgl1-mesa-dri:i386 libgl1-mesa-glx:i386

libgl1-mesa-dri:i386 is already the newest version.

libgl1-mesa-glx:i386 is already the newest version.

 

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 3662 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...