Jump to content

TnTBIondy Panthar

Resident
  • Content Count

    21
  • Joined

  • Last visited

Community Reputation

0 Neutral

About TnTBIondy Panthar

  • Rank
    Member
  1. Same here but win 7... not on a wireless, my firewalll is turned off, my antivirus is disabled, and I get the same notice about handshake :matte-motes-crying:
×
×
  • Create New...