Jump to content

Invalid Asset Error in Build 227422


Ashasekayi Ra
 Share

You are about to reply to a thread that has been inactive for 4176 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Thanks for the response.

I re-tried uploading the item, and it uploaded ok if I used the high LOD as a physics shape. o.O

Then, I tried to upload a simple item later that wouldn't upload with a simple box physics shape.  But, it would take its own lowest generated LOD. Very weird.

Link to comment
Share on other sites

There seems to be a lot wrong with phyics shape upload at the moment. I keep getting cases where the upload seems to work but rezzing the uploaded object fails without an error message. It just makes the rezzing sound and nothing appears. Changing the physics shape in different ways then often makes it work, but sometimes not. I can't discern any pattern.   Some of the objects rez one day and not the next, rez on one sim and not the next, and so on. It's too random and unreproducible to make a jira. Add to that the random disappearances (not 0,0,0) of objects that have been sitting there happily for days and give no errors when they are put back, and it has become rather frustrating.

Link to comment
Share on other sites

Yes, it has been frustrating. And, it would happen the week I put aside to upload some outfits I've been working on. u.u;

This is the reproducable error I've come across involving LOD and rigged mesh (separate issue from the invalid vertices error mind you). I placed it in a jira [ https://jira.secondlife.com/browse/CTS-558 ].

Below is the text from the jira.

 

With skin weights checked, the following circumstances cause the upload button to be greyed out:
1) Without a physics model set, the upload button becomes greyed out. (Not sure if this is expected new behavior or not)
2) When a physics model is added from a file. It occurs whether you use the file as is or with analysis/simplify.
Now, if you change the "Use Level of Detail" setting in the physics window to either one of the LODs, the upload button reappears. However, if you use analysis/simplify, the upload button becomes greyed out again. The button does show again if you re-pick the LOD in the pulldown.
Link to comment
Share on other sites

Only for skinned models? I would initially have expected physics shape to be ignored for these as they are destined to be atttachments that will have nomphysics of collisions. However, Im suppose that as long as it ism possible to rez them instead, then they should be able to have a physics shape. But why not just the default convex hull then? When would you need a different phsyics shape fo a rigged attachment? Maybe when we eventually get arbitrary skeletons for animating static mesh?

Link to comment
Share on other sites

Well, before, you could upload it without a physics shape. But now, the upload button is greyed out if no physics shape is supplied. I'm not sure if that is or is not expected behavior now. I'm looking at old clothing I uploaded (which I know I didn't touch the physics tab with). They all have a shrinkwrapped physics shape when I look at them with Render Metadata -> Physics Shapes. So, I assume the uploader stuck one on them in those days.

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 4176 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...