Jump to content

Cannot rez on non-transparent water


Vulpinus
 Share

You are about to reply to a thread that has been inactive for 2900 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

If I set water to non-transparent, and Advanced Lighting Model off, I cannot rez on the water. Is this expected behaviour? LL or FS veiwer; same in both.

If you wonder why I would do that, I can get an extra 20fps in sea battles like that. It's not often that I drop my graphics settings below ultra, but when battling pirates, I'll take any edge I can get.

The work around is to switch graphics settings to rez, then back again.

I'm just curious though if this is a 'feature' or a bug...

Link to comment
Share on other sites


Vulpinus wrote:

If I set water to non-transparent, and Advanced Lighting Model off, I cannot rez on the water. Is this expected behaviour? LL or FS veiwer; same in both.

If you wonder why I would do that, I can get an extra 20fps in sea battles like that. It's not often that I drop my graphics settings below ultra, but when battling pirates, I'll take any edge I can get.

The work around is to switch graphics settings to rez, then back again.

I'm just curious though if this is a 'feature' or a bug...

I'm able to rezz on water, both at properties I own and at public rezz spots, with ALM and transparent water off using both Firestorm 4.7.7 and the current Linden Lab Maintenance viewer. There must be another variable in your setup that's causing your problem.

Link to comment
Share on other sites

Hmm... interesting.

I tried many times to make sure I had tracked it down. Turning off both ALM and water transparency together prevented rezzing (I just got a red 'no entry' cursor when I tried). Turning either back on immediately allowed me to rez again.

I'll go and see if I can identify the real cause...

 

Link to comment
Share on other sites

I'm not saying you're wrong about another variable (you're probably right) but with everything else set on Ultra and just turning off ALM and Water Transparency, it definitely stops me from rezzing. It's as if the viewer needs to see the land under the water, even though it rezzes on top of the water.

I noticed that if I put a prim under water (on the sea bed, well under) and tried to rez on top of the water above the prim, I could rez there but not on either side. The cursor changed from the red no-entry sign to the usual 'drop your object here' cursor as I moved across where the hidden prim was.

Also, I don't even get any context menu if I right-click the water (away from the hidden prim) but I do if I click the water above the prim.

This is on my own parcel, but is the same on public-access sea where I first noticed that I couldn't rez my ship.

A picture is worth a thousand words... or at least most of the above. Note I had to cheat to put the 'can't rez here' cursor in - my screen grab didn't grab it.



 

ETA: I just tried on another PC with a 'backup' installation of FS on. Different graphics card, lower settings, nothing really 'customised' about that config at all. I get exactly the same behavoiur on that PC.

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 2900 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...