Jump to content

Mesh Upload size


Allison Lynagh
 Share

You are about to reply to a thread that has been inactive for 4443 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

I'm not sure what the problem is, and it doesn't affect me very much, more of a nuissance than anything, but I have come across a weird issue. 

Both a friend and I use the exact same .blend file (I gave her mine since I had the standard sizing already set and ready to go). I create rigged mesh clothing, and yet, there is an issue. Nothing major, but when I upload my meshes, they come in somewhere around 64mx 50mx20m or any other such arbitrarily high and outrageous number. I am constantly having to change the scale in the uploader to 0.01 to get it somewhat close to avatar size, and then scale it further down once I bring it inworld to a manageable size (so it's not a giant 64m cube to those that cannot see mesh). 

My friend has the opposite problem. She uploads her rigged meshes and they come at outrageously small sizes, usually minimum possible sizes (1cm or some such nonsense) and she's constantly having to scale them up inworld just to see them enough to texture. 

We use the same blender (jass-pub 2.49b I believe) and yet we have opposite issues from the exact same blender file base. 

Any suggestions on how to fix this, or am I doomed to continually resize my meshes after and during import?

Link to comment
Share on other sites

Here's something that works for me...

In blender, go the the Scene options region. There should be a set of buttons allowing you to choose what units you want to use. I have always set them to use metric and they appear to be honored through the export to dae and uploading into SL.

Link to comment
Share on other sites

  • in Blender 2.49 the unit was defined in the Collada exporter. You have to modify the scipt to change the unit settings.
  • For jass-pro i have added the ability to change the scale directly in the Collada export popup.
  • For Blender 2.5 and newer the Collada Exporter takes care about the Scale which is defined in the "Scene units" section. The default setting is 1.00 so the exporter takes Blender units as meters. That is how we want it for Second Life.
Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 4443 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...