Jump to content

GoddessAlthea420

Resident
  • Content Count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral

About GoddessAlthea420

  • Rank
    Newbie
  1. when I try to launch the viewer , it opens but then it says I need to install version 6.2.3.527758.... but that is the version I have installed... is anyone else having this issue? does anyone know how i fix it?
×
×
  • Create New...