Jump to content

Max SLAV rigging problem


Guest
 Share

You are about to reply to a thread that has been inactive for 4050 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Hello fellow meshy makers!

I've been working with mesh since it was only on the beta grid and I am just now trying my hand at making some rigs.

As per standard instrucions, I have moved forward and used the "Mesh Wrap" modifer atop a SLAV downloaded shape.

I added the addtional bones needed in Notepad++, howe ever looking at the joints in the uplad window they come out deformed. Deformed as in, misshapen and resmlbing nothing human. Some of them even appear to move in the upload window.

What would be causing this issue? What did I miss?

 

All verts are wieghted, gird is set to 1m per square and standard meters, I did not copy paste the list, Z-Up is selected, and I am using Autodesk Collada FBX 2011 for saving the mesh, as defined in the wiki. What am I missing? What could I be doing wrong?

Link to comment
Share on other sites

Possibilities:

* Is the avatar facing the correct direction, and reset transforms so that all rotations and scaling are nulled out"

* Do the bones line up properly with the model you are making? If they are offset from the center of the limb or not the right length, it will end up distoted.

* I think you mean "Skin Wrap" modifier.  After applying that, you generally have to hand tune the weights, or adjust the range settings in the modifier for how far away they affect vertices.  My experience with Skin Wrap is it gives a first approximation by copying weights from another model, but that is not a substitute for hand adjusting the weights.

* Vertex weights need to add up to 100% regardless if it's one bone or several.  One trick is to weight everything 100% to the pelvis before using Skin Wrap or the bone capsules, or other methods to do weighting.  That way every part will at least have a weight to *something*.

When making my full body mesh avatar, I literally did 100 uploads to the beta grid while tuning weights.  It was my first time, but I don't think there is a "make pretty" button on any 3D software. You need some amount of going back between SL and your 3D program adjusting things until it's right.

 

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 4050 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...