Jump to content

Trying to animate on 3D Max


Alanna Preez
 Share

You are about to reply to a thread that has been inactive for 3635 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Hi everybody, I have been struggling with this for days now.. I dont even know if Im doing things right. I know Max is the worst possibility to make SL animations but its the tool I work in RL so Im more confortable using it than any other. I dont have any animating experiance, my work consists basically on modeling, mapping and texturing so Im relatively new to bones, etc..

 

Here is what I have been trying to do:

1) Im using SLAV to generate the rigged base model with all 26 bones.

2) I renamed the 19 bones SL uses according to this link here. (http://community.secondlife.com/t5/Mesh/Joint-names/td-p/810861)

3) Kept the T pose at frame 0 and at frame 2 I made a static pose just to test it.

4) Run Abu_SL_BVH_Exporter_beta8, unfortunately thats the only script I found that does something. But it gives me a error when it starts to rotate each bone. In order to make it run I had to remove all this rotation and adjustment process.

5) The generated BHV opens on BVhacker, it gives me an "ok" if I test the joints but the animation itself shows as 120f frames. If i try to run it the program crashes.. in SL it gives me errors, like "Premature end of file"

 

Another workflow I tryed was trying:

1) Im using SLAV to generate the rigged base model with all 26 bones.

2) I renamed the 19 bones SL uses according to this link here. (http://community.secondlife.com/t5/Mesh/Joint-names/td-p/810861)

3) Kept the T pose at frame 0 and at frame 2 I made a static pose just to test it.

4) Export it as FBX and open on MotionBuilder

5) Export as BVH.

This works a little better.. I can import on SL but nothing happens, my avatar legs move slightly but thats it, no other reaction at all. If I try to open this one on BVhacker it will complain about the extra joints, mSkull, mEyeRight, mEyeLeft, mFootRight and mFootLeft. If I try to remove them on either max or here it wont run, on SL I will get another error and cant even visualize them.

 

In all cases the animations show as over 100 frames, but honestly thats the smallest of my problems.. can anyone help, it would be much appreciated.

Link to comment
Share on other sites

  • 3 weeks later...

Well i'm on the same track but it seems i'm already a bit further.


forget about 3ds max for the animation part. do that in montionbuilder entirely. All you needs is the bones and to rig the mesh to it. Export (include media) as fbx. In motionbuilder you characterize it. Create a controle rig. Run your SL rig trough your controle rig wich is running data from free mocap bvh or whatever. Then "bake" it to the skeleton/mesh and then you can either go back to max for finetuning the rigging with the fbx. (as your bones should be animated in max now) Or export it as a bvh file.


i dont know i might be wrong.

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 3635 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...