Jump to content

Kasia Mistwood

Resident
  • Content Count

    9
  • Joined

  • Last visited

Community Reputation

1 Neutral

About Kasia Mistwood

  • Rank
    Newbie
  1. Yes, I've tried again, and it worked, im so glad it was the same as yours. Just wasnt sure If it was going to work for real or was just going to be an another fail I know the -1234 is just an example heheh I will sort out something of my own. And yes, since the comunication is done by touching the prim, the 'start' phrase can be switched to 'giaudohvdaousip' which preety much sorts the problem out for good I would like to thank you so much Rolig. Untill today I was touching or telling everything to do things in public and now it all got so much easier Thanks
  2. Yes, I was thinking about it, and came to few things... At first I thought that its fine that way because It is impossible for any avatar to send any accidental 'ON' command on the local chat (since it cant communicate on negative channels effectively on regular viewer). In the first script, anyone could start the object even by typing 'start' at the local chat accidently (to start something else or so...). Now there is nothing any person can do to start it 'verbally'. So no one passing my house saying start randomly will set it on fire But, there is a possible situation I can imagine when it would be still better to have the owner checked. It is if my object was placed around someone with another HUD or object saying 'start' on -1234 channel. So for example if I made a HUD witch operates my house (like switching all lights, switching halloween particles on my tree and filling the pool) and shared it with my neighbour or shared only the channel number with my neighbour, we would switch each others furnitures ON. Thinking about it Ive tried to change the script again... And when I try to put the part if (llGetOwnerKey(id) == llGetOwner) in the listen event, after the part llListen(-1234,"","",""); it tells me the name is not defined within the scope. Should I add another listen event? or should it be as 'key'? Because I understood I should remove the 'reset part' and definitely start with llListen(-1234,"","","")? Like: default{ state_entry() { llListen(-1234,"","",""); } listen(integer channel, string name, key id, string message) { if(message=="stop") { llTargetOmega(<0,0,0>,PI,1.0); } if(message=="start") { llTargetOmega(<0,0,8>,PI,1.0); } }} Or should I have left the reset part and add the owner part to the 'changed' event? I finished with: default{ state_entry() { llListen(-1234,"","",""); } listen(integer channel, string name, key id, string message) { if (llGetOwnerKey(id)==llGetOwner()){ if(message=="stop") { llTargetOmega(<0,0,0>,PI,1.0); } if(message=="start") { llTargetOmega(<0,0,8>,PI,1.0); } }}} But I dont know If its ok. Its working and is possible to save (rare with my scripting). But could you please tell me if it is what was needed to make it work for owner only? Thank you so much again
  3. So Happy I have changed the scripts listen handle as you said and its working great, even transferred or copied. That is just awesome, its exactly what i was trying to learn to do Thank you so much Rolig, I appreciate it a lot Thats how it looks like at the end; Sender: integer gON;default{ touch_start (integer num) { llSay(-1234,llList2String(["stop","start"],(gON = !gON)) ); }} Receiver: default{ state_entry() { llListen(-1234,"","",""); } changed (integer change) { if (change & CHANGED_OWNER) { llResetScript(); } } listen(integer channel, string name, key id, string message) { if(message=="stop") { llTargetOmega(<0,0,0>,PI,1.0); } if(message=="start") { llTargetOmega(<0,0,8>,PI,1.0); } }}
  4. Dear Rolig, Thanks again for your quick and accurate answer , and again Im sorry for replying so slowly myself. Ive spent some time experimenting with channels and Im affraid Ill have to ask one or two more questions (Im trying to learn as quick as I can, but...) Ive put the script for the HUD you gave me into an object and worn it as a HUD. It was possible to click the HUD. Then, Ive put the script into an inworld object and tried if the hud switched the object On. Unfortunately It didnt ( The script for receiver was like that, with the channel adapted to sender (-1234): default{ state_entry() { llListen(-1234,"",llGetOwner(),""); } changed (integer change) { if (change & CHANGED_OWNER) { llResetScript(); } } listen(integer channel, string name, key id, string message) { if(message=="stop") { llTargetOmega(<0,0,0>,PI,1.0); } if(message=="start") { llTargetOmega(<0,0,8>,PI,1.0); } }} When I changed channel from "-1234" to positive "1234" it also gave nothing, but positive channel made it work using chat command "/1234 start". I understand that there must be something wrong with the say/listen part synchronization: Sender: llSay(-1234,llList2String(["stop","start"],(gON = !gON)) ); Receiver: llListen(-1234,"",llGetOwner(),""); ...but I couldnt find out what. Ive tried with llMassageLinked and later changing "llGetOwner" into llList2String, but it only created more mismatches...Or maybe its the 'owner' part that makes some troubles here...? Maybe theres something you could suggest looking at those codes, I would be so grateful for that help. Also, would like to thank you again for your help, time and support :D So much appreciated
  5. Thanks a mill Rolig, Its working great now, even passed around a lot When it comes to the channels used... At first I was trying to avoid using chat at all. I was looking into making a HUD with a button that clicked would say 'start' on any channel which would make a prim inworld perform simple action. After few failed tries, based on scripts found, I've decided to move back to chat solution... Ill have a look into changing the channel used, but would also like to ask if you knew by a chance where to look for a smiple HUD-prim script? I mean as simple as rotating a prim on HUD click... Thanks again
  6. Hello, I would like to ask If anyone could hep me with rather simple script... Ive made a script that rotates the texture when I say 'start' in the local chat, and stops it when I say 'stop'. Works perfectly so far. I wanted to give it to someone and it seems it doesnt work with anyone but me... Ive tried my best to repair it, and make it work after transfer to someone but I failed :( I would like to keep the local chat start/stop feature for next owner. Here is what I begun with; default { state_entry() { llListen(0,"",llGetOwner(),""); } listen(integer channel, string name, key id, string message) { if(message=="stop") { llTargetOmega(<0,0,0>,PI,1.0); } if(message=="start") { llTargetOmega(<0,0,8>,PI,1.0); } } } I've tried to change llListen(0,"",llGetOwner(),""); with llListen( 0, "", NULL_KEY, "" ) and later add: on_rez(integer start_param) { llResetScript(); } changed(integer change) { if (change & (CHANGED_OWNER | CHANGED_INVENTORY)) llResetScript(); } but nothing worked... Cant really tell anymore what might be wrong myself... Hoped that simple change would solve the problem but it seems more complex. I would appreciate any solution, thanks a lot for your reply Thanks
  7. Thanks a lot for your help I've set the particles as you said and itr seems to work well now. They start and stop on start/stop command in chat Thanks for your time again PS: Sorry for such a long time to reply
  8. Thank you for reply, but its not really the problem, sorry if i didnt explain correctly. The particles work perfectly already. They switch ON and OFF on click (touch). I would like to do the same but with local chat command. So make them appear on 'ON' and dissapoear on "OFF" in chat instead of touching. Thanks again
  9. Hello, I was trying to change the way my script operates. So far it switches the light beacon ON on touch and switches it OFF on touching it again. I was trying to make it switch ON/OFF after saying something on the local chat, "lights" for example. Here is my basic 'touch' script. On touch it changes particles to be invisible. integer Toggle = FALSE; default { touch_start(integer num_detected) { if (Toggle == FALSE) { Toggle= TRUE; llParticleSystem ([ PSYS_PART_FLAGS, PSYS_PART_INTERP_COLOR_MASK| PSYS_PART_FOLLOW_SRC_MASK| PSYS_PART_EMISSIVE_MASK, PSYS_SRC_PATTERN, PSYS_SRC_PATTERN_ANGLE_CONE, PSYS_SRC_INNERANGLE, 0.0, PSYS_SRC_OUTERANGLE, 0.1, PSYS_SRC_BURST_SPEED_MIN, 0.0, PSYS_SRC_BURST_SPEED_MAX, 0.0, PSYS_SRC_BURST_RADIUS, 0.0, PSYS_SRC_BURST_PART_COUNT, 5, PSYS_SRC_BURST_RATE, 1.6, PSYS_PART_MAX_AGE, 1.0, PSYS_PART_START_SCALE, <1,1,1>, PSYS_PART_START_COLOR, <1,1,1>, PSYS_PART_END_COLOR, <1,1,1>, PSYS_PART_START_ALPHA, 1.0, PSYS_PART_END_ALPHA, 0.0 ]); } else if (Toggle == TRUE) { Toggle= FALSE; llParticleSystem ([ PSYS_PART_FLAGS, PSYS_PART_INTERP_COLOR_MASK| PSYS_PART_FOLLOW_SRC_MASK| PSYS_PART_EMISSIVE_MASK, PSYS_SRC_PATTERN, PSYS_SRC_PATTERN_ANGLE_CONE, PSYS_SRC_INNERANGLE, 0.0, PSYS_SRC_OUTERANGLE, 0.1, PSYS_SRC_BURST_SPEED_MIN, 0.0, PSYS_SRC_BURST_SPEED_MAX, 0.0, PSYS_SRC_BURST_RADIUS, 0.0, PSYS_SRC_BURST_PART_COUNT, 5, PSYS_SRC_BURST_RATE, 1.6, PSYS_PART_MAX_AGE, 1.0, PSYS_PART_START_SCALE, <1,1,1>, PSYS_PART_START_COLOR, <1,1,2>, PSYS_PART_END_COLOR, <1,1,2>, PSYS_PART_START_ALPHA, 0.0, PSYS_PART_END_ALPHA, 0.0 ]); } } } I was trying to make it change on saying "ON' or "OFF" but it never worked. It switches it ON once, and nothing happens ever again... default { // when the script has been saved (only in default) or when re-entering this state state_entry() { key owner = llGetOwner(); llListen(0, "", owner, ""); } listen(integer channel, string name, key id, string message) { if (message == "ON") { llParticleSystem ([ PSYS_PART_FLAGS, PSYS_PART_INTERP_COLOR_MASK| PSYS_PART_FOLLOW_SRC_MASK| PSYS_PART_EMISSIVE_MASK, PSYS_SRC_PATTERN, PSYS_SRC_PATTERN_ANGLE_CONE, PSYS_SRC_INNERANGLE, 0.0, PSYS_SRC_OUTERANGLE, 0.1, PSYS_SRC_BURST_SPEED_MIN, 0.0, PSYS_SRC_BURST_SPEED_MAX, 0.0, PSYS_SRC_BURST_RADIUS, 0.0, PSYS_SRC_BURST_PART_COUNT, 5, PSYS_SRC_BURST_RATE, 1.6, PSYS_PART_MAX_AGE, 1.0, PSYS_PART_START_SCALE, <1,1,1>, PSYS_PART_START_COLOR, <1,1,1>, PSYS_PART_END_COLOR, <1,1,1>, PSYS_PART_START_ALPHA, 1.0, PSYS_PART_END_ALPHA, 0.0 ]); } if (message == "OFF") { llParticleSystem ([ PSYS_PART_FLAGS, PSYS_PART_INTERP_COLOR_MASK| PSYS_PART_FOLLOW_SRC_MASK| PSYS_PART_EMISSIVE_MASK, PSYS_SRC_PATTERN, PSYS_SRC_PATTERN_ANGLE_CONE, PSYS_SRC_INNERANGLE, 0.0, PSYS_SRC_OUTERANGLE, 0.1, PSYS_SRC_BURST_SPEED_MIN, 0.0, PSYS_SRC_BURST_SPEED_MAX, 0.0, PSYS_SRC_BURST_RADIUS, 0.0, PSYS_SRC_BURST_PART_COUNT, 5, PSYS_SRC_BURST_RATE, 1.6, PSYS_PART_MAX_AGE, 1.0, PSYS_PART_START_SCALE, <1,1,0>, PSYS_PART_START_COLOR, <1,1,0>, PSYS_PART_END_COLOR, <1,1,1>, PSYS_PART_START_ALPHA, 1.0, PSYS_PART_END_ALPHA, 1.0 ]); } } } I tried a lot of combinations but none has ever worked. After running once it always stays this way :( I would be very very very glad for help with that :) Thanks :)
×
×
  • Create New...