Jump to content

TheGovnor

Resident
  • Content Count

    10
  • Joined

  • Last visited

Community Reputation

0 Neutral

About TheGovnor

  • Rank
    Member
  1. TheGovnor

    Really??

    Hi I was trying to make a hud worn from inventory detach and delete it self. Everything works except the delete part. I was under the understanding that if you used llAttachToAvatarTemp, then llDetachFromAvatar that the object would delete self on detach followed by llDie();, But its not :(. You cant drop an attachment to delete itself, from avatar if it has a script in it.... So llAttachToAvatarTemp, then llDetachFromAvatar llDie(); will only work if you wear/attach the hud or object from rez and not inventory?. You cant make an object worn from inventory delete itself from your inventory on detach at all?? This is just very frustrating if so :((.
  2. QAvimator is limiting?? In what way??. I have been using it for over 6 years and can make any animations. I have been hired by many people in sl to make alsorts of animations. All have been very satisified with the products. Infact I have had comments that some of the animations are the best they have seen in SL...this is from 10 years + players. The only limits are your imagination . I have used Daz and blender (both great programmes) but always end up back in QAvimator to get the animations exactly how I want them. I will agree that Daz and blender makes animating alot easier in ways than QAvimator. There are alot of functions in QAvimator that many people dont know about due to the lack of litature concerning QAvimator. Yeah Im a die hard .
  3. Ah got it sorted. Your comments help me figure it out. Im new to scripting . TY .
  4. Hi All Im trying to make the contents of a hud self delete after 5 seconds and also detach from the avatar. Heres the script. It saves and works as intended, except the deleting part... Any help or suggestions would be very much appreicated. Oh and it works fine when i change it to on rez.
  5. I wondered what was going on..... get rid of voice and cam and make sl great again .
  6. Or get good with QAvimator, its very very good.
  7. All is working how I would like it too now. Ty for your help and suggetions .
  8. What I was trying to do is put the on off script inside the melee script and activate the melee script via the on off one within the melee script. Hud will have to be 2 linked prims for it too work then, makes sense now....how did I miss that part .
  9. Ok here are parts of the script. string ownerName; integer switch; integer COM_CHANNEL = -12345; integer status; string draw_command = "draw"; string sheath_command = "sheath"; ButtonPress() { llSetLinkPrimitiveParamsFast(LINK_THIS, [PRIM_SIZE, <0.01, 0.0775, 0.0775>]); llTriggerSound("e6b5e02f-5d8a-831b-a951-0481981740b4",1); llSleep(0.025); llSetLinkPrimitiveParamsFast(LINK_THIS, [PRIM_SIZE, <0.01, 0.1000, 0.1000>]); } default { on_rez(integer params) { llStopSound(); llSetLinkAlpha(LINK_SET, 1.0, ALL_SIDES); llSetLinkAlpha(1,0.0,ALL_SIDES); ownerName = llKey2Name(llGetOwner()); } state_entry() { llListen(COM_CHANNEL,"", NULL_KEY,""); integer perm = llGetPermissions(); if (perm != (PERMISSION_TAKE_CONTROLS | PERMISSION_TRIGGER_ANIMATION)) } touch_start(integer total_number) { ButtonPress(); if (switch==0) { switch=1; llSay(COM_CHANNEL,"draw"); } else if (switch==1) { switch=0; llSay(COM_CHANNEL,"sheath"); } } attach(key on) { if (on != NULL_KEY) { integer perm = llGetPermissions(); } } listen( integer channel, string name, key id, string message ) { if(llGetOwner() != llGetOwnerKey(id)) return; if(message == draw_command) { weapon_show(); } if(message == sheath_command) { weapon_hide(); } }
  10. Hi I feel like a dosh. Im new to scripting... I have made a hud and scripted it to act like an on off button. It works fine. I have a melee script that i took from a weapon and then added the hud script to it, it saved without issue. I have then put the melee+hud script into the object (hud) and added the animations etc. The problem is when I touch the hud and it turns on, the melee part of the script wont activate. The on state triggers the Draw msg..but for some reason the rest of the script isnt hearing the msg. If I wear the weapon with the origonal melee script in it and then press the hud on screen the melee weapon activates o.O. If I take off the weapon and wear just the hud with melee/hud script joined..the hud will trigger the melee part of the script if I type /65 draw in chat and all works fine o.O. So communication is happening...just not within the joined melee/hud script itself. I have looked and looked and tried alsorts of things but the press on wont activate the melee script when the two are as one script -_-. I dont know what Im doing wrong, but feel its something to do with the melee script coming from an wear on avatar and the hud script isattachment to screen. So they are not communicating as one, but will when seperate. its doing my head in cos it probably very simple to fix grrr. Hope this isnt to confusing..please help.
×
×
  • Create New...