Jump to content

Poltergeist Azarov

Resident
  • Content Count

    94
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Poltergeist Azarov

  • Rank
    Advanced Member
  1. Thank you so much everyone. As i see so far, as much as user count increases up to 60, script run is around 2%... Looks like they run at their lowest performance of 100%, am I right? In this case, what causes bottle neck is clear enough i think. This makes me think i will need to divide hard processes and distribute to clients themselves.
  2. Thank you. So how would you avoid the problem? Script slows down alot due to agent count, every client needs to send a message to server at each 25 seconds. (We can say client count gets up to 50 sometimes).
  3. Yesterday i realized in a sim, when there are many agents like 80, object to object messages are failing some ways. When this happens, time dilation is ok, frame_number is ok(not freezing) but looks like scripts are working very slowly. In this case the server-object is releasing queued messages which is sent by using llregionsayto by clients. My question is, what slows down the scripts exactly? The CPU time consumed by agents in the sim? How to avoid the queue problem when scripts are working very slowly?
  4. Somehow two hosts i used have closed outbound traffic over the port: 12046 at the same time! This is really sick... Probably they both made an update on their servers according to a new release of an application. Or they are must be connected to each other somehow... Anyways, time to look forward. Cheers...
  5. Checked both, thank you for letting me know these also. I'll need to keep these in mind. However when I call the link through my web browser, it works fine: http://sim10052.agni.lindenlab.com:12046/cap/97350f35-cb77-de19-9cbd-e4e23d7d52e3/ Returns "Hello there!". In this case, this thread makes sense: http://forums-archive.secondlife.com/54/70/362356/1.html However i tested the issue through two different hosts and both hosts were working fine so far which makes me think its a SL side HTTP-in problem. Maybe SL needs some more headers since two days? I'll try to simulate a web browser call through PHP...
  6. Hello, I am not sure if everyone is having the same trouble with connecting to SL objects though cURL so PHP since last night. My entire flower system is stopped due to cURL timeouts. Is there any update or something?
  7. I use something like that to prevent double clicks. Edit: Sorry by the way. This must be not the one you are looking for. float last_touch_time;default{ touch_start(integer x) { if ((last_touch_time+1.0)<llGetTime()) { llOwnerSay("Single touch."); last_touch_time=llGetTime(); } }}
  8. Thank you Innula, Yesterday I changed whole communication scenario to not to need server ip. Now things are better I think. However the scenario is complicated, so script is complicated which makes me tired even though I code it myself.
  9. Sorry, it does not. Thank you for the link though I will just stop looking for a solution for that and keep coding things different way.
  10. Hello, I needed sl server ip for some reason today. to do that I sent a packet from inworld to my host and tried to extract ip address and all I got was localhost: 127.0.0.1... Then I contacted to host provider about that and they said I need to talk to second life provider. Heres the php code that I was using to get visitors ip: <?PHP function getUserIP() { $client = @$_SERVER['HTTP_CLIENT_IP']; $forward = @$_SERVER['HTTP_X_FORWARDED_FOR']; $remote = $_SERVER['REMOTE_ADDR']; if(filter_var($client, FILTER_VALIDATE_IP)) { $ip = $client; } elseif(filter_var($forward, FILTER_VALIDATE_IP)) { $ip = $forward; } else { $ip = $remote; } return $ip; } $user_ip = getUserIP(); echo $user_ip; // Output IP address [Ex: 177.87.193.134] ?>
  11. I didnt know that syntax thing. Thank you for letting me know it
  12. Hello, sorry I havent checked the forum since few days. I just saw your request. You will need to use Sublime text 2 first of all (since version 3 does not work properly yet). Then package control has to be installed. See: https://packagecontrol.io/installation and the last step is to add LSL syntax addon at https://github.com/Makopo/sublime-text-lsl Note: Actually its not that difficult to setup as much as it was for me since I already find the best syntax file and such by almost a week of research and tests. It was so difficult for me... Enjoy it
  13. I use "Sublime text 2" even though it was not easy to setup. However, much better than notepad++
  14. As you have said Nova, In fact, its not really possible to make a beam or trail by using ribbon on a static prim but after some work, I did it. It is kind of a tricky beam I can say. Had to spend a serious time on it to find a tricky way. Since my point is to make a gun which does not need to rez a prim. heres the another example preview. (This might be seem to be slow on this preview GIF. Its fast as it should be inworld). From the otherside, as shown on this example, I also simulated a bullet deviation which might be used in the near future.
×
×
  • Create New...