Jump to content
  • 0

how to reverse mouse when walking/flying?


Question

16 answers to this question

Recommended Posts

  • 0

Avatar mouse steering

 

You can orbit your view around your avatar by clicking anywhere on your avatar and holding the Left mouse button. As you turn your view left or right, your avatar turns to face the same direction as the camera, allowingyou to steer your avatar.

 

http://community.secondlife.com/t5/English-Knowledge-Base/Camera-point-of-view-controls/ta-p/700047#Section_.5

Link to post
Share on other sites
  • 0

I hate to necro this, but I had the same problem, and figured out how to fix it. So this is here as a "Dear people from the future" for whenever someone Googles this. Like me. Six months from now when I do a fresh install and don't remember how I fixed this. :)

To be more specific about the problem:

The "Invert Mouse" setting controls the up/down movement while in mouselook, so that's not what we're looking for.

The problem here is that normally, when you're in third person, walking, you can left-click and hold your avatar's back, and then drag the mouse to the left and right to steer. Normally, (or at least, previously by default) your avatar would turn towards the direction you dragged the mouse.
The new default (viewer 3x) SEEMS to be inverting that, dragging to the left turns your avatar clockwise (to the right). What's actually happened is that  the "Single click on land" setting in the Move & View tab in preferences is set to "Move to Clicked Point" by default. It's pretty self-explanatory: instead of right-clicking on land and selecting Walk/Move Here, you can just click once, a little dot appears, and your avatar starts walking towards it. The problem is that with this setting on, the viewer ignores when you click and hold on your avatar, instead steering like it would if you clicked and held on the land.
Sorry that was so long winded, I get that way when I've gone too long without sleeping.


TL;DR:
To fix this problem in Viewer 3 (and maybe other viewers built on it, eg Firestorm):

  1. Click Me menu > Preferences.
  2. Click the Move & View tab.
  3. In the drop down menu next to Single click on land, select No Action.
  4. Click OK to close/save preferences.
  5. Change takes effect immediately.

Changing the debug setting ClickToWalk to False does the same thing.

[EDIT]: Yeah, I was waay too tired. Sorry, Mootly, I think the thread post order is set on "Shuffle" for some reason :P and I didn't see your post. Have a Kudo(s?).

/me goes back to lurking.

  • Like 1
Link to post
Share on other sites
  • 0

Meanwhile, eight years later!

"Invert Mouse" controlling the "up/down" camera angle is *exactly* what I was looking for, and Baloo's response pointed me in the right direction BUT… I assume that the UI has changed since then, because I sitll had to hunt around to find my answer!  So, here's an update, with the current path to this solution:

 

Avatar --> Preferences (Ctrl+P) --> Move & View --> Mouselook --> Mouselook mouse sensitivity --> Invert!

 

-Sonarr

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...