Jump to content
Sign in to follow this  
stevenking888

How can i install the SL in the linux OS of ubuntu.

Recommended Posts

If you installed the client system-wide (with root priviledges), a desktop file can be found in /usr/local/share/applications. If you install in your home, the file will be in ~/.local/share/applications (which is a hidden folder).

This desktop file says that the SL client should appear somewhere in the big desktop menu. If not, take that file and link it onto your desktop or drop it onto a panel.

Edit: And leave the Wine in its cellar! The Linux native client is the most stable...

Share this post


Link to post
Share on other sites

In Ubuntu you'll also need to install the SDL libraries. Either through the package manager or from commandline:

sudo apt-get install libsdl1.2debian

Depending on what else you've got on your system it might already be there. If the client doesn't start, that's the most likely missing library.

Oh and if you really can't find the launcher in your menu, just launch SL by going to the installation directory and running the "secondlife" shellscript.

Share this post


Link to post
Share on other sites

Don't use wine, why would you? There are native Linux versions of almost all TPVs and the official LL viewer, don't complicate things when you don't need to. Installing the viewer in Linux is much easier and much faster than doing so in Windows. Don't try to install, forget the install script, the Linux viewer is built to run directly from the directory you have unpacked it to. Just unpack the tar file in your home directory (or wherever you wish) and run it by the ./secondlife command from the directory you unpacked it to. Also just make a launcher to run that command to make it even easier.

Share this post


Link to post
Share on other sites

Actually, if the Windows version works under WINE with reasonable performance, I'd be tempted to recommend it to people running 64-bit Linux because of the issues with Second Life and streaming media under 64-bit Linux.

Share this post


Link to post
Share on other sites

Melissa, installing esound and the 32 bit compatibility libs under Linux 64 bit and uncommenting the line 8 in the secondlife.sh shell script from

#export LL_BAD_OPENAL_DRIVER=x

to 

export LL_BAD_OPENAL_DRIVER=x

will give you streaming sound in many viewers, including the official LL ones as well as Firestorm, as this will switch streaming music playback over to the integrated FMOD in these viewers.. No need to emulate  windows under linux to have sound under 64 bit Linux..

By the way:

A  64 bit system will also give you the advantage that the V3 based viewers will not crash at 2 GB of RAM usage, they will crash at 3.7 GB of RAM usage.

Pure 64 bit V3 third party viewers ( yes, there are two of them out there) will not crash at 3.7 GB of RAM usage. I had such a viewer scratching the 8 GB RAM usage mark once.

Time for LL to make a 64 bit Linux viewer too or to finally fix their memory leaks....

Jeannie

Share this post


Link to post
Share on other sites

Diamond icon? What diamond icon?

The steps to install Second Life under Ubuntu are like this:

1) Download the Viewer from here: https://secondlife.com/support/downloads/

2) Extract the archive to someplace you can remember (if you do not know how to extract an archive under Ubuntu: Right-click on the archive, select "Extract here")

3) The extracted viewer will now be in a subdirectory called "SecondLife-i686-[version]". Go into that folder.

3a) If you just want to run it: click on the file called "secondlife". Second Life will automatically be installed in your Ubuntu menu under "Internet".

3b) If you want to install it "properly", click on the file called "install.sh". This will install Second Life in a folder in your home directory and also create a lauch icon under the "Internet" menu.

Btw, the icon isn't a diamond. It's a green hand on black background.

Caveats:
* If you're on 64bit, you'll need to install the package "ia32-libs-multiarch". That gets most of SL working.
* If you're using a nVidia or ATI graphics card you need to install the proprietary drivers for those.

Share this post


Link to post
Share on other sites

I did this maybe  20 times  and  is still the same .  ,, diamond icon " ;) I mean  secondlife file which should start  sl .

im on linux ubuntu 13.04  

before when I use  9.04 was working fine  for years and  now I back to  ubuntu and  can't install sl 

 

,,Btw, the icon isn't a diamond. It's a green hand on black background.

yeah - and  this I have and is only png image

and  file with name secondlife  when I click on this  showing me this : 

#!/bin/bash

## Here are some configuration options for Linux Client Testers.
## These options are for self-assisted troubleshooting during this beta
## testing phase; you should not usually need to touch them.

## - Avoids using any FMOD Ex audio driver.
#export LL_BAD_FMODEX_DRIVER=x
## - Avoids using any OpenAL audio driver.
#export LL_BAD_OPENAL_DRIVER=x

## - Avoids using the FMOD Ex PulseAudio audio driver.
#export LL_BAD_FMOD_PULSEAUDIO=x
## - Avoids using the FMOD or FMOD Ex ALSA audio driver.
#export LL_BAD_FMOD_ALSA=x
## - Avoids using the FMOD or FMOD Ex OSS audio driver.
#export LL_BAD_FMOD_OSS=x

## - Avoids the optional OpenGL extensions which have proven most problematic
##   on some hardware.  Disabling this option may cause BETTER PERFORMANCE but
##   may also cause CRASHES and hangs on some unstable combinations of drivers
##   and hardware.
## NOTE: This is now disabled by default.
#export LL_GL_BASICEXT=x

## - Avoids *all* optional OpenGL extensions.  This is the safest and least-
##   exciting option.  Enable this if you experience stability issues, and
##   report whether it helps in the Linux Client Testers forum.
#export LL_GL_NOEXT=x

## - For advanced troubleshooters, this lets you disable specific GL
##   extensions, each of which is represented by a letter a-o.  If you can
##   narrow down a stability problem on your system to just one or two
##   extensions then please post details of your hardware (and drivers) to
##   the Linux Client Testers forum along with the minimal
##   LL_GL_BLACKLIST which solves your problems.
#export LL_GL_BLACKLIST=abcdefghijklmno

## - Some ATI/Radeon users report random X server crashes when the mouse
##   cursor changes shape.  If you suspect that you are a victim of this
##   driver bug, try enabling this option and report whether it helps:
#export LL_ATI_MOUSE_CURSOR_BUG=x

if [ "`uname -m`" = "x86_64" ]; then
    echo '64-bit Linux detected.'
fi


## Everything below this line is just for advanced troubleshooters.
##-------------------------------------------------------------------

## - For advanced debugging cases, you can run the viewer under the
##   control of another program, such as strace, gdb, or valgrind.  If
##   you're building your own viewer, bear in mind that the executable
##   in the bin directory will be stripped: you should replace it with
##   an unstripped binary before you run.
#export LL_WRAPPER='gdb --args'
#export LL_WRAPPER='valgrind --smc-check=all --error-limit=no --log-file=secondlife.vg --leak-check=full --suppressions=/usr/lib/valgrind/glibc-2.5.supp --suppressions=secondlife-i686.supp'

## - Avoids an often-buggy X feature that doesn't really benefit us anyway.
export SDL_VIDEO_X11_DGAMOUSE=0

## - Works around a problem with misconfigured 64-bit systems not finding GL
I386_MULTIARCH="$(dpkg-architecture -ai386 -qDEB_HOST_MULTIARCH 2>/dev/null)"
MULTIARCH_ERR=$?
if [ $MULTIARCH_ERR -eq 0 ]; then
    echo 'Multi-arch support detected.'
    MULTIARCH_GL_DRIVERS="/usr/lib/${I386_MULTIARCH}/dri"
    export LIBGL_DRIVERS_PATH="${LIBGL_DRIVERS_PATH}:${MULTIARCH_GL_DRIVERS}:/usr/lib64/dri:/usr/lib32/dri:/usr/lib/dri"
else
    export LIBGL_DRIVERS_PATH="${LIBGL_DRIVERS_PATH}:/usr/lib64/dri:/usr/lib32/dri:/usr/lib/dri"
fi

## - The 'scim' GTK IM module widely crashes the viewer.  Avoid it.
if [ "$GTK_IM_MODULE" = "scim" ]; then
    export GTK_IM_MODULE=xim
fi

 

 

 

 

If I remeber  before was  something like  run  and was working fine  . Now  I can't install this.

Share this post


Link to post
Share on other sites

For some reason you seem to have changed the default action from "Run" to "open with whatever text editor". The "secondlife" file is an executable.

Since I don't use Ubuntu I'll have to leave this one to someone familiar with Gnome/Unity/Whatever.

Share this post


Link to post
Share on other sites

was only save file and open  

for  this file was  not any  run 

I wish   could  be some run  like  in last  version  when I use  but  it is  like this with  secondlife and phoenix  .

Tnx 

I hope someone can help me  with this

Share this post


Link to post
Share on other sites

That can't be. Are you doing these steps EXACTLY as written? And I mean TO THE LETTER, EXACTLY as written? Here's the step-by-step for KDE, it should be pretty much the same in Gnome/Unity or whatever DE you use.

  1. Go to https://secondlife.com/support/downloads/ and click on the big "Download the SL Viewer on Linux"
  2. SAVE the file, DO NOT OPEN IT
  3. Go to the location where the file was saved. Usually that's the "Downloads" folder.
  4. Right-click on the file, choose Extract->Extract Archive Here, Autodetect Subfolder (takes a moment to complete)
  5. Look for a newly created folder called "SecondLife-i686-3.5.2.276129" (as of today that's the current viewer) and open that folder
  6. Double-click on the file secondlife

If that opens a text file, you haven't followed these steps. If nothing happens you're likely missing some dependencies.

To figure out which dependencies are missing, right-click somewhere in the folder where Second Life got extracted and choose Actions->Open Terminal Here

In the black terminal window, execute the following command and paste the output here in this thread:

./secondlife

Share this post


Link to post
Share on other sites

yes , I did Exactly  same what you post before .

click on secondlife  but  was no action ..

open terminal and got this :

sylwia@sylwia-Aspire-5551 ~/Downloads/SecondLife-i686-3.5.2.276129 $ ./secondlife
64-bit Linux detected.
Running from /home/sylwia/Downloads/SecondLife-i686-3.5.2.276129
 - Installing menu entries in /home/sylwia/.local/share/applications
./secondlife: line 154: bin/do-not-directly-run-secondlife-bin: No such file or directory
*** Bad shutdown ($LL_RUN_ERR). ***

You are running the Second Life Viewer on a x86_64 platform.  The
most common problems when launching the Viewer (particularly
'bin/do-not-directly-run-secondlife-bin: not found' and 'error while
loading shared libraries') may be solved by installing your Linux
distribution's 32-bit compatibility packages.
For example, on Ubuntu and other Debian-based Linuxes you might run:
$ sudo apt-get install ia32-libs ia32-libs-gtk ia32-libs-kde ia32-libs-sdl

*******************************************************
This is a BETA release of the Second Life linux client.
Thank you for testing!
Please see README-linux.txt before reporting problems.

 

 

Share this post


Link to post
Share on other sites

Okay, that is definitely different than opening the file...

./secondlife: line 154: bin/do-not-directly-run-secondlife-bin: No such file or directory

That error message indicates that you either got a corrupted download or a borked archive extraction. Let's just go back to the beginning... Open a terminal window (anywhere), and execute the following commands, in order. This should hopefully get you going regardless of what else is going on. It's way more complicated than it needs to be, but it should cover most bases.

# This next command will ask for your password to install wget and the 32bit libraries needed for SL.
# Beware, this might take a while if the 32bit libraries aren't already installed.
sudo apt-get install wget ia32-libs-multiarch

# This command is just to make sure we're in your home directory and not somewhere else on the file system
cd ~

# Make sure we have a clean environment
rm -r SecondLife-i686-3.5.2.276129
rm SecondLife-i686-3.5.2.276129.tar.bz2

# Fetch the archive from LLs servers
wget http://download.cloud.secondlife.com/Viewer-3/SecondLife-i686-3.5.2.276129.tar.bz2

# Extract the archive (might take a moment)
tar xfj SecondLife-i686-3.5.2.276129.tar.bz2

# Try to launch it
cd SecondLife-i686-3.5.2.276129
./secondlife

Let's see where that gets you.

 

Share this post


Link to post
Share on other sites

so after  this  command   (sudo apt-get install wget ia32-libs-multiarch ) I got this :

sudo apt-get install wget ia32-libs-multiarch
[sudo] password for sylwia:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
wget is already the newest version.
ia32-libs-multiarch:i386 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 400 not upgraded.
1 not fully installed or removed.
Need to get 0 B/9,126 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? y
dpkg: error processing libreoffice-writer (--configure):
 package libreoffice-writer is not ready for configuration
 cannot configure (current status `half-installed')
Errors were encountered while processing:
 libreoffice-writer
E: Sub-process /usr/bin/dpkg returned an error code (1)

Share this post


Link to post
Share on other sites

and  again I back to same point ... 

64-bit Linux detected.
Running from /home/sylwia/SecondLife-i686-3.5.2.276129
 - Installing menu entries in /home/sylwia/.local/share/applications
./secondlife: line 154: bin/do-not-directly-run-secondlife-bin: No such file or directory
*** Bad shutdown ($LL_RUN_ERR). ***

You are running the Second Life Viewer on a x86_64 platform.  The
most common problems when launching the Viewer (particularly
'bin/do-not-directly-run-secondlife-bin: not found' and 'error while
loading shared libraries') may be solved by installing your Linux
distribution's 32-bit compatibility packages.
For example, on Ubuntu and other Debian-based Linuxes you might run:
$ sudo apt-get install ia32-libs ia32-libs-gtk ia32-libs-kde ia32-libs-sdl

Share this post


Link to post
Share on other sites

Do you get similar  errors when using 3rd party viewers

Where did you extract the downloaded viewer archive to?

Did you run the unnecessary 'installer'?

J.

Share this post


Link to post
Share on other sites

yes, same errors was with  other viewers

was extracted to  download folder

,,Did you run the unnecessary 'installer'? -  I did what?  I just  trying  from 3 days  install this Exactly like was  in other post .

now go back to   13.04 because in other was not working  and   in some  ubuntu like 9.04 or 10.04   was not even wifi

prefer to do this on ubuntu 13.04 if is   some way to do this

thank you

 

 

 

i give up

:(

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...