Jump to content

Questions (and now some answers) exporting 3ds max rig


Kwakkelde Kwak
 Share

You are about to reply to a thread that has been inactive for 2777 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Very strange, mathematically that doesn't add up at all...glad you got it working though....

Can you tell us what SL gives you for the dimensions? Utilities (the hammer on the right) -> Measure.

Can you also say how you have your units conversion set up in the dae exporter?

Link to comment
Share on other sites

for the default fem av lower body mesh, dimensions in the Utilities:

x=36.37m y=34.91m z=115.129m

FBX Exporter (Version 2011.3.1):

Include:

   Geometry:

         Split per vertex normals - off

         Convert deforming dummies to bones - on

   Animation: on
         Remove single key - off

         Bake animation - off

         Deformations on, Skins on, Morphs on.

   Cameras on; Lights on

Advanced Options:

   Units >> Scale Factor: Automatic on (scene units converted to: Meters greyed out)

   Axis Convertion >> Up axis: Z-up

   Collada: Triangulate on; Single matrix on

Which are all default settings. The only thing i changed was Up Axis: Z-up (i did as the manual says).

Link to comment
Share on other sites

Yes that all seems to be in order, both the dimensions (which would be lifesize had you set the display units to cm) and the exporter (exact same settings I use).

The scale set to 100.000 in my posts seems to be an issue with cm-m..how obvious. Still weird since the dae exporter should convert it.

Anyway, if I do exactly what you did, my model is 10 times too small. If I set my system units to meters, I can use the SLAv script with 1.0, aswell as the SL importer. I really have no idea why you are off by a factor 10. If you by any chance figure it out, please post it...

Link to comment
Share on other sites

Elvina, you only tick off the skin weights when uploading to SL right? Not Joint positions? The mesh should snap to your avi if you do it correctly.

 

My workflow which works for now:

-New max scene with system Unit and viewport Units set to meters.

-Run script - select the 2012.mse one

-Select Avatar, set scale to 1 meter

-create - load

-I dont rescale anything myself right now, but you can of course scale your avatar up like stated before.

-build whatever you want as edit poly

-skin wrap it and select the upperbody mesh and lower body mesh as base (easiest way to quickly skin something like clothing)

-convert skin wrap to skin and adjust vertex weights by hand where needed.

-hide everything except for skinned object and bones

-export selected to .dae using fbx plugin for 3ds max (use standard settings but make sure to include animation-morphs-etc)

-import selecting skin weights but not include joint positions

-wear the item

 

More or less this, it did take me quite a while to get everything figured out as well but now it seems to work fine.

 

  • Like 1
Link to comment
Share on other sites

More or less how we all do it, but the correct joints can be vital. Not for clothing, but it is when you want an alternative avatar.

Since you don't scale your model up in 3ds max, don't you have the camera clipping issue since the model is so small?

Thanks for contributing btw, a lot of max users including myself are having or have been having these scale issues with the SLAV script.

Link to comment
Share on other sites


Hoaghes Beaumont wrote:

Elvina, you only tick off the skin weights when uploading to SL right? Not Joint positions? The mesh should snap to your avi if you do it correctly.

yes i do tick them both, skin weights AND joint positions. I tried a few times ticking only skin weights and not ticking Joint positions, and the mesh came out all squashed. It didn't snap to the avi. With Joint position ticked it does snap, however.

 


My workflow which works for now:

-New max scene with system Unit and viewport Units set to meters.

-Run script - select the 2012.mse one

-Select Avatar, set scale to 1 meter

-create - load

-I dont rescale anything myself right now, but you can of course scale your avatar up like stated before.

-build whatever you want as edit poly

-skin wrap it and select the upperbody mesh and lower body mesh as base (easiest way to quickly skin something like clothing)

-convert skin wrap to skin and adjust vertex weights by hand where needed.

OMG!!! :matte-motes-shocked: it's that simple?!?! never knew about Skin Wrap, i've been using Skin all along, doing hours of rigging by hand when this little trick does it in seconds! :matte-motes-shocked: Thank you thank you!!, i'm going to play with this and re-rig my mesh! :D

Link to comment
Share on other sites

  • 2 weeks later...


Kwakkelde Kwak wrote:

 

Anyway, if I do exactly what you did, my model is 10 times too small. If I set my system units to meters, I can use the SLAv script with 1.0, aswell as the SL importer. I really have no idea why you are off by a factor 10. If you by any chance figure it out, please post it...

now i know what it was! Every time when i used the free SLAV plugin demo i got this error message:

Unhandled exception has occured in a component in your application. If you

click Continue, the application will ignore this error and attempt to

continue. Input string was not in a correct format.

I naturally assumed it was just the license error, normal for a demo.

Then i went ahead and bought the full version of SLAV plugin on the Marketplace. When i got the license key, it still didn't work, i got the same error message. I asked Wiz (the creator) for support and he had suggested to change my decimal symbol in Windows. I did and now everything works like a charm! It seems that my decimal symbol in Windows was set to "," and i had to change it to "." The factor 10 difference that i had at first is now gone and i can work with SLAV plugin on scale 1.

I use cm / cm system units in Max and I scale the bones to 10000% like Kwakkelde suggested, and then i build my model around it. Then i don't apply any XForm and don't scale the final rigged mesh. When i upload it to SL i only tick Skin weights, and don't tick Joints positions, as Hoaghes suggested, and upload on 1.0 scale. The result is: mesh that fits my normal shape and looks exactly the same size when rezzed on the ground. ^^ Woohoo! :smileyvery-happy: Huge thanks to all of you guys! ♥

Link to comment
Share on other sites

Ok I have been reading none stop for three days, and I'm sure there is something i'm still missing and my eyes hurt from reading in this forum.

 

Now... After following this thread I managed to have the rigid mesh finally to a decent size to my avatar, however now .. it looks deformed.

 

Scaled the SLAV to 1 i did however try with the model skirt to see if its the model I made that was the problem but no... even when I uploaded the model skirt it was deformed in SL.

a little help please? lol my brain is farting alot now.

Link to comment
Share on other sites

Is there a way to move the shoulders and arms inwards?

You will notice in SL, if you move the shape slider shoulder width down from 50%, it also scales the chest inwards deforming it.

The max slav skeleton is at 50% shoulder width which is WAY too wide and broad for a female, i want the shoulder width at about 15% in SL. But if i scale it down to 15%, the breasts and chest are squeezed inwards and look really long, even if the chest/breasts are weighted 100% to the mChest bone.

Link to comment
Share on other sites


Jarmade Spires wrote:

 

The max slav skeleton is at 50% shoulder width which is WAY too wide and broad for a female, i want the shoulder width at about 15% in SL. But if i scale it down to 15%, the breasts and chest are squeezed inwards and look really long, even if the chest/breasts are weighted 100% to the mChest bone.

You could scale the skeleton, but an easier way would be to get the commercial SLAv version and download an avatar that works better in SL....Maybe there's another default avatar that will fit your inworld av better. You can select various shapes in even the free SLAv.

btw...15% in max isn't the same as in SL ofcourse. In SL 0% is a lot wider than 0.

Link to comment
Share on other sites

Please write up a tutorial. I used the wiz daxter model and had the same problem (with huge sizes) it was flying like a kite in the sky, nearly the size of half a sim lol. 

 

I would REALLY appreciate a tutorial as Im on the verge of switching to blender for this... I dont want to betray good ol max so please please a tutorial would be AMAZING.

Link to comment
Share on other sites

  • 4 months later...

Hi.

I've read through the posts and found your workflow a bit easy to follow. But I think I am messing up something. I've been able to do everything up to 'hide everything except for skinned objects and bones'.

So after that I export it to FBX right?
When I do I am getting this error but its exporting.

"The plug-in does not retain the orientation of Diagonals on Editable Poly objects. This could have an impact on modified UV coordinates. Refer to the Online Help for more information. The following objects are affected:

-Cylinder001"

Any idea what I am doing wrong?

And thanks everyone for some 3dsMax help, finally!

-Zythal

 

Even though I get an error. I am able to upload the cylinder mesh to SL. Funny thing is, after I wear, it attaches to my avatars right arm. In 3DS Max the avatar is inside the cylinder, so it should be wrapped around me right?

I know I'm getting something real basic wrong. Any idea to fix this?

 

Link to comment
Share on other sites

".. you check include skin waight on SL importer if you dont do this, it just attached like a normal object and dosent act as an Avatar.. "

This is the problem I am facing. Infact the 'include skin weight' tickbox is disabled. So if I cant click it, it attaches as a normal object. 

Any suggestions?

 

Link to comment
Share on other sites

Hi Kwakkelde,

Thanks for the reply. I thought you guys were gone, since the post is old.

I was converting to FBX using 3DS Max and then using the standalone Autodesk FBX Converter 2011.3.1 to convert the FBX to Collada.

Now I am using something called OpenCollada which exports Collada files directly from 3DS Max.

I think my problem is that, somewhere along my skinning info is getting lost.

So let me state the workflow from that point..

1. Apply SkinWrap Modifier to the cylinder
2. Add UpperBody and LowerBody
3.Convert to Skin
4.Hide everything else but Cylinder and bones
5.Select Cylinder Mesh and bones
5.Export Selection to Collada (Untick Animation, Change axis to Z-up)

And this is what I get:

Untitled-1.jpg

I will try some more and also try to figure out what I am doing wrong. 

 

Cheers,
Zythal

 

 

 

Link to comment
Share on other sites

Yay, ur a genius. I actually thought this method didn't require it. But Im lost when I opened the DAE file in notepad. I can't find <Name_array id="DefaultClothingItemController-Joints-array" count="26">. 

But thanks. Now I know what needs to be done. although the file is all jargon to me, I will go through it and edit that.

EDIT: Found it. Mine actually says "<Name_array id="Cylinder001Controller-Joints-array" count="9">. I changed that to 26.

the bones i have are

mHipLeft mPelvis mHipRight mTorso mChest mCollarLeft mShoulderLeft
mCollarRight mShoulderRight

I dont need to change those right?

Link to comment
Share on other sites

You most certainly do not want to change those. You need to add the missing bones after the ones you mentioned, or the wrong bones will be assigned to your skin.

The bones are:

mHipRight mKneeRight mAnkleRight mFootRight mToeRight mHipLeft mKneeLeft mAnkleLeft mFootLeft mToeLeft mPelvis mTorso mChest mNeck mHead mSkull mEyeRight mEyeLeft mCollarLeft mShoulderLeft mElbowLeft mWristLeft mCollarRight mShoulderRight mElbowRight mWristRight

From what I read in a very recent post, you can add the entire list after the bones already in the file, doubles apparantly don't give issues. I didn't test this for myself though.

 

I forgot to say, as far as I know, OpenCollada gives all kinds of errors between 3ds Max and SL. It won't export the uv maps correctly. I've heard the 2012 version of 3ds max gave issues with the autodesk exporter, but I am 100% sure it works for 2010 and 2013.

You can find the exporter here:

Autodesk FBX plugin

Link to comment
Share on other sites

So the first thing I should do is download the new FBX plugin and make fbx file from that and use standalone converter to make the Collada file?

EDIT: Exported FBX from the updated plugin (FBX Plugin) . Converted to Collada using Autodest FBX Converter 2011.3.1
Edited the number of bones to 26 and added the missing bones.

This is what I get now:

2.jpg

But still, when I press Wear, it doesnt look as its shown in this pic. The cylinder looks as if an attached object, not part of the avatar.

Link to comment
Share on other sites

The name "FBX converter"  is a bit confusing. It also exports directly to DAE.

If you aren't using 3ds Max 2012, the best thing to do is to download and install the plugin yes, then export to DAE.

If you are using 2012, I think you still need to do it, but in 2012 you should export to FBX, then convert the FBX file with the stanalone converter you already have.

I have no experience with the 2012 version, so I'm just repeating what others encountered. The UV mapping issue with the OpenCollada exporter I have experienced first hand. It nearly drove me mad :)

Link to comment
Share on other sites

Well at least you're a bit closer to your goal.

Strange though, does the object move with the bones in 3ds max?

If you use 2011, the FBX exporter should create the exact same files the standalone converter does, that's 2011 aswell afterall. You can skip that entire step and exort as DAE.

Link to comment
Share on other sites

Yes. Its rigged in 3dsmax. Moves perfectly.

3.jpg

EDIT: Created new DAE file. this time directly from 3ds Max 2011 using the new plugin. Edited the bones. Im still getting the same results as the screenshot I pasted before.

Anyways, I will go through everything all over again and see where Im going wrong. Yeah... very near to the goal!! Thanks to you. :)

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 2777 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...