Jump to content
Sign in to follow this  
Crissi Yoshikawa

IS THE MARKETPLACE BROKEN AND GIVING AWAY PRODUCTS FOR FREE?

Recommended Posts

I have now received two notices that my products have been delivered by my magic box and both orders show on my mareketplace transaction history as Undelivered and Not Paid.  There are no payments recorded on my SL account Transaction History so I have not been paid for either of them, One delivery is 12 hours old.  That's now 2 out of 2 orders that have been delivered without being paid for today.  Its the first time it ever happened to me much less twice in one day.  WTH?

Looking at my web SL Transaction history, there is a notice that transactions are delayed by xx minutes.  It goes up every time I look.  First it was 15 minutes, then 25 then 32 minutes and now 34 minutes.  I have not seen anything like it in my nearly 5 years on SL. Of course there is nothing on the network status blog.  Everything is just hunky dory as far as LL is concerned while our items are given away.

WHAT IS GOING ON??? Is anyone else seeing this too?

Share this post


Link to post
Share on other sites

I don't know if it is happening or not because I can't compare every MP transaction with my transaction page.

 

I do know I have had 14,000L in failed deliveries the last 24 hours. One of those tried a second time and that order failed. The rest never tried to repurchase but I contacted them with a LM -- in my experience they have already bought something else and those were just lost sales.

Share this post


Link to post
Share on other sites

I recently bought a pair of shoes on the marketplace and the delivery was delayed for some time. Eventually the product was delivered but no money was taken for the sale. Yes, i think the marketplace is broken.

My sales are at almost zero now that we no longer have Xstreets, where I got brisk sales. I don't know why.

 

Julie

Share this post


Link to post
Share on other sites

I hope you all who are not getting paid will start a JIRA and file a ticket to make sure the Commerce team is aware.

Share this post


Link to post
Share on other sites

Julie, thanks for confirming from a buyers view what I am seeing as a seller today-items are being bought and delivered and no payments are being credited at all.  

I have now three products delivered since SL midnight and no payments credited at all.  I'm out almost 2,000L so far today. And i have irrefutable confirmation that the products were delivered and rezzed despite the status of the MP saying they were not delivered and therefore not paid.

I'm sure if it was LL's money being lost they would be all over it.

Share this post


Link to post
Share on other sites

I found one of those while doing my spreadsheets yesterday, from the 8th of January. Interestingly the status was "Undelivered" not "delivery failed" - which status did others have, out of interest? I know it was received because I got the rez notice in email.

Btw anyone who wants - I made this script available for free a while back - it tells you when purchases are rezzed:

https://marketplace.secondlife.com/p/ArtiZan-Business-Script-IM-Creator-on-Rez-notifies-when-products-are-unpacked/3061369

Oh and "partially failed" means it was in a cart where something failed, not necessarily yours - if you click on the transaction you'll often see that your own stuff says "delivered". Yes, a bit silly.

Share this post


Link to post
Share on other sites

Hi Zanara, every single one of mine is doing exactly the same thing.  It says BEING DELIVERED for about an hour then goes to DELIVERY PARTIALLY FAILED.  They are all one item purchases so there does not appear to have been anything else in the cart-just the one item.  And they all say NOT PAID under payment status.  The order summary says DELIVERY FAILED and NOT PAID.

 I talked to one of the buyers and they said they were charged initially then refunded for failed delivery.  But they were definitely all delivered.  I have a registration script in  my products too that emails me on first rezz.  I also got the magic box messages saying the items were all delivered.

I have tried updating my magic boxes to the latest though, just in case its causing MP to think the delivery failed somehow although I have never had these problems before.  Who knows why things just seem  to happen in the MP.

 Wondering if my sim could be a cause-chat lag has been randomly horrible on it recently (like 10 seconds delay randomly)  though the sim stats look fine.  Lots of free frame time and .998 Time Dilation all  the time.  That's what we get for being on a guinea pig server version though we pay the same tier as everyone else.  Its not like we volunteered to be an RC channel. Sheesh.

Share this post


Link to post
Share on other sites

Thanks Zanara -- I just decided today to start adding a script like this to my marketplace transfer sets (though it will mean about 100 hours of work), but now I think I better add it to copy sets too, since that is the only way I can tell if some things get delivered at all, since we have had other reports that people receive no notifications at all and no payments for things customers by some fluke report as having been delivered (otherwise we would never have found out -- and none of us has a clue how often that scenario might occur).  The Markeplace gets away with this because monitoring payments against transactions is just too time consuming.  It is probably cheaper just to lose sales than spend that amount of time.

Really sucks tho.

 

Oh, and watch this thread disappear since it is reporting a "technical problem".

Share this post


Link to post
Share on other sites

What can happen though is that there might be only one of your items in a cart, but the buyer has things from other merchants in the same cart, and one of those fails. The only time you see that it was a shared cart is when you get the "partially failed" notice, but your own purchase went through OK.

Makes me wonder if sometimes it's reporting a failure for another item in cart, and that gets mixed up with yours, although plenty of the "partially failed" items are paid correctly too. Or just fails to report back correctly that it delivered - there are known box-web communication issues in general.

IIRC magic boxes still use XML-RPC for comms which is officially deprecated, so anything can be happening: http://wiki.secondlife.com/wiki/Category:LSL_XML-RPC

"XML-RPC requests often time-out due to the front-end server being overloaded. LL has continued to upgrade the server hardware periodically, but it has remained unreliable. LL developers have advised that the XML-RPC design isn't scalable (due to the single server bottle-neck) and that the service is "deprecated". They suggest using LSL HTTP as an alternative. If an XML-RPC request does time-out the script's remote_data event may or may not be triggered (and any script response is lost). See this blog entry for more about the future of XML-RPC."

Share this post


Link to post
Share on other sites

oh Crissi - I jsut saw that you said you recently updated boxes. If you haven't already, go to the box status page (link from merchant home that takes you to old xstreet) and delete any old boxes there. It takes the web days to delete them and until then it still tries to deliver from them.

Share this post


Link to post
Share on other sites

Thank You Zanara!, I have just deleted the old magic boxes from the list there.  I didn't even know that list of magic boxes was hidden back there on the XStreet page. PHEWW Could it be any more hidden?  That is rea[ly good to know! TY!

I see what you mean about magic box box communications possibly being behind the delivery/payment problems.  Seems that communication was done on a wing and a prayer and the prayers have stopped working.

Share this post


Link to post
Share on other sites

Back last year while in-world I got a product delivery IM from the box, but no payment was received and no transaction posted. As the item was expensive I filed a support ticket. The very next business day I received an email from Dacota Linden as follows:

If there is no corresponding Sales Order History Entry or Sales Transaction Entry for the product and you did not receive an email notification that there was a sale of your product then the delivery was from a Re-delivery of the product.

This means that one of your buyers submitted a Support Case to Linden Lab as a Failed Marketplace Delivery.

The order would be verified and the product re-delivered to the buyer in world upon verification of the order.

That indeed proved to be the case.

Share this post


Link to post
Share on other sites

Hi Ela, thanks for that but this is definitely not what happened here.  I have had a few of those LL redeliveries in the past too but these deliveries correspond directly to failed marketplace transactions occurying simultaneously and were confirmed delivered to the buyer in those "failed" transactions by my on rez registration scripts in the products and by corresponding simultaneous magic box emails.  

It appears that the marketplace believes the magic box deliveries failed even though they didn't and refunded the buyers even though the products were actually delivered to the buyer.  Its beginning to sound like it may be caused by failures in the magic box delivery server as Zanara suggested in her reply where it somehow doesn't get or doesn't process the message that the magic box has made its delivery and so the money should be paid to the seller so it assumed that no delivery occured and gives a refund to the buyer.  One of the buyers I talked to confirmed that she got the product and got a refund from LL saying it hadn't been delivered.  I actullay went to her place and helped her set it up.  She bought it and it was definitely delivered and she had received a refund so had not actually paid for it.  She was honest enough to pay me on the spot. but I have three others to track down... so far today anyway.

Share this post


Link to post
Share on other sites

still freaky how several merchants here post about so many MP Magicbox delivery horror stories.... high frequency of delivery failures, and now this problem.....

and yet for me to get a delivery failure is extremely rare.... I just looked at my sales history since Jan 1, 2012.

>  I had 3 order with a status of Partial Delivery Failure.

>  All 3 were shopping cart fails and not of my product in the cart and I was paid for my product in those orders

>  That was 3 failures (which were not really fails for me) of about 135 sales.

>  100% delivered for me & only 2% where my product was part of an order that failed (although not mine)

>  I have 1 magicbox (with v3.0.11 code) in my store on what is generally known to be a laggy mainland sim.

>  My magicbox has all my MP products in it which is about 60 items

 

So maybe those that have major problems have far greater daily sales that stresses the magicbox out or far more in your magicboxes.  Dont know... but its weird how some have no probs and some have tons of probs.

Share this post


Link to post
Share on other sites

I buy a lot of stuff on the Marketplace, rarely shop inworld because I don't have the patience for all the rezzing in shops, etc... Delivery failures from all this shopping are very rare for me, perhaps i have not gotten 3 items in more than a year. Some are delayed, but generally i am satisfied with deliveries.

I do wish I could report of deliveries with my items for sale, but as I have said before, the Markeplace has reduced my sales to zero.

Julie

Share this post


Link to post
Share on other sites

I do think that for the most part MP deliveries are good but I dont want to dismiss that there seems to be a root cause situation that seems to cause a lot of delievery grief for some merchants. 

I also know that in the pas few weeks (not sure about last week) one of my friends in SL who is only a shoppper in MP (not a merchant) told me that her shopping experience has been horrid.  She generally shops in the midnight to 4am timeframes and almost all her orders have completely failed or were an hour late.  Her impression of MP shopping of late has been - "I'm lucky if I get my orders now from MP".

So I believe there is something wrong.... I just dont know why my configuration as a merchant of MP seems to completely avoid these delevery failures.  I do get the delivery delays during the witching hours like most do but those are not failures.

Finding root cause of a problem involves problem isolation.  I am a huge fan of the Kepner Tregoe Problem Analysis methods.  A key to this method is to clearly prove the aspects of what the problem is vs is not.  Then throw theories against these IS / IS NOTS.

i.e.

>  if it IS the version of Magicbox code then why are merchants with my version of code having delivery probs?

>  if its because a magicbox is on a laggy sim... then why does it not happen on my laggy mainland sim?

>  if its because a merchant only has 1 magicbox.... then why do I have no problems with only 1 magicbox?

These are the things that need to be analyzed... compare merchants with problems to situations of merchants that are having no problems.

Share this post


Link to post
Share on other sites


Ann Otoole wrote:

I wonder if their magic boxes are on homestead sims or on regions that always have over 25 avis on them.

this is a good theory and one that could be assessed against IS / IS NOTS... 

The problem is that there currently is no clear list of IS's and IS NOTs.  People are mostly trying to figure out the root cause to the problem by looking at the symptoms experienced by those with problems.  A list of the configurations of those with no problems needs to be added to the list so the problem can be isolated.

Your thoery has some promise because I am a healthy deliveris merchant and my magicbox is not on a homestead and from what I see, the sim I am on rarely has 25+ avis on it.... soo...

Share this post


Link to post
Share on other sites

I am one that has tons of problem for a while then for no discernable reason, none for a while. With no changes on my part. A mystery.

Share this post


Link to post
Share on other sites

To add some facts to my situation, I have a similar situation to ToySoldier.  I am on a mainland sim that I own 80% of.  There is only one other resident (who happens to love highly animated animals and has 3 or 4 of them: dogs and big cats and such--ARGGGGG! They are script lag monsters from what I see on the events per second stat often being over 1,000EPS) and a linden highway and railroad runs through it.  There are rarely more than 3 or 4 people in the sim, usually 0-2 people.  Its a very quiet sim  Up to now, my delivery failures have been very minimal, maybe 10 failed deliveries a year out of roughly 1,000 + yearly deliveries.  The exception is multi-item cart sales. I would say every single one of those fails to deliver at least one item in the cart.  I would estimate that 1 out of 10 multi item cart sales fully worked.  Not exactly a good record.

 My sim TD is pretty much always 0,998 though occasionally dips to 0.97 or so, and almost never below that. Having said that, the last couple of months have had pretty awful random chat lag and edit lag.  Chat lag can go from none to 5-10 seconds randomly during the day with no discernable trigger cause.  Also edit lag has been randomly horrible too in the same period, with rezz/delete/edit functions sometimes taking up to a minute and sometimes failing completely saying I don't have permissions on a full perm object/NC or rezz of an object has failed.  But as I said this has been going on the last few months with no visible effect on SLM deliveries.  Sure would like to get to the bottom of that issue but no luck so far and LL has been of little to no help.  Everything in the sim is fine as far as they are concerned.

It is a LeTigre RC sim so there are weekly restarts with new guinea pig server software. (BTW, what did I do to deserve being a server software guinea pig?  I pay the same tier as everyone else. What would happen if a bank tried that with their customers doing forced online software testing??) Anyway, I digress.  Getting upset is pointless, they do what they do-we have to live with it such as it is.

My magic boxes, of which I have two, both with all 60 or so of my products in them are in my sim.  Up to yesterday I had not updated the magic boxes themselves for quite a long time since I had no significant problems.  They were running the 3.0.2 version of scripts so were pretty old but working fine.  

Starting just past midnight Saturday morning SL I had my first order on SLM-the magic box announced delivery by email, no sales email ever came.  I checked the MP Transaction Log first thing in the morning and the order was listed with Partial Delivery Failure showing as the  status.  The order detail said Not Delivered, Not Paid.  Meanwhile I had a registration email from the product itself showing it had been rezzed by that same buyer.  Clearly it was delivered.  This same exact thing repeated for all four orders on Saturday. I was not paid for any of them. At the end of the day I replaced both magic boxes with the latest 3.0.11 version.  I talked to one buyer who said she had the funds debited and then refunded with a message that delivery had failed.  She insisted she pay me on the spot for it once she knew what had happened.  I will refund her if LL ever owns up and pays me the $2400L they owe me.  I still have to contact the other 3.  What a PITA.  Have not had any MP orders yet today so I don't know yet if the magic box change has had any effect. We'll see soon.

Clearly something changed to trigger this behavior.  The change from previously  functioning well to yesterday's DOA was clear and absolute.  Every single one of the four sales did the exact same thing and they were all single item sales.  The trigger for the problem is not obvious at all.  I posted to see if it was me or others were seeing the same dramatic change.  It seems to be something on  my sim/magic box end from what I'm hearing as others have not had the same results.

Share this post


Link to post
Share on other sites

UPDATE: Just got my first two MP orders of the day with the new 3.0.11 magic boxes.  Both worked perfectly-delivered and paid within a minute ot two.  Both were single item orders.  It seems wise based on this for everyone to make sure they have the 3.0.11 magic boxes set up just in case it was that, but who knows really.  It could have nothing to do with it.  Maybe killing a chicken or doing nothing would have the same result.  Logic rarely applies here.

Share this post


Link to post
Share on other sites

I have a feeling that, just like search results, the delivery failures are cyclical and naturally the more goods I shift the greater the chance of a delivery failure. Maybe they even have an algorithm designed to share the pain :-). In general  I don't have too many of that kind of problem but when  I do it comes in clusters and  short of spending the next  six months adding  a script like Zanara has to confirm rezzing of bought items it's impossible to verify if it really is an LL issue or as I have found, one where the goods are accidently dismissed by the buyer who then claims they were never delivered.

I just take all requests  for redelivery at face value as it's too time consuming to drill down and investigate. The  one  pattern I have observed is that  customers sending an item as a gift from a shopping cart that has multiple items from other merchants in it is almost certain to  end up with a belly flop.Then  again I often get  requests for redeliveries for items I don't sell - again this comes back to the multiple merchant aspect of  the shopping cart.

Personally when buying I have only ever failed to get the goods once in 2 years. But then I only ever buy one item at a time and have never used the gift function (I much prefer to hand over a gift personally rather than leaving to a third party auto function)

The shopping cart is the problem - it's borked and it doesn't like dealing with multiple merchants. I have a sneaky feeling that is one problem that Direct Delivery will not solve. Which could be why the much hyped launch is now running late.

^L^

 

 

Share this post


Link to post
Share on other sites


Crissi Yoshikawa wrote:

UPDATE: Just got my first two MP orders of the day with the new 3.0.11 magic boxes.  Both worked perfectly-delivered and paid within a minute ot two.  Both were single item orders.  It seems wise based on this for everyone to make sure they have the 3.0.11 magic boxed set up just in case it was that, but who knows really.  It could have nothing to do with it.  Maybe killing a chicken or doing nothing would have the same result.  Logic rarely applies here.

Great! 

 

So you are not mad at Zanara for telling you about the boxes?

Share this post


Link to post
Share on other sites

I did thank Zanara for her help, but thanks again Zanara, and thank you too, Pamela!  Maybe together we can actually unravel a few twisted mysteries of SL with a bit of logic and some luck.  So far so good,  I have four successful orders so far today.  Not a problem in sight.  For the moment...  THANK YOU!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...