Jump to content

Solved: No audio streaming on slackware linux 64 bit


PromisingBoy
 Share

You are about to reply to a thread that has been inactive for 4524 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Hi, first post, so be gentle. ;)

I did study the streaming issues under linux 64 bit extensively, in this forum and elsewhere. The general gist is that most issues are related to missing 32 bit libraries (given the viewer and its plugins are 32 bit applications).

Indeed, when I check the log I find a lot of warnings by gstreamer plugins about missing libraries.

 

2012-01-28T11:19:29Z INFO: optionally_start_music: Starting parcel music http://secondstream.de:10001
2012-01-28T11:19:29Z INFO: start: streaming audio mMediaPlugin is now 0x185e0780
2012-01-28T11:19:29Z INFO: start: Starting internet stream: http://secondstream.de:10001
2012-01-28T11:19:29Z INFO: start: Playing stream...
 pid:1042: (media plugin) grab_gst_syms:87: Found DSO: libgstreamer-0.10.so.0
 pid:1042: (media plugin) grab_gst_syms:101: Found DSO: libgstvideo-0.10.so.0

(<unknown>:1042): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstneonhttpsrc.so': libneon.so.27: cannot open shared object file: No such file or directory

(<unknown>:1042): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstaasink.so': libaa.so.1: cannot open shared object file: No such file or directory

(<unknown>:1042): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstflac.so': libFLAC.so.8: cannot open shared object file: No such file or directory

(<unknown>:1042): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstcacasink.so': libcaca.so.0: cannot open shared object file: No such file or directory

(<unknown>:1042): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstvideo4linux.so': libgudev-1.0.so.0: cannot open shared object file: No such file or directory

(<unknown>:1042): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstvorbis.so': libvorbisenc.so.2: cannot open shared object file: No such file or directory

(<unknown>:1042): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libresindvd.so': libdvdnav.so.4: cannot open shared object file: No such file or directory

(<unknown>:1042): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstcdparanoia.so': libcdda_interface.so.0: cannot open shared object file: No such file or directory

(<unknown>:1042): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstmad.so': libmad.so.0: cannot open shared object file: No such file or directory

(<unknown>:1042): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstvideo4linux2.so': libgudev-1.0.so.0: cannot open shared object file: No such file or directory

(<unknown>:1042): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstogg.so': libogg.so.0: cannot open shared object file: No such file or directory

(<unknown>:1042): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstrsvg.so': librsvg-2.so.2: cannot open shared object file: No such file or directory

(<unknown>:1042): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgsttaglib.so': libtag.so.1: cannot open shared object file: No such file or directory

(<unknown>:1042): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstlibvisual.so': libvisual-0.4.so.0: cannot open shared object file: No such file or directory

(<unknown>:1042): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstcdio.so': libcdio.so.7: cannot open shared object file: No such file or directory

(<unknown>:1042): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgsttheora.so': libtheoraenc.so.1: cannot open shared object file: No such file or directory

(<unknown>:1042): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstwavpack.so': libwavpack.so.1: cannot open shared object file: No such file or directory

(<unknown>:1042): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstdvdread.so': libdvdread.so.4: cannot open shared object file: No such file or directory

 These don't worry me. What does worry me is the next bit:

 

2012-01-28T11:19:29Z INFO: LLPluginProcessParent::receiveMessage: message class: media_time -> version: 1.0
 pid:1042: (media plugin) receiveMessage:1209: MediaPluginGStreamer010::receiveMessage: unknown message class: media_browser
 pid:1042: (media plugin) processGSTEvents:252: GST error: A HTTP protocol source plugin is required to play this stream, but not installed.
 pid:1042: (media plugin) processGSTEvents:252: GST error: A HTTP protocol source plugin is required to play this stream, but not installed.

Does anybody have an idea what HTTP source plugin we are talking about and how I might install it? 

Thanks

 

Link to comment
Share on other sites

Thx. I built and installed the 32 and 64 bit version of libsoup but unfortunately it had no effect.

Btw, a couple of solutions or workarounds have been proposed in the meantime:

(a)  use and special configuration of some application called phoenix. however, thre seems to be no ready-made package nor a build script for my distro.

(b) executing the following in a shell prior to starting the viewer. Nowever, it doesn't go with the other sound output and even seems to block it:

tail -f ~/.xsession-errors|gawk '/Starting internet stream:/ {system("mplayer -volume 20 "$7" & ")}'

 so i really would like to solve the primary issue.

Link to comment
Share on other sites

Update: I made a Slackware package for the Firestorm Viewer. I then installed the package and started the Firestorm Viewer. I found I had to disable OpenAl and the sound was much better, including streaming audio!!

Alas, the video performance was even worse than the SecondLife Viewer, so I went back to that one, this time with OpenAl disabled. And lo and behold, streaming sound was working!!!

I had tried it before, but since then installed an uncountable numer of 32 bit libs.

So I guess the case is closed.

 

edit: in case someone is wondering how to do it, you open the file /opt/SecondLife/secondlife or /opt/firestorm/firestorm in a text editor and uncomment the line

export LL_BAD_OPENAL_DRIVER=x

 

edit2: this solved the issue for SL viewer 3.2 and Firestorm 3.2. Unfortunately, it did not suffice for Firestorm 3.3. Sigh. Still investigating.

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 4524 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...