Jump to content

Help Why isn't this Alpha Texture Displaying RIght?


You are about to reply to a thread that has been inactive for 4045 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Ok I'ma try to explain this the best I can and I'll include snapshots to show what I mean.

I have a shadow texture I created to use with my piercings.  I have it and another one which is used for the bar and the ball.  Well, these have always looked right meaning they looked trasparent and faded out at the sides.  Suddenly after my computer had to be resinstalled to factory settings, when I view these textures in world, they are solid with no transparency. 

This is what I see when I look at them:

IncorrectShadow.jpg

However, when anyone else looks at them, they see this (which is how it should look):

CorrectShadow.jpg

So I have a problem here because even if everyone else sees them correctly, I can no longer create new ones because when I snapshot for new ads, I see the solid texture around the piercings.  

Another thing I note that I find odd is that other alpha textures in world are displaying right.  I have some old shadow textures I bought from a texture store, and I see those correctly.  I'm confused as to why the ball shadow and bar shadow I uploaded are displaying wrong for me (and it seems only me).  I even tried reuploading them to see if that would fix this issue for me, but I still see them as solid.

Does anyone have any info on why this could be?  It really doesn't make sense to me.. ;-/

Does anyone think it's possible that this is happening because I updated to the newest drivers for my graphics card?

Link to comment
Share on other sites

I have had that aswell. I think always in the coolviewer when it was first released with mesh and this week once on an older version of the RLV. With me it was my hair, different ones the two times. The first time (with coolviewer) I just decided to use another viewer, the second time it was cured after a relog. So I don't think it's your graphics driver.

It is 2 bit alpha instead of 8 bit alpha, or something like that. ( every pixel on a texture with alpha is either invisible or visible, nothing in between) There was some talk about it earlier on these forums, if I recall correctly it happens on very dark textures and in phoenix there was a switch for it... I know this doesn't solve anything, but it might put someone into the right direction.

Link to comment
Share on other sites

It gets even weirder.  I had sent this texture to my partner in world to use on her piercings too back when I first made it.  She put on her piercings and the texture looks right.  She sent me the piercings and I put them on and the textures still look right.  However when I view piercings I created with the shadow, it's still solid  So I asked her to send me the texture I sent her, but when I put it on a prim, it turned solid again.  So she created a new box and put the texture on it, and once again it was solid.  WTF?!  

Link to comment
Share on other sites


Sae Luan wrote:

OMG ok I did that suggestion just started up Firestorm instead and it worked!  However, is there a way to fix it on the main LL viewer??  I prefer the LL viewer.

The official viewer does have the option, however it's enabled by default and most TPVs based on it have it enabled by default as well. And it is a very useful feature that helps minimize the alpha sorting problem. So unless you plan on telling all of your customers to disabled it I think you might want to find a different solution.

If you make the prim 1% transparent the alpha masking won't be applied to it.

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 4045 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...