Jump to content
Sign in to follow this  
Stephan Gaudio

Problems with V3 and ATI Graphics Card

Recommended Posts

Greetings! I thought I had a pretty fast computer: AMD Phenom II X4 955 Processor, 4GB RAM and a new ATI Radeon HD 6850 graphics card. I am using the latest viewer 3.2.4.

When I got the graphics card, I used to have 40-60 FPS, but then it started getting slower and slower. Especially the driver from last summer till today made my FPS drop to almost 0, which is why I didn´t install them. Now I got the newest Catalyst driver and found out that disabling VBO in the SL hardware settings increases the performance to unbelievable fast 10 FPS. Still that is significantly lower than when I bought the card about a year ago. Am I the only one that has problems? Any tips on improving performance?

Share this post


Link to post
Share on other sites

I think the problem is with ATI cards.

It seems that  ATI cards do not have good OpenGL drivers and  SL uses OpenGL (rather than DirectX)

I recently got a ATI HD 6570 card and the FPS was horrible. 

I then came across this article

http://spressie.com/2011/10/10/second-life-computer-guide/

I had a couple of years old  nVida card (GeForce 7900 GS) lying around. I tried that and got much better FPS (nearly double of what i was getting with the newer ATI card).

So I am dicthing my HD 6570 and getting an nVidia (GTX 550 Ti)

 

 

Share this post


Link to post
Share on other sites

Thank you, that link is very helpful. I had problems with my former 2 ATI cards as well. It is clearly related to the driver. Sometimes I get a lot of speed and then with a new diver it drops to almost nothing.

Share this post


Link to post
Share on other sites

I have an ATI graphics card as well but the majority of programs and games I am on deal with ATI better than Second Life. My computer just works better with one. I wish the cards would just work with SL :S

Share this post


Link to post
Share on other sites

ATI Graphics Cards are wonky with Second Life.  I've had good and bad results with drivers and different versions of SL.

For example I currently am having issues with both the latest version of SL (3.2.4.246439) and the latest version of the ATI drivers for my video card.

I have an ATI HD5670 with ATI drivers 8.841.0.0 dated 4/5/2011.  When I installed the new version of SL I got all kinds of phantom artifacts around my avi when she moves.  So my first instinct is to upgrade my video drivers.

I update my video drivers to version 8.920.0.0 dated 11/9/2011.  All of a sudden my FPS goes to about 2.0 / sec.

Then I revert both my SL version back to 3.2.1.244864 and my drivers to 8.841.0.0 and I get back to about 15 fps at very crowded Hotlanta.

My last thought was to update my video drivers again without updating SL and I my FPS was back to two.

So what I've deduced is...

1. The new ATI drivers for my video are crap for SL use.

2. To use the latest version of Linden Labs Viewer I need to update to the latest crap drivers to remove the artifacts.

3. I'm not doing any of that and will stick with the older version of SL and graphics drivers for now.

I find it interesting that my computer works great with every 3D application I can put on it... but Second Life.  And I'm paying for this?

Share this post


Link to post
Share on other sites

I was starting to think I was the only one having this issue. I installed the latest update to sl viewer this past week and when I signed back in it was immediately obvious that something was wrong with the graphics. The texture glitches were so bad I had to stop using sl because I was becoming ill. Judging from this thread it appears there is no immediate cure. It seems like every time I update the sl viewer my experience gets worse. Is this really progress LL?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...