Jump to content
Sign in to follow this  
Azah Tabor

Shoutcast V2 not showing Song names inworld

Recommended Posts

Good Evening to you all.

Ok, I having quite a problem with this, and I thought I would call upon the great people within SL to see if anyone else has had this problem and has been able to fix it.

I have my SAM 4.9 set up to My Shoutcast V2 server. on the Server site that shows my stream, I can see what songs are playing perfectly. When I start up Winamp and connect to the address, that too shows which song is being played. yet, while inworld, the sound comes through perfectly, yet the DJ boards are unable to show any details for the song/people listening/bite rate of the stream.

it is probably something I have set wrong within Shoutcast V2, but I can not seem to locate the problem. SAM is set to the correct address as well as using the V2 settings.

The other stream I have that shows up inworld is a Linux V1 server, where this is a Windows V2 server.

If anyone could give me a little advic e, I would greatly appriciate it. Have a good day and hope to hear soon

Azah Tabor

Share this post


Link to post
Share on other sites

I'm not sure of what the settings are on your shoutcast board, never set one up, but if you look at your statistical relay configuration in SAM 4.9 there is an option there for setting your SID number, which is required for Shoutcast V2.

I suspect this has something to do with it. There is possibly a setting to match within the shoutcast board.

Share this post


Link to post
Share on other sites

Thank you for your reply to My question. I have run through the SAM system and both the statistic relay as well as the stream config are set up correctly. The song titles are being shown on the website for the stream from the Shoutcast, it is just not coming inworld to the boards.. No matter what board it is (thou, at the moment, I have been using the one Created by Lestat Productions).

###### UPDATE#######

I have noticed that, in Firestorm, when I turn the music on, the viewer says the names ov the songs as it should be.  Could this problem be down to the boards inworld only and not My Shoutcast or SAM setup?

Share this post


Link to post
Share on other sites

From what I recall most of the DJ displays used to use the info from the 7.html page provided by Shoutcast V1 to get song information,  The 7,html page no longer exists on Shoutcast V2. This in effect breaks the LSL scripting in older DJ boards unless the stream supplier is still running Shoutcast V1.

From http://wiki.winamp.com/wiki/SHOUTcast_DNAS_Server_2_XML_Reponses

In SHOUTcast DNAS v1 servers a 7.html could be accessed to get certain information about the current server instance for reporting and other usage. This is no longer provided in the SHOUTcast v2 DNAS and has been replaced by an equivalent xml response which provides some extra information via the /stats (public) or admin.cgi?mode=viewxml&page=1 (private) options.

The following shows the order of and what information was provided by the 7.html response against the xml entry name in the /stats or admin.cgi?mode=viewxml&page=1 xml response:

CURRENTLISTENERS STREAMSTATUS PEAKLISTENERS MAXLISTENERS UNIQUELISTENERS BITRATE SONGTITLE

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×