• Announcements

    • Xiola Linden

      The New Community Platform   03/21/2017

      We are still working on making adjustments and changes to the new platform. Thanks  to everyone who has been sending in feedback and filing any bugs you've encountered! 
  • 0
Sign in to follow this  
Followers 0
tisia Willis

How can i adjust windows time out limit as it is affecting SL and causing me to crash?

Question

I apologize for not being clear. Wkat i would lile to do is increase the time ou based on below if this makes sense.

 

OpenGL message “lost connection”

Answer ID 3007   |    Published 07/14/2011 08:14 AM   |    Updated 09/07/2011 10:11 AM
OpenGL message "lost connection"

I have seen this Event Log Message:

The NVIDIA OpenGL driver lost connection with the display driver due to exceeding the Windows Time-Out limit and is unable to continue.

The application must close.

 

What does it mean?

If you received this message from an application (on a pop up message or in the Event Log), the application was unable to continue rendering because the Microsoft Windows imposed time limit (TDR) was exceeded. This is normally the case when the workload sent to the Graphics Card is greater than what the graphics card can process in the normal timeout of two seconds.

You can find more information in this page:

http://msdn.microsoft.com/en-us/windows/hardware/gg487368.aspx

How can this be fixed?

Two possible solutions to try would be:

  1. Reduce the graphics workload if possible, such as rendering to a lower resolution or with less detail.
  2. Increase the timeout to allow more time to complete the really tough rendering parts. Microsoft provides the information on how to modify the Windows Registry to achieve this.

 

Share this post


Link to post
Share on other sites

25 answers to this question

  • 0

Time out limit?  As in "Screen saver"?  Right click on the PC desktop and select "Properties", then the Screen Saver tab.  You can adjust the timeout for the screen saver there.  While you have that window open, also click on the Power button.  You'll see settings there under Power Management for telling your computer how long to wait beofre turning off your monitor to save power.

Share this post


Link to post
Share on other sites
  • 0

What does it mean?

If you received this message from an application (on a pop up message or in the Event Log), the application was unable to continue rendering because the Microsoft Windows imposed time limit (TDR) was exceeded. This is normally the case when the workload sent to the Graphics Card is greater than what the graphics card can process in the normal timeout of two seconds.

You can find more information in this page:

http://msdn.microsoft.com/en-us/windows/hardware/gg487368.aspx

How can this be fixed?

Two possible solutions to try would be:

  1. Reduce the graphics workload if possible, such as rendering to a lower resolution or with less detail.

    2.  Increase the timeout to allow more time to complete the really tough rendering parts. Microsoft provides the information on how to modify the Windows Registry to achieve this.

-----------------------------------------------------------------------------------------

Reading what the "What does it mean" message telling you that too much information is being sent to your graphics card to render the scenes, I would say your best bet is to take the first option in the "How can this be fix?".  Increasing the time limit will most likely only delay your crash.  If your card or system can't keep up with the incoming information it will never get caught up until one of two things happen......the data slows sufficiently for everything to get rendered (which won't happen in SL) or the program is closed (either via a crash or you closing it).  Technically, nothing crashed on your computer.....Windows closed the application (your SL viewer) before a crash occured.  Increasing the time limit will probably cause a real crash.  And that crash will likely be your operating system and not the viewer (something that is very much less desirable than a simple application crash......system files are at risk of damage with an operating system crash where an application crash they are not).  The real solution is getting a higher performing graphics card and/or more system memory.



Share this post


Link to post
Share on other sites
  • 0

This sounds to me as if you've encountered the dreaded Open-GL bug.   To cut a long story short, Nvidia  depreciated a lot of code in their drivers for more recent cards (mine's a GTX 460 and was certainly affected) that the SL viewer was still using.   This means your graphics driver is being flooded with error messages, and it times out.   I'm assuming you're using Nvidia, since that's the driver most usually associated with that error message, though I think some other drivers were affected too.

This has now -- very recently -- been fixed.   The very latest beta version of the viewer, 3.2.4.24  -- which I've not yet tried -- includes it, and you can get that from http://secondlife.com/support/downloads/  (under "other viewers").    I can certainly run Niran's latest version of his viewer very successfully with the latest Nvidia drivers,  and can also run Catznip 3.2-beta and the NaCl viewer.   I'm told that the latest Firestorm also includes this fix (and I've no reason to doubt it, but it's just I've not tried it).

So my very strong advice would be to try with one of those viewers and the latest driver for your graphics card, and see if the problem persists.

If it still persists, that probably means some of the graphics driver's dlls have been corrupted, which can happen.   Try doing a completely clean reinstallation of your driver, as described here (Nvidia's version of a clean installation leaves a lot of stuff still there, and that cause problems -- it did for me -- and, in consequence, if you want the job done properly you have to do it yourself).

But certainly, one of those viewers and the latest Nvidia driver should fix the issue.

If you really really want to change the timeout, and don't mind fiddling with the Windows Registry, Kitsune Shan's post in the jira tells you how do to it.    But I really wouldn't advise trying that except as a last resort and unless you know what you are doing.  

2 people like this

Share this post


Link to post
Share on other sites
  • 0

First, deprecated. Second, I'm ready to say this answer is probably offbase. Here's the reasons:

1. It hasn't been an issue for me until I started using the V3 viewers. I've also yet to update my drivers, going on 6 months of problem free usage until this particular issue. This more than anything leads me to believe it's new code that's the problem, not upgraded drivers.
2.The only exception I see when debugging the process using exodus, where I also see the bug in question, is kd_header_in at memory location [x], which is just some bug in the login screen, and is handled gracefully.
3. I let the failing first-chance exception go, get the unhandled exception and it fails through to llcommon.dll where it blows up. I get 0 significant errors before this.
4. If you log in with all pop-out windows (read: inventory, sim stats, etc) closed, it loads perfectly and reproducably every single time. (Read: This is a potential workaround, on a GTX 460, and a GTX 570)

I'll do some profiling later, but it looks to me like the new window code for non-docked windows (haven't tried opening the dock yet, will later) is blocking the render thread long enough to cause a timeout. This doesn't change if multi-threading is enabled or not.

Summary: try closing all windows save the chat window, which I have in the condensed mode where it's a floating window. I've been able to reliably reproduce both crashes (with windows open) and logins (when windows are closed) using this method.

ALSO. Exodus crew, there's breakpoints in them thar hills. Thanks.

Share this post


Link to post
Share on other sites
  • 0

Yeah, if you're using old drivers, then it's not an issue. I rolled my driver back to 260.99 and could log in with with any viewer, without problems. But if I used any more recent driver, I had huge difficulties logging in until Runitai Linden got his Shining fixes working. It's a combination of the new code for mesh-capable viewers and Nvidia deprecating the the fixed function, at least according to https://jira.secondlife.com/browse/SH-2240

Certainly the only viewers I've been able to use without difficulty on more recent drivers have been either old ones (based on 2.7.n and earlier) or very recent ones that include Runitai's new code.

Share this post


Link to post
Share on other sites
  • 0

I had this issue with a GTX 460 after a couple years of no problem. Was an Nvidia driver update so I had to roll back and then no problem till it was fixed a few drivers later. I recently upgraded to GTX 670 and have the issue again. So the comment "The real solution is getting a higher performing graphics card and/or more system memory." is not correct? I have an i7 930 with 12 gb RAM. i think the issue is some conflict between Nvidia's drivers and SL code. Other programs were having problems for people if you check the forums including Photoshop.

Share this post


Link to post
Share on other sites
  • 0

Nope he doesn't mean the screen saver. Win7 closes SL viewer because of a program timeout. OpenGL driver not responding so Win7 shuts it down.

 

Share this post


Link to post
Share on other sites
  • 0

Hi buddies,

Apparently this is a problem with card driver. Various graphic cards present the same problem when newest drivers are installed. So, after stay tired of google it and bind it i tried myself a lot of tests and below i solved the problem for my NV GTX550TI:

installed the latest driver and in "nVidia Control Panel", go to 'Manage 3D Settings' and set 'Power Management Mode' to 'Prefer Maximum Performance'.

Only this configuration and passed few days without any problem. Games at max

I hope this help more people... So, let´s play ;)

And please, if this work for you reply with an ok, alright!?

2 people like this

Share this post


Link to post
Share on other sites
  • 0

This doesn't work. I had a GTX 460 that developed the problem a year ago after working perfectly then got the error 7 after upgrading Nvidia drivers so had to roll back. Not fixed until SL did some patching suspect. Now I upgraded to a GTX 670 and getting the same issue. Both cards were factory overclocked which may not help.

Share this post


Link to post
Share on other sites
  • 0

Innula Zenovka's answer, posted at the top of this ancient thread, was marked correct because it works for most people. If you are having a similar problem and still having trouble, please start a new thread instead of burying your comments here in a necropost, where nobody will see them. ;)

Share this post


Link to post
Share on other sites
  • 0

It might very well be worth filing a bug report, under 1 Second Life Viewer VWR, in the Jira, giving full details of your system and operating environment. The original NVIDIA/OpenGL bugs all related to earlier cards and are marked as closed -- see https://jira.secondlife.com/browse/SH-2276 . If the problem's starting up again with the latest cards, LL need to know about it, and the Jira is the way to inform the right people.

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

I believe no one has a good answer yet on how to change that setting.  That link leads you to Windows Vista regedit, most of us are using Windows 7.  I had to switch to a better computer to even attempt a lighting trick I wanted for taking photos.  I decided to use SL Viewer as a starting point. I found this problem testing out a light project prim demonstrated by Torley, "Second Life Tutorial: Awesome rainbow lighting effects,"

 .  So in doing this created a HD light projector which casts a shadow using the settings in the viewers.  It is suggested you use Ultra setting.  This just crashes me within 5 minutes.  Then I switched it to High setting.  Make sure to hit the "Advance" button to see all the settings.  So I am lowering the Graphic Quality as many have suggested.  So I Check everything on the left but Depth of Field (why do I want to see blurry things at a distance).  Then I changed Shadow to Sun/Moon+Projectors, Minimal Water Reflection, Unchecked Avatar Clothing, Draw Distance 128, Particles 256, Environmental settings (Trees, Terrain, and Sky) to Low.  Hit OK and Apply. You would think this would be enough, right? No,  I had to go to Hardware Settings.  Unchecked Anisotropic Filtering (it IS slower when enabled), Disable Initializing (I believe this helps keep track of all the shadows), Check Enable VBO (Enable Open GL), keep Texture compression unchecked.  Hit OK.  This was all done so I could see the Ambient Occlusion effect and the shadows it creates.  When you do the above setting you lose shadow focus.  This is probably what is slowing down your graphics card.  Everything set at Ultra your shadow looks perfect duplication of you in shadow form.  When set at the lower settings it's just blurry.  I would assume it's in a way rendering you twice.   Shadows do appear for objects just not as obvious.  I am not a guru but that is my guess.  Can I guarantee this will work for everyone?  No, every configuration is different.  This is what worked for me.  Please add any arguments or clarifications.  I know there are people that know more and I am ready to learn.  I checked out the Jira link and got lost quick in all the posts and comments.

Share this post


Link to post
Share on other sites
  • 0

I know exactly what you are refering to. It's an issue with the drivers and your video card and i think the game involved also. So the best solution is upgrading to the latest Nvidia video driver and hopefully it's been fixed for you. I had this happen with 2 different video cards (GTX 460 and a GTX 670). Which video card are you using? My issue was months ago and has been fixed I assume with the driver and/or SL since I don't have the issue anymore. Is your video card overclocked? That was one of the issues with my latest video card and my GTX 460 wa also Factory Overclocked.

Share this post


Link to post
Share on other sites
  • 0

Did you make a game profile in the Nvidia Control Panel for your viewer? After you upgrade your drivers I would try that. On my machine it will run the viewer at adaptive power settings and I will get a lot less fps and performance. If you make a game profile and set power management to "prefer maximum power" you may get higher fps and performance. There are other settings you may wish to change like AA and AF, Vsync etc.

Share this post


Link to post
Share on other sites
  • 0

I assume you noticed that this necrothread is a year old now ....... ;)

Share this post


Link to post
Share on other sites
  • 0

Well someone posted today and I got 3 emails from this posting so apparently some people still have an issue? Not everyone upgrades their video drivers and a lot of people don't even know what you would be talking about. I know people don't even know what an oil change is and why they should have had one 3 years ago...lol. I knew one guy 50 yrs old putting 100% radiator fluid into company vehicles (10 LIMOS). To this day still beleives he's right...lol. Needless to say to of the Limo buses blew gaskets before being a year old multiple times.

Share this post


Link to post
Share on other sites
  • 0

Ref: http://msdn.microsoft.com/en-us/windows/hardware/gg487368.aspx

HKLM\System\CurrentControlSet\Control\GraphicsDrivers

Create a new key of type DWORD 32 bit if you have a 32 bit OS or DWORD 64 if you have 64 bit OS

Call it TdrDelay.

The default value is 2. I have seen suggestions of setting it at 8 which seems quite a jump so you could try 4. This is the number of seconds for timeout.

In googling this issue i found some wrong information about setting up this registry value which said to put it in

HKLM\System\ControlSet002\Control\GraphicsDrivers

This will do nothing. System\ControlSet002 is a backup. The Microsoft reference above gives the correct registry location "CurrentControlSet\" if yo want to check it out for yourself.

Of course you do this at your own risk. I am not saying it will fix the problem or that it won't blow up your computer. It is just the direct and correct answer to the OP.

 

Share this post


Link to post
Share on other sites
  • 0

Im having the same issue as of 5-16-14 with the newest release of firestorm 64bit. 

__________________________

Windows 8.1  / 64bit

Firestorm 64bit
Nvidia GTX 870m (3gb)

12 gb ram

__________________________

-Tabitha

Share this post


Link to post
Share on other sites
  • 0

Did you use the latest video driver? Maybe laptop video cards are going to have an issue. I haven't seen a problem on my Desktop with Win7. Was it immediately after install of FS?

Share this post


Link to post
Share on other sites
  • 0

Tabitha, 

I recently came across the same issue as well. My driver is currently up to date. I am not great with computers, but I can usually get by. This time I can't though. I have tried suggestions from other posts, but none seem to keep the application from closing. Here is some of the specs from my rig.

GeForce GTX 670

Driver Version -  337.88

AMD FX-8350 Eight Core Processor

Liquid cooling

Microsoft Window 7 premium 64 bit

800w power supply

970 chipset motherboard

16gb memory

2TB hard drive

Nvidia N670/ 2G

Sound Blaster X-Fi Titanium



Like I said, I am not tech savvy, but if more info is needed I can get it I am sure, if you found a solutiong please let me know. I am only having this issue with SL and nothing else as of now.

Share this post


Link to post
Share on other sites
  • 0

So glad I found this post! My Nvidia GTX770 suddenly started doing this after a driver upgrade and I could not figure out why! Thank you so much for this information! Your fix worked like a charm!

Share this post


Link to post
Share on other sites
  • 0

Which driver was an issue and what "fix" fixed it? I haven't had this issue for a couple years and only with one card that eventually ended up being RMA'd so being factory overclocked may have been one issue although it did run for a couple years after that issue disappeared.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  
Followers 0