Jump to content
  • 0
Sign in to follow this  
Flannery Salvadori

My voice will not work no matter what?

Question

  • 0

Wireless certainly doesn't help, and it may be contributing to your problem.  You can lose a lot of bandwidth on a wireless connection, and you get potential interference from every electronic device within range.  If you can switch to a direct cable connection, do it.

One common problem with voice really is related to bandwidth.  If you set your Maximum Bandwidth in Preferences >> Graphics too high, you are potentially dedicating all of your incoming bandwidth in SL to handling textures, movement, communication, animations, etc. and leaving nothing for voice.  Try lowering your Maximum Bandwidth setting to 500 or even lower. If voice works at all and is not choppy, try raising it a little at a time to see when you start to have trouble again.  It's a delicate balancing act.  If the setting is too low, you'll start to have more lag and rez times will go up, but you'll have voice. You can counterbalance some of the negatives by decreasing your draw distance and doing other things to reduce lag. Ultimately, though, there are limits to what you can accomplish with your machine and your Internet connection.

One final thought, unrelated to bandwidth but sometimes a cause of missing voice .... Go to Advanced >> Debug Settings, and in the window that opens, type: Cmdlinedisablevoice - then ensure this is set to FALSE

 

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Wireless certainly doesn't help, and it may be contributing to your problem.  You can lose a lot of bandwidth on a wireless connection, and you get potential interference from every electronic device within range.  If you can switch to a direct cable connection, do it.

One common problem with voice really is related to bandwidth.  If you set your Maximum Bandwidth in Preferences >> Graphics too high, you are potentially dedicating all of your incoming bandwidth in SL to handling textures, movement, communication, animations, etc. and leaving nothing for voice.  Try lowering your Maximum Bandwidth setting to 500 or even lower. If voice works at all and is not choppy, try raising it a little at a time to see when you start to have trouble again.  It's a delicate balancing act.  If the setting is too low, you'll start to have more lag and rez times will go up, but you'll have voice. You can counterbalance some of the negatives by decreasing your draw distance and doing other things to reduce lag. Ultimately, though, there are limits to what you can accomplish with your machine and your Internet connection.

One final thought, unrelated to bandwidth but sometimes a cause of missing voice .... Go to Advanced >> Debug Settings, and in the window that opens, type: Cmdlinedisablevoice - then ensure this is set to FALSE

 

Share this post


Link to post
Share on other sites
  • 0

Flannery Salvadori wrote:

It works on my desktop computer which is on the exact same connection as the laptop which is what's baffling me.

Also my bandwith is set to 500 and cmdlinedisablevoice is FALSE. :/


Well, at least you have eliminated those possibilities.  Unfortunately, there's not much left.  I didn't say anything earlier, but I assume that you have checked your hardware, your connections, and the sound & media settings in your own machine. If those are all OK, all I can think of is that your laptop is simply not up to handling voice. 

Share this post


Link to post
Share on other sites
  • 0

From what you say, it OUGHT to work.  Go through the following steps to see if you can find where the problem is.

1.  Windows audio settings.  With your microphone selected as the input device, speak.  Make sure you're getting a signal.

2.  In SL Preferences/Voice Chat, select the same audio device for input.  Do you get green bars when you talk?  If not, the problem is in the firewall settings, bandwidth, your wireless settings, or your internet connection.  I'm no expert when it comes to that area...I just push buttons until something starts working.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...