Jump to content
You are about to reply to a thread that has been inactive for 3407 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

So, I try to join Premium account. When I try to add my credit card (mastercard), fill in the details, it says payment failed. So I call my credit card company, and it turns out they didn't even receive a request. So, can someone please fix this?!

P.S. The error I am getting is as follows:

"Sorry, your payment failed. Please check your payment details and try again"

Link to post
Share on other sites

contact LL on below coordinates or check this page here;

 

Contacting Linden Lab billing support

If you have a non-technical issue related to billing concerns, you can call the Linden Lab billing team at the following toll-free numbers:

  • US/Canada: 800-294-1067
  • France: 0805-101-490
  • Germany: 0800-664-5510
  • Japan: 0066-33-132-830
  • Portugal: 800-814-450
  • Spain: 800-300-560
  • UK: 0800-048-4646

Long distance (not free): 703-286-6277

The billing team is available twenty-four hours a day, seven days a week.

 

*meows*

Link to post
Share on other sites

contact LL on below coordinates or check this page here;

 

Contacting Linden Lab billing support

If you have a non-technical issue related to billing concerns, you can call the Linden Lab billing team at the following toll-free numbers:

  • US/Canada: 800-294-1067
  • France: 0805-101-490
  • Germany: 0800-664-5510
  • Japan: 0066-33-132-830
  • Portugal: 800-814-450
  • Spain: 800-300-560
  • UK: 0800-048-4646

Long distance (not free): 703-286-6277

The billing team is available twenty-four hours a day, seven days a week.

 

*meows*

Link to post
Share on other sites

I've heard that this works, but don't know personally...worth a try:

When entering your info, make the three digit security code on the back of your card that they ask for, a four digit code by adding a zero in front and try submitting again :)

Let us know if it works.

Link to post
Share on other sites

I've heard that this works, but don't know personally...worth a try:

When entering your info, make the three digit security code on the back of your card that they ask for, a four digit code by adding a zero in front and try submitting again :)

Let us know if it works.

Link to post
Share on other sites
You are about to reply to a thread that has been inactive for 3407 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...