Jump to content
Sign in to follow this  
Talia Davidov

Horrible Sim Performance since Mesh Rollout

Recommended Posts

We have a jira entry out there SVC-7249 that is now completely getting ignored by Lindens after a request for more data.  What can I do?  My sim is slowed to a crawl crashing multiple times a day.  When I do a support ticket when it is offline all I get is the "yes you were having a problem and your sim is now back up and running" message.  I get no response on the long term issues, just hey we rebooted it for you.

Right now my sim is once again up to crashing multiple times a day.  Some times it is working wonderfully with twenty or thirty residents and not a hitch.  Other times it can be down to just two or three people in the sim and so lagged you can't move a step with time dilation down to .017 or such.

We have tried the pat answers like reducing script count, but the sim was working fine a couple of months ago and has had no major changes since then.  Our traffic now is even significantly less on average.  Still we get this maddening lag.  It seems to be much worse since the OS upgrade.

I am at wits end.  I am seriously asking myself is the amount of grief I am getting from this worth it? 

Very very frustrated

Talia

Share this post


Link to post
Share on other sites

All of SL has been a mess since they unleashed the disaster that is mesh.  I think the solution is simply to undo the idiotic move in the first place, it was a stupid pointless move that we knew was going to be a disaster, so why they did something so stupid I do not know.

Share this post


Link to post
Share on other sites

@Talia

We too have seen this issue on our Homestead, twice.  On one occasion the server simply ground to a halt every time a script was called (one that in normal circumstances has barely any impact on server performance).  On the third sim crash I called Live Chat, and was told that "A team were investigating the issue at that moment".

We were moved to another server and for a couple of weeks we had no further problems.  Last week the issue returned, and although the sim didn't crash, I was able to observe sim pings of over 1 second on about half a dozen occasions.  The following day (Tuesday) was restart day and I noticed on the restart we were moved again (this does not seem to happen routinely on Server update restarts).

I was given to understand that this issue was TIMEWARP, and that it would be addressed by the OS upgrade.  That does not seem to have been the case, since server perfomance is in many cases just as bad.

Expecting Linden Lab to withdraw Mesh and its supporting software is a vain exercise...it will not happen, not least because Philip Rosedale promised it, and that makes in a ""shiny" shiny"".  Too much has been invested for that to even be an option.

Linden Lab need to sort this one out, because from being a showstopper for some, it is rapidly becoming a Gamebreaker.

PS:  I should add that I don't believe that Linden Lab are doing nothing about this issue.  I think they are doing what they often do, and that is running in "Full Stealth" mode, because they do not wish to appear not to be in control of their creation - bad for business confidence.  In one narrow way, that is understandable, but it results in many frustrated and unhappy users of SecondLife.  Sadly for us, Linden Lab does not place our discomfort very highly on its values list.

Share this post


Link to post
Share on other sites

@Allazondra

lol,you have no idea what you are talking about....

@Talia

We have had issues with both our islands as well,and I agree it has come from the mesh roll out.But this happen with sculpted and sculpted changed the face of SL for the good.This will take time to get the bugs.We pay for 2 islands so I feel you on the problems they are properly flooded with support to personally reply.

Share this post


Link to post
Share on other sites

It's really hard to blame poor region performance on Mesh. Perhaps what we need is to go back to texture hair, no sculpties and no flexi (<< that was sarcasm). LL does need to figure out how to better stabilize regions but in the mean time a region restart every couple days works wonders (in most cases).

Share this post


Link to post
Share on other sites

I see Cincia advocates a region restart every couple of days......Hmm.

Not all that long ago I can remember hearing that a region restart every week kept the server doctor away...

I'm thinking I see a trend here - does the term "Memory Leak" chime with anyone?

I think someone needs to go through the code with a magnifying glass and figure out where this issue (memory leak or not) is.

Share this post


Link to post
Share on other sites

Support has moved us to a different server we shall see what happens. 

I would say, I actually think the Lindens have been working hard on the server system.  I have seen more improvements this year than the rest of my time in SL.  I really am not a champion of un-rolling mesh away either.  It is here to stay and thats fine.  I just want them to figure out how to stablize those of us that it has affected.

@Ayesha, I was told it was timewarp as well, and had great hopes for the OS upgrad.  *sighs

@Tammy, Yes I am sure it will get sorted some day.  Just had to raise my voice to try to get something done

@Cincia, Not saying its Mesh, saying it happened during the mesh rollout.  Lots of other changes happened on that same rollout related to the move to Mesh.  The fact that all our issues, and many others as you see, happened with that rollout is really beyond dispute.  When one day your sim works, SL rolls out a new server version and your sim doesn't work, the cause is pretty obvious.  As for the region restart every couple of days, oh no problem there, when its acting up it crashes itself much more often than every couple of days.

Share this post


Link to post
Share on other sites


Ayesha Askham wrote:

I'm thinking I see a trend here - does the term "Memory Leak" chime with anyone?

I don't think so.  We started logging time dilation (or is that Time Downthetoilet?) and also the region it was on.  I'm pretty sure that sometimes we'd come back on a different region and almost immediately be down the toilet.  On the other hand, being a homestead, it's possible that another sim on the same environment had leaked.

Either way, we were fobbed off with "it's your wireless/it's your network", then "oh it's TIMEWARP" and clearly it was none of these.  Anyway, since being moved yet again, we've been free of this for a week or so, all I can say is that it seemed to co-incide with the OS upgrades and I don't see why we'd suddenly have been afflicted by a 10 month old bug.

Share this post


Link to post
Share on other sites

Personally i think its project management and QA (or lack thereof),

Im quite sure they relase stuff that has not been adequatley tested.  Thats the root cause.  

The current mess is just one symptom.   They fix these problems but if they stay with the curent modus operandi they will continue releasing fresh bugs avery week.  

After Mesh there will be 3-D.   (Im joking.  Aren't I?).

Share this post


Link to post
Share on other sites

Actually I advocate estate managers and owners do all they can, using the tools they have available, to keep their regions running as smoothly as possible; i.e. when your region lags hit the restart button. The land I deal with daily is mainland so I go through Live Chat to get region restarts.

Share this post


Link to post
Share on other sites

while yes a restart is a temporary fix it is just that temporary and I am seeing a lot of lag on a private region that didn't use to lag before all these os upgrades we now get severe lag with less then 20 avators on a private region seems something is not right

Share this post


Link to post
Share on other sites

@Cincia

The issue here, Cincia, is that a restart every couple of days is not wise for two reasons:

1) It increases the risk of a faulty shutdown which can result in data (ie object) loss.

2) It is only a band-aid, not a cure.  If a sim is needing a restart every few days, and all other aspects of that sim have been carefully audited (ie scripts using excessive server time etc), it is diagnostic of a systemic issue with SL, either in the Server software or (please no) the underlying Operating System.

Yes, of course sim managers or owners should be diligent in their use of all the land tools that LL give them..and that is quite an arsenal now..but you cannot make a silk purse out of a sow's ear, no matter how many times you restart a sim.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...