Jump to content
  • 0

Im trying to add my credit card, and Im filling in the form, but why is there no submit button?


You are about to reply to a thread that has been inactive for 3511 days.

Please take a moment to consider if this thread is worth bumping.

Question

  • 0

I do see an orange submit button on the website. If it is greyed out for you, you may first try another web browser. If it doesn't help, contact the support:

 

Billing support phone numbers

Toll-Free (US/Canada)

800.294.1067

Long-Distance

703.286.6277

Our Billing team is available 24 hours a day, seven days a week.


Local Toll-Free numbers
  • France: 0805.101.490
  • Germany: 0800.664.5510
  • Japan: 0066.33.132.830
  • Portugal: 800.814.450
  • Spain: 800.300.560
  • UK: 0800.048.4646
  • Support is in English Only

If none of these numbers work for you, send an email to: support@payments.secondlife.com

By the way, I would recommend you always buy Lindens from the LindenXchange on your dashboard rather than inworld. It seems it's faster and safer.

  • Like 1
Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

I do see an orange submit button on the website. If it is greyed out for you, you may first try another web browser. If it doesn't help, contact the support:

 

Billing support phone numbers

Toll-Free (US/Canada)

800.294.1067

Long-Distance

703.286.6277

Our Billing team is available 24 hours a day, seven days a week.


Local Toll-Free numbers
  • France: 0805.101.490
  • Germany: 0800.664.5510
  • Japan: 0066.33.132.830
  • Portugal: 800.814.450
  • Spain: 800.300.560
  • UK: 0800.048.4646
  • Support is in English Only

If none of these numbers work for you, send an email to: support@payments.secondlife.com

By the way, I would recommend you always buy Lindens from the LindenXchange on your dashboard rather than inworld. It seems it's faster and safer.

  • Like 1
Link to post
Share on other sites
  • 0

Wheew thanks so much.......didnt really think it would be such a simple thing as a web browser; Im using Opera and it shows no submit button at all, grey or orange. Tried Google Chrome and it worked perfect, I never got such a fast response submitting a ticket before hehe, so thanks again, you made my day :-D

Link to post
Share on other sites
  • 0

on this one  you will need to call linden labs for its an issue with payment "hiccups".

 

A few months ago ihad the same issue and i had to call linden labs to get them to fix it in the system.  Relax call them...they are nice...they dont bite...LOL

another option is to double check the payment info all together as well as your billing address. Make sure all the info is correct. Some times that is why its asking for your credit card data....(but beware that can be a scam as well from a thrid party outside of SL and Linden labs) so call Linden labs to make sure they fix it in the system to make sure you are not part of a scam.

 

Ihope that helps...

 

have a wonderful SL day

Link to post
Share on other sites
  • 0

I encountered the same issue as well, but finally found a solution. Apparently LL has no idea what web standards are. The page does not display a submit button under Firefox, Chrome, or Opera on Windows or Linux, but when I view the page with Internet Explorer (yuck) in Windows, it works fine. The problem is entirely in the coding of the page. I have a hunch what browser their lead web developer uses.

 

Probable Solution: If you're on Windows, try IE. If you're on MacOS, Linux, or BSD... install Virtualbox or something, then emulate Windows and IE. 

Link to post
Share on other sites
You are about to reply to a thread that has been inactive for 3511 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...