Jump to content
Sign in to follow this  
Kain Xenobuilder

Skinned mesh size 3DS Max 2011 all wrong

Recommended Posts

Hi,

I'm using the Wiz Daxter script to import my avatar into 3DS Max 2011. Works fine. I make clothing based on that mesh. Works fine too. Skinned it, added all the bones to the skin modifier, textured it. It's all good. Export no problems either. I also edited the DAE file so it has all the bones listed.

When I import the mesh into SL however it turns out way big. Like 100 times the size it should be.

I tried scaling down the rigged avatar to 1.80 meters in Max, same problem. I tried exporting a pre-made bodypart from the avatar directly, same issue.

Does anyone know what's going on here?

Share this post


Link to post
Share on other sites

3dsMax has 2 different unit-setups: the 'display-units' and the 'system-units'. You say you scaled your mesh to 1.80meters - this is what the display-units show you. 

But exporters usually use the system-units. So just check in the units setup that you have both, display- and system units set to meters.

Also when exporting, have a look what setting you have in the export dialog - should also be 'meters'  (although 'automatic' should work).

If all the above doesn't help, create a new test-object (1 meter box or so) and check if this works. If it does, but your mesh still fails, have a look at the Reset Xform utility. 

Share this post


Link to post
Share on other sites

Thanks. The units are setup ok.

Just turned out the SLAV importer seemed to have the default setting at 40x the scale needed... (little text input box when running the script in Max)

Grrrr hehe back to redoing the whole friggin thing from scratch.

Share this post


Link to post
Share on other sites

This could be, SLAV probably assumed to work in inches (40 inch are roughly 1 meter).If you already skinned your mesh, maybe you can save your skin-data from the skin modifier, then re-create the meshes at right scale and finally load back the skin-data.

However - good luck :-) 

Share this post


Link to post
Share on other sites

This may be too late to help but there's no need to start over from scratch. Just save your skin weights and reload them after you've brought in your rig at the proper scale and resized your mesh to fit it. If you want to work on a larger rig just import from SLAV at a scale of 1 and then scale it back up. It will work find so long as you remember to adjust the scale factor again when you import to SL.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...