Jump to content

Keyframing now available on ADITI


You are about to reply to a thread that has been inactive for 3507 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

I would assume the empty list part is a bug, but can easily be gotten around by calling the function with ZERO_VECTOR for the position, and a small value for the time.

I'll assume that the physics shape setting only accepting convex hull is also a bug.

ETA:
my suggestion to parse null values as defaults should eliminate the first bug, depending on implementation.

Link to post
Share on other sites

To force a regular single prim to the PE system, you have to change it's physics type. A single prim can't be type None, so Convex Hull is the only option.In a linkset, you can change a child prim to type None, to force it to the PE system. Or by linking a mesh object in.

And from my short testing, calling ZERO_VECTOR isn't quite the same as calling an empty list. To update the current keyframe list, it looks like you have to cancel the previous list beforehand, which is done by calling an empty list.

 

Edit: llSetKeyframedAnimation( [ ], [KFA_COMMAND, KFA_CMD_STOP]); does work without crashing the sim.

Link to post
Share on other sites

I tried to test it with a very simple script explained in the wiki page. I also got stuck in the two obvious traps when using this: 1) how to set PE with normal prims and 2) crash when specifying empty vectors. These should definitely be documented on the wiki, and they should be documented by Linden i think, otherwise we risk to have some voodoo recipes possibly wrong.

15 minutes is definitely a very short period for me to complete an even simple task. What I was trying to do is to have N objects following a circular trajectory and be sure the 4 objects are synchronized each other. Since I couldn't test due to 15 minutes timeframe, I esplicitly asked Oskar if objects are synchronized one with the other or we need to provide an explicit synch mechanism to be sure they are at the right place. Think about a Luna Park wheel where we have all the seats which should rotate but they must be properly bound to a specific part of the wheel.

Thanks for synchronization clarification.

 

UPDATE: I did a very simple test with a ping pong animation on two cubes going up and down. They seem relatively well behaving being synchronized one to the other BUT if you click-edit one of the two it gets paused and will start again from that position when relinquished. This is not exactly the kind of synchronization I had in mind for a wheel. Can you suggest a viable way to keep them synchronized? 

salahzar

Link to post
Share on other sites

While an Avatar is standing on a flat animated object turning like a record the body of the Avatar will turn facing the direction of the forward vector in which it travels. Same goes for a an object moving linearly. The Avatar will face in the direction of the forward vector of the object.

Also note when in mouse look the camera will not turn if standing on a object which is turning or moving.

 

Link to post
Share on other sites

Due to the limit of 0.1 second an object cannot be moved to a point with no visible movement. I thought keyframe animation might be a possible solution. Such as have the object Animate then jump to the the original position as though a strip of film were spliced into a loop.

I tried a few things such as stopping the animation then setting the position using fast params. Then starting the animation right after params functions. But the second call of the key frame animation silently fails if the object is still visible moving via a set position.

Not sure is this a bug. Kind of unexpected

Link to post
Share on other sites
  • 2 weeks later...

Hello dear Linden developers,

personally I find this new function very interesting and I already made some first good experiences with it (especially on elevator development).

But I am very disappointed about the currently available testing facilities:

- the only two available regions "Sandbox - Weapons testing" and "Sandbox - Bispinor" are still set to 15 min auto-delete for more than 2 weeks !  This makes a more detailed software development and testing nearly impossible.

--> Could you please extend this "auto-delete" time to a more practical value or

--> update some other sandboxes with this new function in order to allow further detailed testing ?

 

Thank you and Best Regards,

Geraldo

 

EDIT 10-26-2011:

Meanwhile I am not able to test any code even on these both sandboxes: the new functions seem to be removed.

In addition, I cannot test even a simple application on one of the RC region sandboxes in Agni:
     Blue Steel / Magnum / LeTigre.

Has development of this new function been cancelled (or do I miss any information abou it) ?

Frustrated,

Geraldo

Link to post
Share on other sites
  • 3 weeks later...
You are about to reply to a thread that has been inactive for 3507 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...