Jump to content

Still Calculating...


Pookiepie Bluecoat
 Share

You are about to reply to a thread that has been inactive for 3657 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

I made a chain necklace in blender (duplicated toruses) i go to test grid to check it out, press the calculate cost and equiv button and 10 minutes later im still calculating.  I went back into blender and joined each link to one another by at least 1 vert and tried again still calculating...   I thought ok maybe it's just really big for some reason so I compared the face count with another mesh I made around the same count about 9k triangles this mesh uploads in 2 seconds or less.  Can anyone tell me what to do here?

Link to comment
Share on other sites

They were not triangles ( I thought the export took care of that ).  I did forget to remove a subsurf but I fixed that and still got the same result. I also used mirror but that was also applied before exporting.   No it's not importing back into blender.  Going to keep trying.  Any advice greatly appreciated.

Getting a python error when I try to import back to blender. It's the same error I get when I try to import all of my meshes though and I don't have the upload problem with the other meshes.  

Converted my polygons to triangles before export this time still not uploading =\. 

Link to comment
Share on other sites

The problem seems to be happening during mirroring.  Weather I do it manually (duplication, scale -1) or use mirroring modifier either joining or not joining uploading the sides individually or together the mirrored side refuses to upload.

 

Seems odd though as I've mirrored in all of my other meshes and not encountered this problem.

Link to comment
Share on other sites

I am seeing this too. There is a 65536 vertex limit. Before you say "but I don't have that many vertices"...that's actually why I have come to the forum today!

If I try to upload a mesh with 11001 vertices (according to Blender 2.49b), the "Calculate..." button DOES return a result, but the Mesh Upload window shows my mesh has 65383 vertices. If I try adding a few more vertices in Blender and retrying the same steps, the "Calculate..." button never returns with anything, no error, nothing.

I don't know why 11001 = 65383. But I bet that's what you're running into too.

Maybe someone else has some insight into this.

Link to comment
Share on other sites

No sorry I am not having the same problem exactly it is hanging up at calculating but the vert count is staying near the same as it is showing in blender.  I am not sure why I am having the problem I am having but it seems to be directly related to mirroring the particular mesh I am working with.  I also get no error or anything that gives me the slightest hint into why. 

Link to comment
Share on other sites

Need more info....

Can you tell us how many toruses, whether they are one or multiple blender objects, whether you are using mirror modifier and how many rings there are around the large and small radii of the toruses? Have you tried increasing numbers of toruses to se whether the problem starts suddenly with increasing numbers? How may vertices and triangles does the uploader say are in the upload? How are you specifying the physics shape (if at all)?

Link to comment
Share on other sites

Sure, 86 toruses 4 on the short radius and 12 on the large. Started with one and duplicated and mirriored in edit mode.  End count in blender 4458 verts, 9004 face  count.  

 

Uploader count 9004 triangles, 6830 verts ( highest lod)  no physics specified. 

I have uploaded a single torus, and 43 (left side of the necklace) toruses.  Tried with 84 ( removed the merged toruses from center ) Attempted to upload the 43 on the right side as one piece failed.

As I posted above for whatever reason regaurdless of the method any form of mirroring the left side seems to be causing the problem as it uploads fine. The 43 that are uploading successfully were all duplicated in edit mode and are having no problem uploading.  

Link to comment
Share on other sites

Hmm. I made a thing with 88 toruses (12x4 verts) interlinked. Actually I made two and duplicated 22x with array modifier, then added mirror modifier to get 88 in two chains of 44. I used the upload dialog with as many different settings as I could think of for physics shape and with and without scaling down to necklace size. I did not come across any problem with calculation delays. This was without UV map. I will add that and try again.

PS. It's ok with a UV map too.

I guess the next question is which viewer and server you are using. These tests were on (Help About)...

Viewer: Second Life 3.0.3 (240895) Sep 15 2011 11:47:07 (Second Life Release)
Server: DRTSIM-85 11.09.15.240906 (Mesh Sandbox 25 located at sim9001.aditi.lindenlab.com)

You should probably not be using an earlier viewer.

Note though, that the cost calculation is done by the server.

I'm not using the current Project Mesh development viewer because it invariably crashes within 30 seconds of landing in a mesh sandbox!

 PPS. The triangle count you give is slightly higher than the 2x12x4x86 (=8256) for the toruses. Is there something else there? Is it supposed to be there?

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 3657 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...