Jump to content
Sign in to follow this  
xRiViTx

"Unable to connect to the grid. Despite our best efforts, something unexpected has gone wrong."

Recommended Posts

I keep getting this error when I try to log in:

"Unable to connect to the grid. Despite our best efforts, something unexpected has gone wrong.

Please check secondlife.com/status to see if there is a known problem with the service."

I tried the following at least 2 times each:

-Cleared cache

-Reinstalled my viewer 3 times.

-Tried using an earlier version of the viewer.

-Restarted computer.

-Checked my FIrewall/Anti-virus settings thrice.

-Tried logging in on multiple viewers.

-Tried logging into the mainland, several different regions, last location, home, etc.

-Waited about 5mins between each 'fix' attempt.

-All of the above again.

Does anyone have any suggestions? Any help/advice is greatly appreciated!

I should also note that I crashed before this started happening.

Share this post


Link to post
Share on other sites


Randall Ahren wrote:

Switch your router off and turn it back on. 

That worked for a second, but then it started to show the same error message again.

UPDATE: I messed with my firewall settings and it logged me in for a brief moment, but then I received yet another error code:

"We're having trouble connecting. There may be a problem with your internet connection or the Second Life servers. -- You can either check your internet connection and try again in a few minutes, click Help to connect to our support site, or click Teleport to attempt to teleport home."

I reset my router again, the viewer logged me in but froze on something called 'region handshake' or something other, then gave the above errorcode again. Once again, does anyone have any idea what other fixes I could try? Thanks!

Share this post


Link to post
Share on other sites

Hello xRiViTx. The "Waiting for Region Handshake" message occurs when the Second Life Viewer does not receive an acknowledgement from the server.  The usual cause of this error is a firewall blocking UDP packets. Reconfigure your firewall to resolve this problem.

For information on how to configure firewalls, see:

Share this post


Link to post
Share on other sites

There are some new login problems. It depends which viewer and which version of it you are using. If none of the other suggestions have helped, check out: Can’t Login Second Life.

The problems are known and are being worked on.

Any time a viewer crashes it may leave some of its parts running and fail to release memory and properly close files. All these things can cause problems on the next launch. Reboot the computer to assure all those issues have been cleared.

Also, sometimes the settings file gets corrupted. Rename the settings file and try launching the viewer. You'll find settings in: C:\User\[windows_login_name]\AppData\Roaming\SecondLife\user_settings\[name varies with viewer - settings.xml for SL]

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...