• 0
Sign in to follow this  
Chrissy Gant

How can I fix this OpenGL error to run viewer 3?

Question

5 answers to this question

Recommended Posts

  • 0

Tristizia is probably right about the most recent driver for the newer nVidia cards.  Drivers are nothing but software and sometimes the updates contain bugs (as any software is subject to).  I know everyone says (including myself) that you should have current drivers for successful running of SL.  But here's a good rule to observe for any hardware device.  You need a driver for the device that works for the programs you use.........you don't necessarily need the most recent.  A lot of people download and install every driver upgrade that comes along believing that it is necessary.  If the driver you are using is doing everything you need it to do then don't upgrade it.  If the day comes when something is funky and it appears to be a driver, then go ahead and upgrade it then.  If it doesn't work for the programs you need it work with (such as SL and OpenGL) then don't panic...........just start dropping back to the next most recent driver until you find one that works.  That will save you a bunch of headaches when a driver has bugs like the most recent nVidia driver seems to have with OpenGL.  It also means you won't be upgrading drivers every time nVidia or ATI publishes one (sometimes as often as weekly).

 

I'm using a driver that is about a year old (nVidia 258.96).  It does everything SL needs it to do and I run as fast as I always have since installing my present card (GTS 250 1 gig) in this machine.  When I start having issues that are driver related I'll upgrade......not before.  Past experience with SL and drivers is that a driver is usually good for a couple years before needing an upgrade (that's dependant on how many server upgrades LL does and the features introduced.........sor far my year old driver is capable of handling everything).  Upgrade your drivers when you need to upgrade them.....not just because there is a newer one out.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0


Chrissy Gant wrote:

I installed the newest SL Viewer and it crashes saying; The NVIDIA OoenGL driver lost connection with the display drive and is unable to continue.  The application must close.  Please visit
for help.  Error code:8

Sounds like the error message told you where you need to go.


Chrissy Gant wrote:

This is the latest driver. 

That's not helpful for people searching to find answers to the same problem, as the "latest driver" changes with time; nobody's going to complain if you're too specific.

 

 

Share this post


Link to post
Share on other sites
  • 0

Windows driver version 280.47 and Linux drivers version 280.10.01.04 provide full support for OpenGL 4.2  this includes OpenGL 3.0  http://developer.nvidia.com/opengl-driver

On the down side Viewer 3.0.0.X still have an OpenGL error on my machine and I can not play Second Life unless I use another product that I don't like and looks terrible..

 

Share this post


Link to post
Share on other sites
  • 0

I don't fully agree here that this is (always) caused by SL Viewer 3. This has been haunting me for three weeks, BTW, and I just solved it for myself without changing drivers.Only in my case it was Error 4, yet with an identical error message. Currently using Display Driver 280.26

If you are reading this error message closely, it says it lost connection to the (underlying) driver. This MAY also mean that the driver has gotten unresponsive due to other causes, essentially meaning whatever is going on pulled the carpet from under the feet of OpenGL and thus also the SL Viewer. In my case it always happened when doing stuff in Firefox 6/7. Like switching tabs or in one case simply clicking a link in Wikipedia. Screen goes black for a second, comes back, OpenGL error.

My solution is to set the TdrDelay variable to 0Ah (decimal 10)  in the registy. This prevents Windows Vista and Windows 7 from prematurely resetting the display driver.  Please look up the registry key "TdrDelay" in Google and how to set it if you're not experienced with the registry!

Copy and paste this into a text editor and save this as .reg file, for example "Delayfix.reg" and doubleclick the saved file.

------

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers]

"TdrDelay"=dword:0000000a

-------

Alternatively/additionally you may want to disable hardware acceleration in Firefox if you are suspecting that FF is causing the issue in your case. Hardware acceleration in Firefox has been troublesome for a while by now.

 

Hope that helps!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this