Jump to content
Sign in to follow this  
Pennelope Thiessam

Maya to SL problems - calculate weights button still dissapearing

Recommended Posts

My "calculate weights" button is disappearing when I check "skin weights" (before you blame it on my bones or tell me to uncheck the unused influences box, please read further)

 

Frivolous details:

maya 2011x64

mac OS X 10.6.8 

viewer 2 version 3.0.0.238864

OpenCOLLADA 1.3.0 plugin from here 

I HAVE unchecked the unused influences box in maya

I HAVE checked all the bones with a text editor and compared them to a working mesh file..  they appear to be there in the .dae file

I uploaded all the pictures from this post on a special flickr here

 

Okay I seem to have the same problem as everyone else, but I swear I have tried everything. But, I still feel like in the end, this is going to be something small and stupid and I'm going to groan over whatever I am doing wrong. So here, I'm going to attempt to post my process with screen shots, and see if someone can tell me where I am going wrong. (because I've explained it like eight times, and two of the eight were only helpful in saying they had the same problem)

 

My adventures in uploading mesh from maya to second life (it's been a roller coaster thrill ride)…

 

Okay first off I have this pretty pretty princess dress (not really, I was just fooling around and testing mesh out) that I first formed from a nurb and then converted to polygons. I tried uploading the nurb straight and thought well maybe I can only use ploys for mesh… and that made no difference. 

<picture 01 - my mesh dress>

okay so on I go, I import the Reed Steamroller skeleton from here 

And I did what Raster Teazle suggested here by adjusting the joint size to .05 and switching my coordinates to Z

<Picture 02 - The post>

 

So now my scene looks a little bit like ET:

<Picture 03 - ET Dress with skelton>

 

So I continue by switching to wireframe and clicking the hip bone on the skeleton so the whole thing appears white, and shift clicking the dress I've made. I follow the instructions he gives here… and do my smooth binding. Yes, I unchecked the remove unused influences box. 

<Picture 04 - my smooth bind settings>

Kay so after that I select all and go to export all, double the work but just in case! I have tried both my OpenCOLLADA & my DAE_FBX exporter, and they both produce the exact same results….

<Picture 05 & Picture 06> my export settings

I even tried using the dae_fbx exporter and changing the up axis to Z, but it gave me the same exact results… I haaaave heard rumors that the open collada exporter is buggy with certain versions of maya, and you have to uninstall it completely as it will override your settings to some degree, I wonder if this could be part of the problem. I have not tried that yet.  But I was trying to export my mesh with dae_fbx before I knew everything and didn't have the opencollada exporter installed. 

 

Okay so next I log on to viewer 2, crash, relog, crash relog etc until I finally am able to log in and load and it doesn't tell me I have 20L… I do a mesh upload, and everything appears normal until I hit skin weight, then my calculate weights and fees button poofs!

<Picture 07, Picture 08 & Picture 09> my upload settings for sl

(no need to worry, I will take all the millions of linden I make off of this mesh dress and convert that to 20usd and put that towards buying a new computer!!)

 

So like, I have fangaled with every lil button in there, even tried uploading my file to each lod and what not. And I can't figure out anything, the only thing that comes up funny for me and may possibly be a clue is this… When I click the funny lil settings icon, and I click show skin weights and show joint positions it comes up like this:

<Picture 10> Uhh... wtf

<Picture 11 - possibly the culprit>

(everything I do gives me THIS same exact result)

This leads me to think somehow rigging/skinning is not happening correctly in maya or my exporter is not behaving. I'm leaning towards the exporter, because when i wiggle around the joints in maya, they seem to behave just like that dudes video. But I don't really know, that's why I'm asking YOU! :)

BTW the mesh is uploading in world completely fine, I just can't wear it. So I uploaded a non rigged version and it is mocking me  with evil taunts, please help. 

Share this post


Link to post
Share on other sites

This is the skeleton file that I use. It works perfectly and I don't have any problems.

http://uploading.com/files/185fa4fc/Working%2BSkeleton%2Bfor%2Bmaya.mb/

The steps you have done is correct, but before you skin your mesh. Make sure that you delete the history in the mesh. (Edit >> Delete By Type >> History)  Then you would continue on with the skinning and the steps after that. Then you shouldn't have a problem with the disappearing button.

 

  • Like 1

Share this post


Link to post
Share on other sites

Yes i did! My dress no longer mocks me...

I did everything exactly the same, except added in Streetz's suggestions.

What I have changed:

I finish making my dress.

I save it and close it.

I open Streetz's skeleton. (he posted the link above)

I import my skirt into the working skeleton file.

I select only the skirt and rt click edit, delete history.

Then I continue onto the skinning process ect. and everything works beautifully. 

(it's a bitch learning all the ins and outs of how to properly size it, so I suggest working on the aditi server so that you don't have to spend half your lifes earnings figuring it out, you get a sort of 'fake' linden amount to work with)

PS I waited to post my answer, to make sure it wasn't a fluke and it wouldn't work a day later, but this has solved my problem for over a week now. 

Share this post


Link to post
Share on other sites

Yay!  Thank you Pennelope and Streetz!  This has been driving me nuts too!

But now I have a new problem!  LOL

When I attach my meshes to my pelvis, my view goes up to the sky.  When I back up my view, I am entirely invisible.  I detach the mesh, and am still invisible.  I have to quit SL and relog.  I've had this problem with 3 different types of AVs that I made (even a simple block figure) and also with a very basic tube dress.

What am I doing wrong?  Or not doing?

Share this post


Link to post
Share on other sites

LOL Well, once again, that fixed one problem but created another!  If I use any of the meshes I mentioned earlier, they rezz fine on the ground, but if I attach them, they go invisible . . . but this time my avatar is still visible.  I did create a new mesh around the skeleton and that works fine.  The odd thing is that I had built the dress around the skeleton and that goes invisible, as well.  I'm really confused.

So once again, if anyone has any clue of what I need to do, or not do, please help!  I remember seeing someone else having a similar problem, while I was looking for the answer to the other problem.  Unfortunately, I can't find the post again.

Share this post


Link to post
Share on other sites

Okay it sounds like either, your mesh is not rigged and is super tiny and inside your body (just attached like an itty bity sculptie) or you are still clicking the joints box. Try looking at the upload screen and messing around with the little gear icon, that is the settings, if you click show skin and show rig joints or whatever, and it shows up like mine did, you still don't have it rigged. 

Share this post


Link to post
Share on other sites

I'm not clicking the joints button.  They are as tall as my AV (about 2 meters) when rezzed on the ground.  It must be something that is happening if I change the skeleton to match the model because it didn't happen to the extruded cube AV one I tried most recently (that one worked fine, but was really basic like gumby).  But then again, I didn't change the skeleton on the dress and it did happen to that one.  Sorry, I think I'm repeating myself.  The dresses rig must not have exported properly, I guess . . . or it's my crappy internet connection (wireless hotspot in the woods) and I need to be patient.  It did take it quite awhile to rezz on the ground.  But it definitely isn't working if I try to match the skeleton to my existing models.

Anyway, thanks for the help!  I'm certainly a lot further along than I was!  :)

Is it not possible to adjust the joint position of the skeleton and still have it work?

Share this post


Link to post
Share on other sites

You can not change the skeleton at all.

Basically from what I understand the skeleton is set to match the SL avi exactly, so if you muck with it even a little, you will throw everything off. It's a bit touchy, I imagine as things expand and improve they'll make that less rigid.

But, what I do is I work in two completely separate files. One is my acutal mesh item, dress, skirt, etc. The other is just the skeleton. I work on the skirt until I get it perfect, and even import the skeleton into that file just to line things up how I want. (I know that's probably overkill, but with SL I'd rather be safe than sorry) When I'm finished compeltely I save the skirt file and delete the skeleton or the avi mesh if I imported it. Then I open the skeleton file exactly as I downloaded it from this thread. I import my skirt, click the skirt to delete the history and proceed to skin and export it. This has worked perfectly for me every time. 

Share this post


Link to post
Share on other sites

Thanks! That's the problem then, except for the dress.  I just had done the dress as a test, so it doesn't matter.  I'll have to redesign my AV models (unfortunately), since they aren't proportioned correctly to fit the skeleton.  If anything goes wonky, I'll check and see if I skipped a step, or assume it's my internet and try again.

Thanks again!  :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...