Jump to content
Sign in to follow this  
warehousefifteendesigns

Mesh 'inside out' after texture application

Recommended Posts

I've hit a small snag with a mesh. My mesh imported fine, and looks fine with any standard texture applied. However when I apply my own texture, it turns inside out (see the picture below).

I believe it may be a problem with applying alpha channel enabled textures to meshes, although I'm not sure. Any help, info or advice would be greatly appreciated. Thanks in advance!

 

meshglitch.png

Share this post


Link to post
Share on other sites

I don't have much of a clue when it comes to mesh, but that looks as if the normals are flipped. I'd try to invert the normals and re-upload it.

ETA: It does look cool though. Like an M.C. Escher drawing :)

Share this post


Link to post
Share on other sites

Thanks for the reply. :) I've just discovered my problem... something called 'alpha sorting glitch'. The plant section uses an alpha and it glitched the entire object. I went down the route of seperating the plant, applying a non-alpha version of the texture to the sign and importing the plant as a seperate object, and then linking the two pieces in SL.

The plant is still glitched, but according to what I've read the alpha glitch it something on behalf of the browser itself, and not my mesh (whew).

43645745.png

 

Share this post


Link to post
Share on other sites

That's odd. Usually, this glitch only occurs when both textures have an alpha channel. Did you upload both as PNG or TGA files? In that case, the texture that is supposed to be solid might have an unnecessary, plain white alpha channel.

  • Like 1

Share this post


Link to post
Share on other sites

I have tried both PNG and TGA formats on both the original single-mesh piece and the two seperated pieces. But there's no change whichever one I use.

The plant isn't deforming against the sign mesh now, it's turned on itself, although it's difficult to tell you'd have to walk around it in 3D to see the effects. The back leaves are coming forward, etc.

Share this post


Link to post
Share on other sites

What I mean is that both TGA and PNG files can contain unwanted alpha textures. I always save solid textures as BMP or high quality JPEGs to avoid that problem.

Btw, can't you sculpt the agave leaves like this:

agave leaf.jpg

...and apply a solid texture? That would solve the alpha sorting issue among the leaves.

  • Like 1

Share this post


Link to post
Share on other sites

I was thinking of sculpting the leaves real time, but currently with the alpha planes the mesh is a shocking 5 prims (just the plant component alone), which is a lot for a small thing, I thought.

But it seems this is the only viable option here. :) So that's what I'll do. Thanks so much for your help. :3

Share this post


Link to post
Share on other sites

Hi there :)

In Photoshop, you can get rid of the alpha channel in png files by not saving like you would usually do, but instead clicking "File" -> "Save for Web and Devices". There, untick "transparency" and the alpha problem is gone. This way you can save a high quality png without the alpha glitch happening :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...