Jump to content
Sign in to follow this  
Gadget Portal

IE users- upgrade!

Recommended Posts

I don't want to turn this into a browser war thread, it's supposed to be helpful advice.

I know a lot of users do use Internet Explorer. While the advice "Never upgrade!" is great for SL software, it's not good advice for the rest of the Internet. Here's an article that offers some proof- http://www.nsslabs.com/company/news/media-coverage/internet-explorer-9-best-at-catching-socially-engineered-malware.html

So if you do use Internet Explorer (and don't want to change brands, for whatever reason), you should definitely upgrade.

Those of you that use other browsers, the article doesn't really apply- unless that is, you spend a lot of time on Facebook or something. Then you may want to consider switching.

Share this post


Link to post
Share on other sites

Interesting. Hmmm.... if IE 9, according to the article, detects 96% of all malicious links (99.2% even when the Application Reputation feature is enabled), and other popular browsers only between 7.6% (Firefox) and 13.2% (Chrome), doesn't that mean that everybody should upgrade to IE9?

Share this post


Link to post
Share on other sites

If they would make this SL software compatible with it I would. That is really the only thing that is holding me back at this point.

Share this post


Link to post
Share on other sites

I wouldn't say that, Ishtara. The article doesn't include antivirus software, addons, and as Chris says, missed a couple updates on the other software, so I wouldn't say everyone should switch to IE9. But definitely upgrade to 9 if you do use IE.

Share this post


Link to post
Share on other sites


Keli Kyrie wrote:

If they would make this SL software compatible with it I would. That is really the only thing that is holding me back at this point.

What problems do you have? I've been using IE9 with SL with no issues. I'm using IE9 to make this post.

Share this post


Link to post
Share on other sites


Gadget Portal wrote:


Keli Kyrie wrote:

If they would make this SL software compatible with it I would. That is really the only thing that is holding me back at this point.

What problems do you have? I've been using IE9 with SL with no issues. I'm using IE9 to make this post.

I have not tried it yet, been afraid to, I heard posts show up blank and that you have to use something called compatibility mode. Is that not true? If so I can get rid of that annoying little update warning and update.

Share this post


Link to post
Share on other sites


Keli Kyrie wrote:


Gadget Portal wrote:


Keli Kyrie wrote:

If they would make this SL software compatible with it I would. That is really the only thing that is holding me back at this point.

What problems do you have? I've been using IE9 with SL with no issues. I'm using IE9 to make this post.

I have not tried it yet, been afraid to, I heard posts show up blank and that you have to use something called compatibility mode. Is that not true? If so I can get rid of that annoying little update warning and update.

You're thinking of Compatibility View. It's a little icon up next to the URL. It's a simple one click toggle. Some sites on the Internet do require it, I won't lie. However, I have it disabled right now, and I can see the SL pages just fine.

Share this post


Link to post
Share on other sites

While the advice "Never upgrade!" is great for SL software

 

No its not, SL software updates fix bugs and add features. Never upgrading SL softare is just lazy and bad for people on SL in general.

 

Also, most people, myself included, cannot use IE9, since its only for windows vista and 7. All those on windows XP and non microsoft platforms are out of luck, and since most of the people accessing SL are on windows XP, telling them to update to IE9 is the same as saying move to vista or windows 7

Share this post


Link to post
Share on other sites


Serith Haefnir wrote:

While the advice "Never upgrade!" is great for SL software

 

No its not, SL software updates fix bugs and add features. Never upgrading SL softare is just lazy and bad for people on SL in general.

 

Also, most people, myself included, cannot use IE9, since its only for windows vista and 7. All those on windows XP and non microsoft platforms are out of luck, and since most of the people accessing SL are on windows XP, telling them to update to IE9 is the same as saying move to vista or windows 7

Well, that's good advice too. Using an out of date, obsolete OS is a bad idea.

Share this post


Link to post
Share on other sites

I've never had to use the capatibility view with IE9 (and I've had it since I went Win 7 over a year ago).  I've never had the "blank" page thing.  There are several levels of security you can set with IE9 and I think that is probably at the root of the "blank page" problem.  If you are using IE9 at the "paranoid" security level you are going to have issues with some things (that is one to the settings you can set when you are on the Internet with IE9).

Share this post


Link to post
Share on other sites


Tristizia Demonista wrote:

Using an older OS might be the best choice, if the newer one is to heavy for the Hardware
:)

If your hardware can't run anything newer than XP, it might be time for new hardware, too. SL looks much better on modern hardware.

Share this post


Link to post
Share on other sites

Okay I upgraded. I don't like the tasb at the top like this is there a way to change that?

ETA: And where is my google search bar!!!?

Share this post


Link to post
Share on other sites

I actually like it more, I haven't looked at how to change it. By the way, you can set google search the same way as before- now it's combined with the URL bar.

Share this post


Link to post
Share on other sites


Gadget Portal wrote:

[...]While the advice "Never upgrade!" is great for SL software[...]

This is horrible advice, not just for SL but for everything....

The proper advice is "Only upgrade if there is a reason to", meaning bug fixes, security patches, or new features, that you do (or will) use, or that affect you.....

fortunately for average users, security patches are forced updates in the SL viewer, so they only have to decide whether a bug fix or new feature is worth upgrading for.

Share this post


Link to post
Share on other sites


Void Singer wrote:


Gadget Portal wrote:

[...]While the advice "Never upgrade!" is great for SL software[...]

This is horrible advice, not just for SL but for everything....

The proper advice is "Only upgrade if there is a reason to", meaning bug fixes, security patches, or new features, that you do (or will) use, or that affect you.....

fortunately for average users, security patches are forced updates in the SL viewer, so they only have to decide whether a bug fix or new feature is worth upgrading for.

Well, I only say it about SL because unless they're fixing bugs or indeed patching security flaws, LL generally follows the motto of "fix it until it's broken". 9 out of 10 people hate every cosmetic update LL puts out.

I will agree that I should have phrased that better, though.

Share this post


Link to post
Share on other sites


Chris Norse wrote:

Since Firefox is on V6  as of the last upgrade, I would have to question who researched  this article.

Yeah but Firefox was on v5 last week, and was only v4 two weeks ago, and v3 a month ago... Version numbers in Firefox now just mean 'Oh hai, I iz in ur bandwidth downloading mah filez' and come packages with a lol-fox.

As for IE: the reason browser stats for IE still show a majority of people on 8, and many even on 7 or (gasp) 6 - is sluggish IT departments in corps that fear having to 'make contact with the humans' by training people on how to use newer versions if they let them upgrade.

Spend anytime at work in a job where you have to go online (pretty much any sales, marketing, design, finance, and so on industry) - and you'll spend half your waking hours in front of an ancient browser that was 'chiseled in stone' onto your machine's hard drive.

 

 

Share this post


Link to post
Share on other sites


Gadget Portal wrote:


Tristizia Demonista wrote:

Using an older OS might be the best choice, if the newer one is to heavy for the Hardware
:)

If your hardware can't run anything newer than XP, it might be time for new hardware, too. SL looks much better on modern hardware.

No, really ? :)

Is there a way you will provide me with such a hardware ? :) 

Share this post


Link to post
Share on other sites


Gadget Portal wrote:


Serith Haefnir wrote:

While the advice "Never upgrade!" is great for SL software

 

No its not, SL software updates fix bugs and add features. Never upgrading SL software is just lazy and bad for people on SL in general.

 

Also, most people, myself included, cannot use IE9, since its only for windows vista and 7. All those on windows XP and non Microsoft platforms are out of luck, and since most of the people accessing SL are on windows XP, telling them to update to IE9 is the same as saying move to vista or windows 7

Well, that's good advice too. Using an out of date, obsolete OS is a bad idea.

In some cases it is not smart to update. I pity those that upgraded to Vista, what a waste of money, and so short lived as well. Besides the fact that a whole lot of XP users cannot upgrade due to the high cost of new OS systems. (unless you want to switch to Linux and get rid of IE all together)

That said: I am on an XP machine here, why? I do not want to upgrade to w7 at this point, since it is overly expensive, and soon to be obsolete as well. 

Microsoft made an, in my opinion, critical mistake by making IE 9 for vista or w7 only, and they are continuing this mistake because all Vista users will NOT be able to upgrade to IE10 when it comes out.

The result is that IE lost market to mostly Chrome and Firefox and a little to Opera.

My suggestion for XP users is either Firefox or Chrome, they are just as advanced and well protected as IE and run on XP. I cannot recommend Opera since I never tried it, my recommendation is purely from a personal experience.

Share this post


Link to post
Share on other sites


Benski Trenkins wrote:


Gadget Portal wrote:


Serith Haefnir wrote:

While the advice "Never upgrade!" is great for SL software

 

No its not, SL software updates fix bugs and add features. Never upgrading SL software is just lazy and bad for people on SL in general.

 

Also, most people, myself included, cannot use IE9, since its only for windows vista and 7. All those on windows XP and non Microsoft platforms are out of luck, and since most of the people accessing SL are on windows XP, telling them to update to IE9 is the same as saying move to vista or windows 7

Well, that's good advice too. Using an out of date, obsolete OS is a bad idea.

In some cases it is not smart to update. I pity those that upgraded to Vista, what a waste of money, and so short lived as well. Besides the fact that a whole lot of XP users cannot upgrade due to the high cost of new OS systems. (unless you want to switch to Linux and get rid of IE all together)

That said: I am on an XP machine here, why? I do not want to upgrade to w7 at this point, since it is overly expensive, and soon to be obsolete as well. 

Microsoft made an, in my opinion, critical mistake by making IE 9 for vista or w7 only, and they are continuing this mistake because all Vista users will NOT be able to upgrade to IE10 when it comes out.

The result is that IE lost market to mostly Chrome and Firefox and a little to Opera.

My suggestion for XP users is either Firefox or Chrome, they are just as advanced and well protected as IE and run on XP. I cannot recommend Opera since I never tried it, my recommendation is purely from a personal experience.

You can't expect them to support Windows XP indefinitely, either. It's already ten years old. I don't blame them for making their newer software not compatible with it. A lot of new software on the market now doesn't have XP support anymore, not just IE.

 

As for Vista- I used Vista, now I use Windows 7. Both are improvements on Windows XP, Windows 7 being a significant improvement (although I will admit, I would have had a lot more trouble with Vista had I not built my computer to take advantage of it).

Share this post


Link to post
Share on other sites

While win7 is pretty nice, there is no noticeable difference to running SL on it or XP... unless you happen to be running a 64bit version of either in which case drivers are occasionally hard to find for some things. In fact, using the same machine, XP should run faster than win7, both in default and tweaked.

Vista is a whole different ball game... and if you have the misfortune to be stuck on it, you have my sympathies.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...