• Announcements

    • Xiola Linden

      The New Community Platform   03/21/2017

      We are still working on making adjustments and changes to the new platform. Thanks  to everyone who has been sending in feedback and filing any bugs you've encountered! 
Sign in to follow this  
Followers 0
kurtfreund786

Firestorm beta -- BEWARE!!!!!

15 posts in this topic

I have been using computers since the Sinclair and currently I am having the most bizarre and serious problems I've ever had. There are indications that the source of these problems is a recent Firestorm beta.

My current computers are an iMac and a Macbook Air running OS X 10.7 (Lion) and a PC running Windows 7. I also have an XP laptop on which I did not install Firestorm. I was entering Second Life on a regular basis using my Apple computers and, primarily, Phoenix Viewer and Cool VL Viewer. There were no problems. Then one day I started Phoenix and it said an update was available, so I installed Firestorm.

Firestorm worked a couple of times and I liked the interface. Then the first problem started to occur - I lost the ability to right-click. Restarting Firestorm fixed that for a short while, but then it recurred. Eventually I decided to continue without right-click capability as long as I was able to do so.

Shortly thereafter the second problem started - the pointer disappeared. Naturally, that made it almost impossible to continue. Yet the problems were just beginning. I was able to Cmd-Tab (OS X equivalent of Alt-Tab) out of Firestorm, but the pointer was still missing. I had to shut down the Mac using the power button. OS X came back up, but after several minutes (without restarting any viewer) the computer froze with the message: "You need to restart your computer. Hold down the Power button until it turns off, then press the Power button again." 

After the second restart the computer ran okay, but since people were waiting for me to return to Second Life and I was leery of using my iMac, I decided to use my Air. Since I didn't suspect Firestorm as being the cause of the problems, I installed it on the Air. Very shortly thereafter I had the very same problems. At the time I assumed it was some kind of issue with Lion, so I pulled my HP laptop out of the closet. I installed and ran Firestorm on Windows 7 and within one hour I experienced three Blue Screens of Death.

By that time I did suspect Firestorm, so I went back to my iMac and started Cool VL Viewer, an older viewer that I had used many times. The same problems occurred in that viewer!

I decided that the safest course was to download and run SL Viewer 2. However, the problems occurred again.

My next attempt was to delete all OS X preference files related to SL viewers and try again to run SL Viewer 2. Even that did not work.

Currently, I have not figured out a way to get on Second Life again using either of my Apple computers. On my Windows 7 PC I was able to do some OS upgrades and I can run SL Viewer 2.

Please note that I have no hard evidence that Firestorm beta was the cause of these severe problems, but they did appear only after I had run Firestorm.

Share this post


Link to post
Share on other sites

There are known problems with the graphics drivers in Lion. See this post on the Phoenix Wiki

 

http://wiki.phoenixviewer.com/doku.php?id=mac_os_x_10.7_lion_problems&s[]=lion

 

I can access SL fine from my iMac using both the latest Firestorm Beta and Phoenix. I had to make the changes noted in the article above to get my MacBook Pro tp work. This also seems to affect the SL 2.x viewer but I am not sure.

HTH

PS> There are also some other problems reported with other applications, including Quicktime - the Apple Discussions board is full of issues

Share this post


Link to post
Share on other sites

Firestorm runs just fine on my MacBook Pro but, I'm still using Snow Leopard. The problem as pointed out above is the fact that none of the v2 viewers (including the official LL version) are fully compatible with Lion. There's a sticky from Esbee Linden at the top of the SL Viewers forum page that mentions this.

Share this post


Link to post
Share on other sites

Thank you -- hopefully that will be very useful. However, it does not explain the three BSDs in Windows 7.

I posted on the Apple board about troubles with Second Life and the moderators removed the post. They do, as you probably know, run that board with an iron hand. Knowing that, however, my post said nothing negative about Apple, so I guess they're a bit sensitive about the problems.

Thanks again.

Share this post


Link to post
Share on other sites

The Phoenix wiki says that Macs with ATI cards seem to be running okay under Lion. Not so. My card is ATI Radeon HD 5670 512 MB.

Share this post


Link to post
Share on other sites

I have had no  issues with firestorm running mac OSX 10.7 at all. I have a 2007 imac, with a ATI Radeon HD 2600 Pro graphics card, I also have phoenix 1185 and SL 2.8.1 on my mac as well. They all run mostly ok (SL 2.8 does have the thing where the top menu bar and top part of the viewer window go black) so it might just be something with your computer because i am running nearly the same type of computer wih no issues. You might try talking to Phoenix/ Firestorm Support Group in world.

Share this post


Link to post
Share on other sites

Well, I was able to run Firestorm for a couple of days before the S hit the F, so good luck.

As for the Phoenix/Firestorm Support Group in world, I'd love to talk to them if I could get in world.

 

I'm trying some different things: running Firestorm on my Windows 7 PC again to see if the BSDs return. I'm also going to try running Firestorm under Parallels, although I have no idea if that makes any sense.

Share this post


Link to post
Share on other sites

I have been using Firestorm since the public beta came out, and other intenal betas. I have had no majotr issues with OSX lion once i updated to it, and neither has the mac dev or any other mac beta testers I am aware of. You might try contacting them by email if you cant get inworld http://www.phoenixviewer.com/support

Share this post


Link to post
Share on other sites

Can people using FIrestorm and Lion at least start IMs?

 EDIT: Looks like they, or at least I, can.

Firestorm ATM is the only v2 viewer that works for me chat wise.

 

 

Share this post


Link to post
Share on other sites

Contact someone in the Phoenix/Firestorm Support group and since you have it all written out here, you might just want to point them to this thread.  Hopefully they can help get you back up and running again.

Good luck ...Dres

Share this post


Link to post
Share on other sites

I don't know if all your computers are connected to a home-network but is it possible that all your devices are infected by a virus, worm or even a trojan?

Never heart of issues like that. I use Windows 7 and all the viewers you listed for more then a year now and all these viewers work fine with it.

Maybe you should check your devices with a antivirus-program, although you seems to be a pro in computers, an infection could happen to everybody.

Share this post


Link to post
Share on other sites

I was running ClamXav, but when this problem started I downloaded Sophos and did a full scan that took over a day - no problems.

Thanks.

Share this post


Link to post
Share on other sites

Interesting I had the same problem but on windows 7 .. well more or less same issues with Firestorm.  I work on games and am working on a game right now that is far beyond anything graphically anything out can do, and I can obviously run my work project on max. In fact everything runs fine, i'd know, but SL just doesnt run anymore after years of running. Started with installed Firestorm, which I only did because of the GL issue currently going on with the official viewer that extends beyond 400 or 500 series cards, because people claimed the crashing was less, but that wasn't true. Anyway, don't need to explain things that are work related here and I'm not asking from help since i am the help.My problems too did only occur after running Firestorm.

Share this post


Link to post
Share on other sites

I have a mac book pro, i had no issue with the phoenix version but the firestorm beta version is testing my patience ,it does i am using the Maverick version on my macpro and my mouse goes crazy takes forever for things to load, bridges do not complete, more crash issues i have been asking people for there thoughts and views and some said to install the old phoenix version again.  any thoughts on a different viewer?

Share this post


Link to post
Share on other sites


cara Hema wrote:

I have a mac book pro, i had no issue with the phoenix version but the firestorm beta version is testing my patience ,it does i am using the Maverick version on my macpro and my mouse goes crazy takes forever for things to load, bridges do not complete, more crash issues i have been asking people for there thoughts and views and some said to install the old phoenix version again.  any thoughts on a different viewer?

Singularity seems to be the go-to viewer for people who prefer the old UI... here's the link.

...Dres

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  
Followers 0