Jump to content
Sign in to follow this  
Sommer Restless

Has anyone successfully rigged a mesh in Maya?

Recommended Posts

Heya, I was wondering if anyone had successfully rigged a mesh using Maya and Maya alone. 

I've been trying for DAYS. And obviously I am doing something wrong. I'd love to know if anyone else accomplished it, and if so, how?

Share this post


Link to post
Share on other sites

Hi Sommer yes I have uploaded rigged mesh avatars :D You must keep in mind that right now it is beta and software are being updated constantly and things are changing sometimes on even less than a days time. When you don't fully understand your pipeline, as they call it, such that when something isn't working it is because it is the software, it is going to be very confusing for you and it's not you it's just that things are changing so much you have to constantly stay up with it to be able to know what is going on :D I really hope this helps

With all that being said the Mac version of the viewer will not allow me to upload partial bone sets in the traditional smooth bind I use for an avatar but I have done my avatar many times and others and all have worked in Maya. Any problems were know issues.

EDT: also the FBX_dae exporter now works which it wasn't as well as the open collada tried them both for avatars

Share this post


Link to post
Share on other sites

Open collada not work for riged meshes - Use Autodesk FBX Colada Dae exporter 

I test with Maya 2010/2011 and work fine , In DAE exporter options find and check option Z-UP

You can test and my Plugin for Maya 2010 and 2011 - work only for Window XP

For now mesh is not riged, I dont know how to add weights in Maya, but you can use Mesh(shape), skeleton, UW maps

 

Share this post


Link to post
Share on other sites

I use Maya 2011 on Mac with Open collada and it works fine EVERY time, for rigged avatars. The FBX_dae exporter as of recently works as well that is something that has just recently started working though. As far as partial bone sets as if you were just exporting a piece of clothing those do not work no matter what I do, unless all 26 bones are in the .dae file no upload is happening. One way I have found to do this is with Maya 2011 is using an interactive bind which includes all bones even if you are just trying to rig a shirt. I am on a Mac so thins may make some things work differently as other programs related to SL and Mac work differently.

Share this post


Link to post
Share on other sites

It appears you have been able to upload so that would constitute being able to upload a rigged mesh :D congratulations :D now as far as your rigging goes that is gonna need some work :D I would assume if you got it uploaded you followed my suggestion to use interactive skin bind. Now you need to go into the interactive skin bind tool and adjust your skin weights. If you just did a regular smooth bind then you need to use your paint skin weights tool or your component editor to be able to adjust the skin weights. Then you wont have anything sticking through. Also a partial body alpha will help to keep unwanted body parts showing through.

Searching rigging in Maya specific to the type of rigging your trying should yield you some great tutorials on how to do it. Don't worry that they aren't specific to SL as rigging has nothing to do with SL other than the classic linear type bind is what SL requires. I hope this helps and please understand I know you said you were a fast learner but just to give you an idea a fast learner may be able to learn rigging in about a month or two not a day or two. Hope this helps and happy rigging :D

Share this post


Link to post
Share on other sites

Yes the default SL skeleton which you can get several different ways one of which is in the link I gave you in the other thread, it's in the first post by Reed Steamroller. There is some other valuable information in that thread as well, but be careful some of the stuff is now not functional in SL cause of changes in the viewer.

Share this post


Link to post
Share on other sites

One thing for me that was messing up uploading rigged avatars from Maya was accidentally having the rig in a group.

You may want to open Hypergraph, and verify that your rig is not part of a group (mPelvis should stand on its own in the heirarchy.)

If there is anything above mPelvis, select it, and ungroup.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...