Jump to content

Awkward AO transition


You are about to reply to a thread that has been inactive for 4059 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

I was working on a furry AO that involves replacing the standard standing & walking animations with a position on hands and knees for crawling. Learned qavimator, created a fairly smooth crawl... but there's a problem with the transition from standing (on hands and knees) to walking (crawling). For a brief instant, the avatar goes from horizontal to vertical, while still retaining the bent arms and legs of the kneeling position, before going back down to the right position to begin crawling during the walk phase. Changing back from walk to crawl doesn't seem to do this. Per the qavimator instructions I left frame 1 alone, in the standing position, and told it to start looping at frame 2. Just for fun I tried replacing frame 1 with another kneeling position, but the result was that the avi walks around upright, but with arms and legs bend in the crawl position. The whole reason I started this project was to replace a freebie animation that has the same problem, so it's not just me. What causes this, and is there a way around it? The whole illusion is ruined when the avi suddenly jumps upright before starting to crawl. Contact me inworld if you need to see what I'm talking about, or if you need me to send you the .bvh file.
Link to comment
Share on other sites

This is something that LL REFUSES to fix. Despite their own residents figuring out the problem and coding the fix for them over 2 years ago, they still REFUSE to fix it. The only way to minimize this problem is by adjusting your IN% to bypass the affected area within the bvh. Essentially, the uploader adds extra frames to a looping animation. All looping animations are affected by this, it is just most obvious when you put the avatar closer to the ground. The workaround that I mention does not fix the situation completely but it is much better than just leaving it the way it is. And, the shorter or less frames you use to make the animation, the worse it will be.

Oh, and the KICKER, it is likely that eventually LL will release another viewer which compounds this issue and makes people like myself have to go back, make further adjustments and release a new version. In all likelyhood, that freebie animal walk you have, at 1 time worked perfectly.

NOTE: other platforms that use the same SL code do not generally have this issue, this is just an SL problem.:smileysad:

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 4059 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...