Jump to content
Sign in to follow this  
Six Igaly

Viewer 2.8.. FIrst impression

Recommended Posts

Well, the build tool shows prim count again, that is a pro. Environment editor in estate tools is cool (although a bit limited as far as i can tell) but then...there are a number of textures that are not rendered anymore (alpha textures).  The shadows do show lol. 

Snapshot_001.jpg

Share this post


Link to post
Share on other sites

All I know is that my SL Viewer was working fine, until 2.76 (or something like that), and now it crashes and burns every time.

I've cleared out the Application Data Folder and uninstalled, and tried previous versions of 2.7, and crash every time.

Perhaps 2.8 will work?

Share this post


Link to post
Share on other sites

The viewer 2.7.2 was PERFECT...from 2.7.4 no more basic shadows....sea water is ugly,,,,,glow property doesn't run...fullbright is visible only by night light....checking basic shadows you fall in a black hole....

The 2,7,2 version is not more accepted for isntalling and immediately overwritten by the 2.8.1...that is the same that 2.7.5 that doesn't allow basic shaders.

Many objects built with light effects - glow and fullbright - don't run anymore.

Why so much work to destroy something that was very fine ?

Waiting for a 2.9.x with our shaders !!! 

 

Share this post


Link to post
Share on other sites

Well basically this 2.8 update has broken my SL! 

I can't move… the lag is beyond ridiculous. My graphics are set at mid and it's like wading through treacle (molasses).

On the upside my garden has reappeared and I can count prims.

 

:::sighs:::

 

Share this post


Link to post
Share on other sites

I'm having the exact same problem. What are your system specs (OS, hardware, etc...)?

 

I'd like to compare and see what's causing it. I had to turn off shaders to move around.

Share this post


Link to post
Share on other sites

Hi Tristan,

I'm running an iMac 3.06 GHz Intel Core 2 duo with 4GB 800Mz DDR2 SDRAM

VidCard: NVIDIA GeForce 8800 GS

Things were pretty good up to about V2.4 or 5 then it all started to snarl up… and now it's just totally broke for me!

Share this post


Link to post
Share on other sites

On my 2011 powerbook I've taken a 50% performance hit for some unknown reason with 2.8 and it's gotten completely crashtastic.

Now I know how those Nvidia folks have been feeling I guess.

Share this post


Link to post
Share on other sites

There are some serious issues with 2.8 - I have been running the nightly build for some time now and can tell you that many things are better and many things are worse - especially rather worrying performance dips.

It looks like a lot of the good work improving stability and performance up until 2.7 is being thrown away in the rush to get mesh and other features in.

And you really need to fill this vacancy quick: http://lindenlab.hrmdirect.com/employment/view.php?req=72717

Share this post


Link to post
Share on other sites

CPU: Intel® Core i7-2600 CPU @ 3.40GHz (3400 MHz)Memory: 4096 MBOS Version: Mac OS X 10.6.8 Darwin 10.8.0 Darwin Kernel Version 10.8.0: Tue Jun  7 16:32:41 PDT 2011; root:xnu-1504.15.3~1/RELEASE_X86_64 x86_64Graphics Card Vendor: ATI Technologies Inc.Graphics Card: ATI Radeon HD 6970M OpenGL Engine
OpenGL Version: 2.1 ATI-1.6.36

Share this post


Link to post
Share on other sites

yeah. it might be a bug in the Mac OS version.

 

I use a 27" iMac, 3.33, 8GB RAM, ATI Radeon 512 MB Graphics. usually push 40-50 FPS on average, with 2.8 it SUCKS.

 

I'm rolling back to 2.7. Turn off shaders and your performance will improve. but what's the fun in THAT? LOL

Share this post


Link to post
Share on other sites

Ok yeah, I'm thinking this is a problem with the Mac OS viewer, even though with most versions that Mac viewer has been more stable than the Windows viewer (i run both sometimes for kicks)

Share this post


Link to post
Share on other sites

UPDATE:  I have normal FPS with everything enabled using the beta SL viewer 2.8.1. Try that one. I haven't played with it long enough to report any issues, but my FPS problems went away as soon as I loaded it.

 

Cheers!

Share this post


Link to post
Share on other sites

I lost shadows with 2.7.4 and I don't see them again in 2.8. To be precise, I do see shadows, but they don't relate in any way I can see to the objects that might be shadowed. Not sure if this is my graphics card as they seem to work for others, details are:

Graphics Card Vendor: NVIDIA CorporationGraphics Card: GeForce GTS 250/PCI/SSE2
Windows Graphics Driver Version: 8.17.0011.9621OpenGL Version: 3.2.0

Otherwise 2.8 seems a considerable improvement over its immediate predecessors, though I find the user interface has become very sluggish, though rendering peformance is fine. I click on an inventory item and can count to 3 before it responds.

 

 

 

 

Share this post


Link to post
Share on other sites

I tested it out. I still get the friendlist glitch, but at least a fix for that is definitely planned with the Magnum RC regions, which I will test once its rolled out.

Aside from that, the new profiles I do like, though instead of "feed", the "about me" page should be open by default when opening profiles. At least for non-friends, thats the more relevant page to open.

 

Also, shadows work and look nice, but lordy does my graphics card spin up. when its sitting in comfortable idle mode at 60fps with deferred off in firestorm 2.5.2, its howling like a banshee at 30 fps with shadows on in 2.8. Its only a minor thing, but i wonder if there isnt more tweaking to be done in that respect. Just feels like there might be, but could be me

Share this post


Link to post
Share on other sites

The fps in 2.8.1 and .2 betas should be about normal if you turn off  VBO on the Mac. It is listed as a known issue in the release notes for v. 2.8.0 beta, but is not for 2.8.1 and 2.8.2 (I think).

On my system, disabling VBO makes the Mac run hotter, and I *really* don't need that, so I'm sticking with 2.7.5 for now.

ETA. I didn't realize that v. 2.8.0 was out. What I say above is for the beta versions.

- Luc -

Share this post


Link to post
Share on other sites

FPS wise and things everything seems fine with 2.8

 

The major problem I now have is my inventory window stutters. I click something in my inventory, SL locks up for a second. Open a folder in my inventory / Rename Something / Make a new object - All cause stutters.

 

Seeing as I'm a builder on SL this is making things really awkward so I'm gonna be forced to use an alternative viewer I think D;

Share this post


Link to post
Share on other sites

Well, i just installed 2.8.1 and it crashes me just as much as when it was beta. Also transparent texture issue still occurs! So this time i will violate my own rules....i am downgrading to 2.7.52 :matte-motes-dont-cry:

Maybe i will wait for viewer 3 now :matte-motes-big-grin:(which hopefully is also Lion compatible).

Share this post


Link to post
Share on other sites

Totally against my own rules..downgraded even back to 2.7.2 just now!  Works perfect, have my shadows and all transparent textures render as they should!  No crashes either.  So no updates anymore untill i hear everybody is hysterical about the latest and best version ever! Or of course till the viewer finally forces me to upgrade again :matte-motes-big-grin:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...