Jump to content

OS X: 2.8Ghz Core i7/ATI4850 vs OS X:2.8Ghz Core2 Duo/nVidia 8800S + Shaders (Makes me CRY)


You are about to reply to a thread that has been inactive for 4084 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

 

Hi There,

I have two macs.

Whilst the Mac I usually use (the 27" iMac with a Core i7/2.8Ghz and ATI4850) certainly outperforms my other Mac (the 24" iMac with a Core 2 Duo/2.8Gz and nVidia 880GS - it's a NOTEBOOK graphics card) when not running the new shaders for shadows, when I add the shaders in:

 

  • The nVidia 8800GS runs my own sim at about 18-20 fps
  • The ATI4850 runs my own sim at about 5-7 fps

 

This is so disheartening. The machine with the ATI4850 was a top-of-the-line machine when I bought it. Now I know that the ATI cards in iMacs have always been problematic and it appears that the ATI cards regardless of Mac are not as well supported in SL but this is just silly.

It annoys me that a LAPTOP quality 8800GS can outperform the ATi4850.

Does anyone know anything about this?

 

  • Yes, I know about the custom and advanced settings;
  • Yes, Render Apple Multi GL is on

 

JW

Link to comment
Share on other sites

Hmmm.... If I'm not mistaken, the graphics card in the iMac is also a mobile version.  Which might explain some of it, but the differences seems quite substantial. Have you tried the latest beta viewer? It is supposed to be quite a lot better than the current production version.

- Luc -

Link to comment
Share on other sites

 

I have taken a look at it; at the moment I can't quite decide whether it is better. Switching viewers without also switching one's cache on Macs tends to confuse the texture caches. Then, it takes the viewer quite a while to recover (trust me, I am quite used to the various ways to convince textures to actually load on macs - let's put it this way, there are times when something 200m away will load perfectly but the board with a single, small texture right next to my avatar will stay resolutely gray).

That said, let's just say Viewer 2.8 for the 10 minutes I looked at it -- I am meant to be studying -- gave me a frame rate of about 1-1.5 fps. 5-8 fps is sort of usable; not very mind you. But 1-1.5fps is a joke. However as noted in the previous paragraph I think this was more that the viewer got confused rather than it really was 1-1.5fps.

 

JW

Link to comment
Share on other sites

(I was a bit unclear before - both iMacs have mobile versions of the graphics cards)

Something is not right here... I have an old iMac - way older than yours - with an ATI card which I believe give better fps than yours. You should definitely get more than 10 fps on the newer iMac, for sure.

What are your graphics settings?

- Luc -

Link to comment
Share on other sites

  • 2 weeks later...

One think you defintely should try is turning off VBO in the hardware settings. Also, try set the anti-aliasing to 2x. As you have seen, the latest viewer - 2.8.0 - and the latest betas does not work properly with this on. V. 2.7.5 works well on my MBP with VBO on but not the latest viewer. (This is in the release notes too). I tried it and have the same issue - between 1 - 3 fps with VBO turned on.

I have to say, I have never set any viewer to Ultra on any of my Macs - not even on the latest generation MacBook Pro 17". I always leave it a bit lower than that. Never understood what hardware skinning does, and have not seen any difference in fps with it on or off. I usually leave particles at around 2500, but water reflections at 'Everything'. I also leave imposters on and set to 12.

http textures might affect texture rezzing - it does for me so I keep it disabled - but should not have an impact on fps.

My guess is that the VBO setting will make a difference, but I'm not entirely certain.

- Luc -

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 4084 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...