Jump to content

Why are my Meshes Showing up as Prims?


Runitai Linden
 Share

You are about to reply to a thread that has been inactive for 4140 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

  • Lindens

Short version: Update to build 236082 or later if you're seeing prims where you used to see meshes.  236082 is building now (2011-7-18 21:12 SLT) and might not be available.

Installer links here:

Windows -- http://automated-builds-secondlife-com.s3.amazonaws.com/hg/repo/mesh-development/rev/236082/arch/CYGWIN/index.html

Mac -- http://automated-builds-secondlife-com.s3.amazonaws.com/hg/repo/mesh-development/rev/236082/arch/Darwin/index.html

Linux -- http://automated-builds-secondlife-com.s3.amazonaws.com/hg/repo/mesh-development/rev/236084/arch/Linux/index.html

 

Long version:

In an attempt to make some non-mesh enabled viewers (i.e. viewers based on the 2.7.2-2.7.5 releases) display something meaningful (and not crash) when encountering mesh content, we're testing out a protocol change that is not backwards compatible with old mesh viewers.  A simulator using this protocol has been deployed to the Mesh Experimental channel, so you'll need to update to the latest mesh viewer to view mesh content on the following regions:

Mesh City 2

Mesh Sandbox 1, 20, 21, 27, 28, and 32

MeshHQ 3

 

The new viewer *is* backwards compatible with old sims, so you can use it everywhere, not just on Mesh Experimental sims.  If you're wondering how we pick which prim to show for which mesh, it's based on the number of texture entries in the mesh asset (the prim you see has the same number of texture entries as your mesh).  Your mesh object will also appear as this prim if you take it to a region that is not mesh enabled, and this is the prim that people with any legacy viewer will see in place of your mesh.

 

 

 

 

 

 

  • Like 1
Link to comment
Share on other sites

Ok now. I think Iwould rather people saw nothing, or maybe a just-visible untextured ghost, rather than great big inappropriate shapes. What are baked textures going to look like on these? This is sort of replicating the horrible sculpty blob phenomenon, but for ever! I suppose it will help to drive people away from the legacy viewers. Is that the reason for doing this? On the other hand, it will make them hate meshes first.

Link to comment
Share on other sites

I had posted this in another thread, but I think it is more suited to this one.

 

I decided to come in and have a look with Phoenix Viewer 1.5.2 (1102) May 14 2011 18:19:22 (Phoenix Viewer Release).

Here is me wearing my rigged mesh dress and shoes. I had to be careful of angles, because the alpha layer did not show on this viewer and I wanted to keep things PG.

Mesh Dress.jpg

Mesh Shoes.jpg

Here are pictures I took of my cooking hearth and table.

Mesh Cooking Hearth.jpg

Mesh Table and Rigged Dress.jpg

These last two items are not mine, but I thought they would be good because you know what they should look like. The first are Daniel's palm trees, and the second is an ice freezer.

Mesh Palm Trees.jpg

Ice Machine.jpg

I think it is nice of the Lindens to try to make something better than triangles appear to those using non-mesh compatible viewers. I think trying to make them look like anything is probably a pretty tough job, and this might be the closest they can come.

In my own opinion, I would not recommend they try too hard at this. People will move to mesh capable viewers if they don't want to miss out or if they want to see the world fully. If they choose not to, well, it is their choice. It is a valiant effort to support the Luddites, but do not waste too much time on it.

Link to comment
Share on other sites

Hey everyone! I am on the Mesh Viewer. Where are all the menus? Preferences, inventory, etc?

 

Is there a way I can get all my menus back, including advanced? I would like to shoot machinima of a mesh build we are doing in the near future- so does Flycam work and would I be able to hide all my menus easily?

 

Sorry-- very lost!

Link to comment
Share on other sites

Sounds like you logged on in Basic Mode. :matte-motes-silly: If so, on the Login screen, choose Advanced from the dropdown where it says Basic.

Oh, I see you got an answer already elsewhere. I shoudn't read the forums from bottom to top. :matte-motes-nerdy:

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 4140 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...