Jump to content

New viewer 2.7.4 for Mac not working properly?


Jenn Raymaker
 Share

You are about to reply to a thread that has been inactive for 3643 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

I am having this EXACT SAME issue! I have a Mac too, and I downloaded the 2.7.4 version. I couldn't see ANYTHING except the sky and the water. I couldn't even see my avatar!! She's COMPLETELY invisible. I went back to version 2.7.2, and even though I could see a few more things (like trees and flowers), it's still pretty much the same thing. The only thing I could see on my avatar is her hair! Then I went even further back... to the 2.7.1 version. The same things are visible on that. It's like the 2.7.4 version corrupted all the other versions on my laptop! 

I don't know what to do either! And I'm kind of freaking out because I put a lot of work (and money) into my avatar and if I lose that information... 

Anyway, can ANYONE help?!!! I would also like to know how to fix this. NOW!

Link to comment
Share on other sites

I fixed it! (I posted up a thread and the solution is in there but I'll restate it here.) 

First of all, don't use Phoenix because they're about to get rid of it in the next month or something like that. I'd hate for you to get used to using it and realize one day you can't use it anymore. Use Firestorm if you must... BUT you don't have to. And I'mma tell you why: 

We, Mac users, don't have to shy away from SLV2. We can use it. Like I said before, prior to the update to 2.7.4, I didn't have any real problems with 2.7.2 (except for the occasional crash, but that's pretty typical with SL). Yesterday, I downloaded Firestorm and was using it, and even though it's the most similar to SLV2, the interface still has many differences that annoy me. And it would lag A LOT. So, I looked at other options and tried other viewers: Singularity, Imprudence, and Kirsten. Disliked all of them. 

Today, I thought maybe I should I log in through SLV2 again, to see if things might be different. (I hadn't deleted SLV2 from my computer.) I logged in and the problem was the same: everything, but water and the sky, was invisible. Then remembered that I had to raise my Quality settings on Firestorm, so I went to the settings and saw it was on "High". I raised it to "Ultra" and nothing really changed. So, lowered it to "Mid", and almost everything became visible again! Some things still weren't, so I lowered even further to "Low" and everything was visible. Simple fix!

Apparently, even though my settings were on high in 2.7.2, my computer can only take low in 2.7.4. And the graphics are still the exact same quality they were in 2.7.2 on high. So, there's no sacrifice there, in case you're wondering. 

So... if you have my exact same problem: Me > Preferences > Graphics > Quality and speed. Now we as Mac-users can still use SLV2 and get the best, most up-to-date SL viewer. Hope it helps you guys and all Mac users!

Link to comment
Share on other sites

I'm having the very same problem since the latest Beta Update for Mac.  Prior to that I hadn't had any problems but now I can't move, and everything laggs to the point where i can't even chat locally.   I sure hope someone has another update to fix these problems soon because as it stands I can't stay on SL for more than a few mintues without great frustration.  Anyone have any suggestions that might help?

 

 

Link to comment
Share on other sites

I have a MacBook Pro (Updated to Version 10.6.8) with an 8GB RAM card and whenever I try to log in almost every viewer gives me the spinning beachball and the SLV2 Official Viewer doesn't allow me to log in but doesnt have the spinning beachball and I tried everything to fix it. I used the Disk Utility repaired permissions and did someother first aid work to it. I tried reinstalling viewers, clearing the second life folder in the Library, and nothing seems to work. Can someone please help me?

Link to comment
Share on other sites

  • 2 months later...

Using a new MacBok Pro and have downloaded the SL viewer now available on line .. Result is that the log-in fails at the "region" stage.  Downloaded Firestorm Beta... result is very same.

Apparently Linden Labs dont like Macs...  Linden Labs, you got a problem way more important than serving the builders and folks who want to see the leaves on the trees...and that is...New arriivals find SL hugely difficult to use!   And of course, if u have a Mac, you can not use it all !  What a mess, no wonder SL is dying.

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 3643 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...