Jump to content
Sign in to follow this  
Loki Eliot

MAC USERS - OSX LION POSSIBLY OUT END OF WEEK! DOES IT RUN SLVIEWER???

Recommended Posts

OK so reports are suggesting Apples OSX Lion may be released end of this week. So far i have heard NOTHING on wether SL works on it, in fact i've heard mostly that it does not.

Has ANY mac users got the SLviewer to work on OSX Lion Developer Seeds? or are we going to start seeing MAC users dropping off the Grid?

Share this post


Link to post
Share on other sites

I highly doubt it. (Edit: I doubt it is the end :smileytongue:)

If there isn't a work around it's probably not a MAC.  

 

My two favorite MAC - ronyms are:

Makes Adults Cry

Many Additional Components

 

I'm run by Windows... I mean, ... I run Windows.

Share this post


Link to post
Share on other sites

Second Life has worked just fine on Lion for months (and they fixed a lot of the driver issues, too). I've been using it. This is true of versions 2.3, 2.4, 2.5, 2.6 and 2.7 (and 2.7.2), as well as Firestorm and my own work. I haven't tried anything else.

 

Second Life 2.7.2 (233432) Jun 21 2011 17:17:16 (Second Life Release)You are at 297647.0, 255774.0, 24.1 in Andretti located at sim21001.agni.lindenlab.com (216.82.30.35:13006)Second Life RC BlueSteel 11.06.28.234196CPU: Intel® Core i7 CPU         870  @ 2.93GHz (2930 MHz)Memory: 12288 MBOS Version: Mac OS X 10.7.0 Darwin 11.0.0 Darwin Kernel Version 11.0.0: Fri May  6 22:16:19 PDT 2011; root:xnu-1699.22.53~1/RELEASE_X86_64 x86_64Graphics Card Vendor: ATI Technologies Inc.Graphics Card: ATI Radeon HD 5750 OpenGL EngineOpenGL Version: 2.1 ATI-7.0.82

 

Share this post


Link to post
Share on other sites

i don't have lion yet, however, yesterday i downloaded 2.7.4 and now i log in my avi appears naked, bald and only partially razzed, and my sim won't rez beyond a few dunes and water. the problems seems to also have affected 2.7.2 as well.

has anyone had similar issues and/or found solutions?

thanks,

om~

Share this post


Link to post
Share on other sites

Thats a shame, LL were doing such a good job getting it to work on my new Mac, then about a week ago something went wrong and they re-introduced the stutter bug. Lukily i keep old Dev  builds that work well in case of such an event. 

It's starting to look like a circle of events. They get it working for a week, then break it for a couple of months then fix it again, then break it again. 

https://jira.secondlife.com/browse/SH-2031?page=com.atlassian.jira.plugin.system.issuetabpanels%3Aall-tabpanel

But they do work hard, i just think maybe they get confused with all the different Dev builds knocking about they end up re-introducing bugs AND merge them with all the other builds of viewer.

Share this post


Link to post
Share on other sites

I just installed Lion Mac OS X 10.7 over the top of Snow Leopard.

After dowloading the update - but before installing - you can make a backup bootdisk from the InstallESD.dmg (it's about 3.7 GB)

 

SL is running great with it :)- I am using Second Life version 2.6.9.231049 which is Second Life Project Viewer - Search.

Just remember you will no longer be able to use any old Power PC apps after installing Lion.

Also - you may want to go into your Mac System Prefs/ Mouse/ and Uncheck the *Move content in the direction of finger movement when scrolling or navigation*. Unless you like scrolling in the opposite direction ;)

 

Share this post


Link to post
Share on other sites

I am using Phoenix in a Mac, using Lion, and I have no problems for the moment, except that at beginning, before enter in SL, the program asks me for some skies losts (those skies like A-9PM etc.) I'll try to reinstall the program. In fact, when I am in SL, all seems run well...

Xente

Share this post


Link to post
Share on other sites

Phoenix works fine. I too have the "skies lost" issue. Will report back after reloading. Oh, if you noticed the lack of repeating characters ... It's a "feature" of Lion.r

Share this post


Link to post
Share on other sites

Oh hello everybody.

Running Phoenix and Firestorm on Snow Leopard right now. And while both do an awesome job on my MBP (Nvidia 9400M graphics) performance is not exaclty good. I found out that it is due to really bad drivers from nvidia ...

So my question is in addition to how any current viewer runs on Lion in general, is the problem about inconsistent framerates with activated VBO fixed???

For those who do no know about it: VBO usually increases the framerate in OpenGL easily by 50% compared to it switched off, But since 10.6.4 the Nvidia driver was totally screwed up and caused to drop framerates heavily every time you turned around, meaning you looked in another direction. So in the end the function was useless and I went for racing/flying with low fps rather than having fps drops that freeze your view for seconds sometimes.

Share this post


Link to post
Share on other sites

They did fix it for a month then broke it again, but this time it seems to be affecting all systems, mac, windows and Linux. 

The Jira for the 'stutter bug' is here they are working hard to re-fix this issue.

 

Share this post


Link to post
Share on other sites

Thanks a lot for the Demo Video. So this looks exactly the kind of thing i am talking about. However i read youre on ATI Graphics which work way better to begin with on Mac OS X 10.6.4 and above zo begin with than the Nvidia ones, due to driver issues. I did a lot of reading an looking for related problems and Vertex Buffered Object are a pain since said Mac OS update containing a seemingly worse Nvidia Driver.

Your specs even indicate ANYTHING should run smoothly on OpenGL ;)

I just hope i find some sort of advice weather Lion has better drivers for Nvidia Cards. In the end it would mean to me the only reason to upgrade honestly.

Do you think making a screencast ond submitting it migth emphasize the need for improvement, both for Nvidia and LL? I would gladly make one to demonstrate teh nature of the problem I experience. I think developers just either put not enough efford in Macs or are simply too few.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...