Jump to content

a 10th gen i7 and a RTX 3070 not enough for PBR to run shadows


Recommended Posts

al least according to the hardware probe and settings changed when it starts. Of course it handles shadows fine I wonder why it has to turn it off,  sets antiailsing to 2, avi detail all the way down....

Is there a way to disable this hardware probe and auto setting at start up? I have both FS legacy and PBR running and when I switch from one to another these settings are all changed, again. Would be nice to turn this off at start up. Also would be nice if the default 'start' on PBR didn't have mirrors on

Link to comment
Share on other sites

I'm running a Ryzen 9 7950X3D with a 3070, and I keep having graphics settings changed too. Shadows stay on, but the quality slider goes down one notch. It's random though. I can login ten times with no change and on the 11th, it's bumped down slightly (not specifically 10 and 11). Everything runs fine with everything maxed out, so  it makes no sense to me. Usually at around 60fps.

Link to comment
Share on other sites

Hardware probe? is that some feature of official?

Does sound like it's extra useless if it's doing that! is it some sort of external application that is launched and adjusts the settings incorrectly? I guess the nuclear option would be to just delete/rename it if that is the case.

edit: downloaded official to check, didn't notice it mentioning anything about hardware probe. Did take a look at Debug settings though and there is one called "NoHardwareProbe" - try setting that to TRUE and restart. Debug setting description is "Disable hardware probe." so sounds like what you need.

 

 

Edited by AmeliaJ08
doesn't work that way
Link to comment
Share on other sites

Try Amelia's suggestion.

Or edit your launch icon to change the launch command. See: https://wiki.secondlife.com/wiki/Viewer_parameters

Add the switch: --noprobe     = Disable hardware checking at startup.

I've had my viewer do the New Graphics Setting thing on earlier versions. As I recall there is a Windows Permissions problem.

 

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

28 minutes ago, Jackson Redstar said:

I did find the Probe debug settings changed them made no difference. Ill see if i can try amelia suggestion

Hmm no difference sorta implies that it is maybe unable to save settings? I mean, given the other behaviour you noted. Is the viewer installed in the usual folder (C:\Program Files\) and are you using the same user account that installed it?

 

 

Edited by AmeliaJ08
Link to comment
Share on other sites

My settings save just fine. If I change it to a saved setting, it goes back to what was saved.

Link to comment
Share on other sites

Various settings in the viewer can be changed any time in a session. But they aren't saved until the viewer exits. If your viewer crashes silently on exit, those changes may not get saved. The next launch of the viewer will load the previous settings missing the last changes.

The work around is to make the setting change after a fresh launch and then immediately exit the session.

The idea being that the viewer has to run for some time for the 'crash on exit' issue to be triggered. So, shorten the run time and hope the viewer exits without a problem.

There are files in the 'logging folder' that tell us if the viewer crashed and when. The viewer creates files that are specific points in the launch and shutdown.

  • SecondLife.error_marker – I don’t know what information is inside. I don’t have a copy to examine as I write this.  The presence of the file indicates where, when, and what error happened. I think this is a disaster backup file for crash reporting in which information about the crash is retained in the event the crash handlers are destroyed before they can create the other more complete crash files.
  • SecondLife.start_marker – There is no information inside. The presence of the file indicates how far into the start process the viewer has gotten. Whether the file exists or not is the pertinent information.

If your viewer is not crashing on exit then the problem is more likely a Windows permissions issue.

Edited by Nalates Urriah
grammer
  • Thanks 1
Link to comment
Share on other sites

2 hours ago, Jackson Redstar said:

i would have to assume that on start up debug settings dont really do anything. I looked into the other suggestion - way above my pay grade! lol

Debug Settings are the viewer's settings. The word 'debug' in use here is more a verb than a noun.

  • Like 2
Link to comment
Share on other sites

20 minutes ago, Jackson Redstar said:

other than a degree in IT, looks like no way to turn off the hardware probe at start up. Might be a cool feature to add for installation - you can turn off hardware detection

Changing the debug setting or using the parameter had no effect?

Link to comment
Share on other sites

I've some issues running shadows in PBR, but not much. Still on older hardware myself, 1050 GPU. But I keep my dd down to 128, SSR off, occlusion off, and mirrors off unless I'm in a small room with a few of them by myself. Medium-high settings for me (in between medium and high).

I'm usually on FS, but lately on Alchemy as that viewer is more stable for me ATM.

I always have hardware detection on in FS.

Link to comment
Share on other sites

2 hours ago, Jackson Redstar said:

other than a degree in IT, looks like no way to turn off the hardware probe at start up. Might be a cool feature to add for installation - you can turn off hardware detection

The cool feature has already been added. But it is implemented as a command line switch. The hardware probe is used to reduce problems for new installs. If you turn off the probe then you manually have to ask which video card and drivers are being used so the view can run. The viewer makes an initial attempt to figure that out, because the typical user these days has no clue, and fit the settings of the viewer to a users hardware for a balance of performance and appearance.

Right click the icon you use to launch the viewer, go into Properties, you'll see an entry for "Target:", that looks like:

"C:\Program Files\Firestorm-Releasex64\Firestorm-Releasex64.exe" --set InstallLanguage en

At the end of the line add a space and the switch (notice switches require 2 dashes):

--noprobe

You can see the full list of command line switches for Firestorm by opening a CMD window and launching Firestorm using the command:

"C:\Program Files\Firestorm-Releasex64\Firestorm-Releasex64.exe" --help

In the Debug Settings you have two settings to try; NoHardwareProbe and ProbeHardwareOnStartup. These two appear to be sticky.

In 2011 people were running into similar issues. See:

 

Link to comment
Share on other sites

31 minutes ago, Jackson Redstar said:

that explanation was a bit easier - it "worked" but not really - without the probe everything was turned down to the lowest possible settings, be careful what you ask for lol

That is the problem with skipping the probe. However it does let the viewer run.

You then have to setup all your own settings. In 2008 when I started playing in SL there was no other choice. The Lab hard coded some stuff and made some choices based on what they knew about any given video card they could detect. But they were always behind the curve. So we ALL tweaked our computers and viewers for our preference of balance between performance and quality.

With a --NoProbe switch in place you should be able to start adjusting your graphics settings and have a viewer working reasonably well.

  • Like 1
Link to comment
Share on other sites

I'm not aware of any SL viewer that selects settings well automatically, I genuinely wondered if Firestorm is even trying to do that since the settings it chooses don't seem right. I assumed everyone just tweaked their graphics settings appropriately, you absolutely should.

 

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...