Jump to content

Blender error message I can't decipher


Nacy Nightfire
 Share

You are about to reply to a thread that has been inactive for 4780 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

daeTriangles.material = mesh.materials[k].name

AttribluteError: ‘NoneType’ object has no attribute ‘name’

 

 

I rigged my mesh and all the vertex groups seem to be properly assigned.  I assigned a single material to the mesh and I made uvs.  I also "made real" the modifier.   When I select the mesh and the bones in obj mode and try to export I get the above message.   Anyone know what this means?

Link to comment
Share on other sites

Ok, I couldn't program my way out of a paper bag, but I figured out what I was doing wrong.  I assigned a material in edit mode, but I needed to assign a material via F5/Material Button "make new".

Now I have to figure out why my uploaded rigged mesh looks like chewed up gum. :(

Link to comment
Share on other sites

Ah ok. Sometimes you will get stray vertices after performing a decimation. You may want to select all in edit mode, hit W then select remove doubles. After that, you can check for totally unattached vertices. Make sure you are in face select mode, select all the faces then move it. Go back to vertex select mode if you see a cloud of vertices left behind, you'll need to delete them.

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 4780 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...