Jump to content
  • 0
Sign in to follow this  
Dottie Idlemind

What happened to my shadows in Viewer 2?

Question

  • 0

Hi Dottie,

I have an ATI Radeon HD 5850 so I'm going to install the latest viewer and login to see if I can enable Shadows. Like you I have been able to use Shadows for a long time so if I can't now, there may be a problem.

In the meantime, uninstall the viewer completely including manually deleting the Second Life folders in AppData > Roaming and AppData > Local.

If AppData is hidden, you need to enable viewing. Follow the instructions for your OS here: http://forums.majorgeeks.com/showthread.php?t=7422​0 or here http://www.bleepingcomputer.com/tutorials/tutorial62.html

If you wish to save existing chat files you've had with other avatars, move the Roaming > [avatar name] folder elsewhere on your computer and drag any chat text files you wish to retain into the new Roaming > [avatar name] folder once Second Life is reinstalled and you've logged in at least once. Ignore if you don't want to save any.

Now download Second Life from the main download page and install it.

Log into the region Smith. If you can't change Login Location, tick the box 'Show on login' under Preferences > General > Login Location. Make sure you are in Advanced mode and not Basic prior to logging in. Allow your Inventory to load. Click the Recent tab to get this going and wait until it's loaded before doing anything. Now try Shadows. 

I usually advise people to open Preferences > Setup tab and change 'Software updates' drop down menu to 'Download and install updates manually', as the automatic update process has caused problems for some. Unless you are experiencing problems a simple uninstall from the Start Menu > All Programs > Second Life should suffice before downloading and installing future viewer releases.

  • Like 2

Share this post


Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0

Hi Dottie,

I have an ATI Radeon HD 5850 so I'm going to install the latest viewer and login to see if I can enable Shadows. Like you I have been able to use Shadows for a long time so if I can't now, there may be a problem.

In the meantime, uninstall the viewer completely including manually deleting the Second Life folders in AppData > Roaming and AppData > Local.

If AppData is hidden, you need to enable viewing. Follow the instructions for your OS here: http://forums.majorgeeks.com/showthread.php?t=7422​0 or here http://www.bleepingcomputer.com/tutorials/tutorial62.html

If you wish to save existing chat files you've had with other avatars, move the Roaming > [avatar name] folder elsewhere on your computer and drag any chat text files you wish to retain into the new Roaming > [avatar name] folder once Second Life is reinstalled and you've logged in at least once. Ignore if you don't want to save any.

Now download Second Life from the main download page and install it.

Log into the region Smith. If you can't change Login Location, tick the box 'Show on login' under Preferences > General > Login Location. Make sure you are in Advanced mode and not Basic prior to logging in. Allow your Inventory to load. Click the Recent tab to get this going and wait until it's loaded before doing anything. Now try Shadows. 

I usually advise people to open Preferences > Setup tab and change 'Software updates' drop down menu to 'Download and install updates manually', as the automatic update process has caused problems for some. Unless you are experiencing problems a simple uninstall from the Start Menu > All Programs > Second Life should suffice before downloading and installing future viewer releases.

  • Like 2

Share this post


Link to post
Share on other sites
  • 0

Hello Dottie. Your graphics card included in the recommended cards for SL (ATI 5000 series) but after the new update at least for me, seems that they are out of date. Many people had or still have serious problems with the last version 2.7.1 of Viewer 2. Maybe the best suggestion is to run back to the previous version of Viewer 2, 2.6.9 and set your software updates NO to be installed automatically. (Preferences --> Setup --> Hardware). You can find it here.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Hi Dottie,

You're absolutely right. Something is broken in the latest viewer for me too as although Lighting and Shadows is ticked for me, all the settings are greyed out and I've tried in both high and ultra graphics modes. I rarely use the official viewer as I prefer Kirstens and Shadows is working perfectly in S21 (7) 2.7.8 but I've yet to try her latest S21 (8) RC 2b. I'll download and try it soon as well.

I suggest we update our graphics drivers too just in case that fixes it.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

I thought it may be the automatic update too as I posted above but it's not. There is an issue with the latest viewer. Something has broken so we'll have to see if a driver update fixes it or it's more serious.

Share this post


Link to post
Share on other sites
  • 0

From my understanding (since I <3 taking photos with shadows and have been updated on recent developments), while shadows is supported in the main SL Viewer at last, it's still being actively worked on and tweaked as we measure performance. This has resulted in some interesting developments, like shadows finally working with Macs that have ATI graphics cards. Of course, it's not cool to have shadows stop working on cards you'd expect it to be fine on as in Dottie's case, and the 58xx range includes some pretty high-performance ones.

A few other suggestions for now, if reverting for the time being isn't preferable:

  • Switch to a "future" Viewer instead: download the SL Viewer Beta and see if that makes a difference. You can always uninstall it if it doesn't work out.
  • Go to Develop menu > Rendering and try to manually override shadows there.
  • For the technically-minded, you may want to discuss this issue on OpenSource-Dev.

In some cases, features are shown as disabled in the main user interface, but can be overriden through debug settings. This happened the other day when I was on my wife's iMac, which could show shadows but not depth of field. So I manually forced that on in Debug Settings. :)

And! When diagnosing issues like this, it's always a good idea to go to the SL Viewer's Help menu > About Second Life and paste those lines into a forum post.

Thanks Nyll for the pointer.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

I'll throw in another wrench.  While I have shadows, if I zoom out sculpts go wonky and stay that way.  ONLY if, and only sometimes, do I have a temp, partial solution.  If I manually delete all my cache the problem is fixed but only until I zoom out again.  More often than not , I have to completely reinstall after a manual clearing out.  And, of course, the issue is back if zoom out.  I wondered if it was me because the Kirstens Viewer does the same.  This makes taking pictures with shadows impossible.  What happened?  Is there a setting I can tweek? Is there another viewer?  ANYTHING??  I'm stuck with no way to take good outfit pics. I'm running a year old, high end NVidia card. 

Wonky.pngWonky2b.jpg

Share this post


Link to post
Share on other sites
  • 0

@Curious.

I haven't seen that problem mentioned before. Perhaps check if there is a Jira on it and if not, start one. What is your RenderVolumeLODFactor set at in Advanced > Debug settings? Does it make any difference to your zoom issue if you increase it to 4 or 5?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...