Jump to content

How do I Fix Animation Deforming


xLMDx
 Share

You are about to reply to a thread that has been inactive for 790 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Hi,

After creating an animation in blender whist using an Add-on to create more realistic physics  and exporting the Animation file to second life. The Avatar’s body deforms after the animation is is finished .

* note * the deforming does not happen in blender and the deforming does not happen during the animation in second life 

I baked my animations  and export them as usual .


How do I fix this ??

Link to comment
Share on other sites

4 hours ago, Eric Bloodrose said:

If you are using Avastar to export the animation, make sure you have the "With Bone Translation" option disabled, that could cause deformation problems.

Once The is is disabled the physics no longer work . Any possibility that I am doing something incorrect 

Link to comment
Share on other sites

In order to get more precise answers to your question it is important to let us know if you are using Blender only or with Avastar, and what add-on are you trying to implement with animation. With assumption you are using Blender Avastar I can offer following suggestions:

 

1. Keyframing bone translation, and exporting animations with bone translation property are two different things.

Exporting animation “With Bone translation” is simply unacceptable for body animations as this property in SL is reserved for shaping your avatar inworld and will deform avatar.

The only case when you may use it is for “tongue out” facial animation, but then you have to be sure all other facial bones are keyframed only to rotation data.

That doesn’t mean you cannot keyframe translations/positions of the bones (for some bones you simply have to) exporter will take care of conversion, you cannot export animation with translation property.

2. When baking animation, be sure to remove Scale channels in dope sheet. Even you don’t export animation with “Apply Armature Scale” property, it may cause all sort of problems.

3. When baking animation, try to use “Visual keyframing” in baking options, that might help your add-on to really be baked into animation.

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 790 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...