Jump to content

Grainy noise appears when Advanced Lighting is turned on (Solved for OP; feel free to keep commenting for others)


You are about to reply to a thread that has been inactive for 154 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

I've recently started taking pictures again and noticed this new grainy noise when I enable Advanced Lighting, which never used to be there. It seems to only appear on my avatar (head and body) and they disappear when I turn any of the shaders off.

I googled and googled but could not find the cause, so if anyone has any idea, I would be so grateful.

I've experimented with the viewer graphics settings and also the settings in my GPU control panel, like Antialiasing, Sharpening, etc. Also my monitor display settings. They don't make any difference.

Here are some screenshots (all with Advanced Lighting turned on).

This image taken in a pre-EEP version of Firestorm doesn't have any noise. I was using a different PC then, with AMD Radeon RX 580.

1781845085_screenshotold.JPG.e8da63b10a106121c1f319e1774bb624.JPG

 

For comparison, I tried to replicate the image yesterday in Firestorm and Black Dragon. Both results in noise - not exactly the same in appearance but affected area is somewhat the same (only on avatar).

Firestorm 6.4.21:

1766969967_screenshotfirestorm.JPG.2435d8f45728a276171ec1502df453ea.JPG

Black Dragon 6.4.18.48191 (64bit) 4.0.5:

1088619140_screenshotblackdragon.JPG.c4a2f8d31692b09404ccbd1bc65044cc.JPG

Drivers all updated. Current specs:

CPU: AMD Ryzen 7 5800X 8-Core Processor              (3799.99 MHz)
Memory: 65452 MB
OS Version: Microsoft Windows 10 64-bit (Build 19042.631)
Graphics Card Vendor: NVIDIA Corporation
Graphics Card: NVIDIA GeForce GTX 1080/PCIe/SSE2
Window size: 1920x965 px
 

ETA: My issue has now been solved thanks to everyone's help in this thread.

Edited by blaireberry
Update status to solved
  • Like 1
Link to comment
Share on other sites

2 minutes ago, colleen Criss said:

I'm experiencing the same now for weeks. I've tried all the same things you have. No love. I was wondering if my card was going bad BUT I do not have this when I run any other thing on the pc.

Same, this issue seems to only happen for me in SL so I'm thinking my GPU is fine.

  • Like 1
Link to comment
Share on other sites

2 hours ago, blaireberry said:

Same, this issue seems to only happen for me in SL so I'm thinking my GPU is fine.

There are several settings in the debug menu that may help.  I don't recall which one but I fixed the issue there.  Under render shadow...render shadow detail?  You can always set back to default is that isn't the one.

  • Thanks 1
Link to comment
Share on other sites

Thanks everyone, all those answers helped fix the issue.

In Firestorm, the noise was gone after setting all the ambient occlusion values back to default. Shadow blur also has an impact.

In Debug Settings, although I ended up resetting everything back to default, I'll just mention that when I played with the xyz values in RenderShadowGuassian and then reset them, it vastly improved the noise appearance (this was before they completely went away with ambient occlusion reset). Another setting that had an effect was RenderShadowBlurSize, but since there is a shadow blur slider in Phototools I left that alone.

In Black Dragon, I also reset the ambient occlusion (SSAO) back to default and adjusted the shadow blur value and the noise is also gone.

I'm guessing my old picture was taken with just Ultra being enabled, without adjusting many of the other settings. I'm very relieved - thank you so much.

  • Like 2
Link to comment
Share on other sites

Do you by any change have texture compression enabled? “Compress Textures” or whatever it’s called. If you do, turn that off, clear cache and re-log. That’s the only thing I can think of that may cause this. If it’s not that, then I don’t know. 

  • Thanks 1
  • Haha 1
Link to comment
Share on other sites

  • blaireberry changed the title to Grainy noise appears when Advanced Lighting is turned on (Solved for OP; feel free to keep commenting for others)
1 hour ago, davidventer said:

Do you by any change have texture compression enabled? “Compress Textures” or whatever it’s called. If you do, turn that off, clear cache and re-log. That’s the only thing I can think of that may cause this. If it’s not that, then I don’t know. 

Sorry, I replied without reading the thread. Didn’t see it was already solved and I was wrong. My bad. Glad you got it sorted. 

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 154 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...