Jump to content

Taking contents out of "no modify" object


tomm55
 Share

Recommended Posts

I have noticed some weird behavior. While it is NOT possible to add things to a "no modify" object or delete contents from such object, it IS possible to take contents out of it, but ONLY until you try to delete some of its contents.

For example:

1. Create a box, make two "no copy" scripts in it, then make the box "no modify" (or make sure it is "no modify"), take it and give it to someone else.
2. Ask him/her to rezz the box.
3. Ask him/her to add some content to the box - not possible - OK.
4. Ask him/her to drag only one script out of the box to their inventory - possible (huh?) - script gets moved from box to inventory and deleted from box despite the box being "no modify".
5. Ask him/her to delete the second script (right click script and delete) - not possible - says "Not permitted to edit this." - OK.
6. Ask him/her to drag the second script to their inventory - now NOT possible 🤪
7. Ask him/her to take the object and rezz it again.
8. Ask him/her to drag the second script to their inventory - possible again 🤪

Is this expected behavior? Or am I missing some important point?

(Tried google, looked even here).

Reproduced with Firestorm (v6.4.21.64531) and official viewer (v6.5.2.43139), giving same results.

Edited by tomm55
simplified
Link to comment
Share on other sites

15 minutes ago, arton Rotaru said:

Actually, it's like that for quite a long time. There are a couple reports where pros and cons are discussed. https://jira.secondlife.com/browse/SVC-6145

Thanks a lot for the link. I did not know I can access Jira with my username and password (just tried it), so that's very useful for me. And yes, it looks like it has been so for ~15 years and was basically accepted as a feature 🙂 Thanks.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...