Jump to content
  • 0

space navigator won't work with my mac


Molly Cybertar
 Share

You are about to reply to a thread that has been inactive for 3752 days.

Please take a moment to consider if this thread is worth bumping.

Question

  • 0

Luc Starsider uses a Space Navigator with SL on his Mac and he's on Answers very frequently. Torley Linden also uses it with his Mac.  Perhaps this thread will help but if not, I'll drop Luc a PM. Torley often pops in on threads like this too.

http://community.secondlife.com/t5/Viewer-2-0-General/Problem-with-Space-Navigator-in-Second-Life/td-p/175663

Also see http://wiki.secondlife.com/wiki/SpaceNavigator

Link to comment
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Luc Starsider uses a Space Navigator with SL on his Mac and he's on Answers very frequently. Torley Linden also uses it with his Mac.  Perhaps this thread will help but if not, I'll drop Luc a PM. Torley often pops in on threads like this too.

http://community.secondlife.com/t5/Viewer-2-0-General/Problem-with-Space-Navigator-in-Second-Life/td-p/175663

Also see http://wiki.secondlife.com/wiki/SpaceNavigator

Link to comment
Share on other sites

  • 0

/me waves to Nyll.

I'm also using my SpaceNav on Snow Leopard. I, however, have not yet upgraded to the latest version of the driver - mine is version 1.6.1.

First of all, I recommend you download and install Onyx which lets you perform a few necessary maintenance tasks on your mac. Make sure you are logged in with Administrator rights on you mac, start the program and confirm the questions you get when it starts. Then, go to the Automation tab and run the tools there - If not all of them, run at least the daily, weekly and monthly scripts. The program will run tools and scripts that are present on your Mac, but is rarely run automatically. This will make sure things run as smoothly as possible.

You may have checked, but in the viewer, in me->Preferences->Move & View, under the button Other Devices, make sure the 'Enable joystick: SpaceNavigator' checkbox is checked. I have not touched the other settings in the panel. The 'Roll' and 'Zoom' mapping, since you mention the mouse taking over these functions, are set to 4 and -1 respectively.

In the SN driver, I have had to leave it on 'Any application' to get it to work with SL. Adding SL and creating a configuration specifically for it has not worked for me.

I'm not sure this will help, but try/check them. If you still have a problem, i suggest deleting the SL viewers prefs file from ~/library/Preferences (Hopefully, there is only one, called com.secondlife. and something). Also move the folder ~/Library/Application Support/Secondlife to the desktop. (This folder contains chat and IM logs, so you may want to hang on to those.) This means you will have to change all the viewer settings to your liking when you log in. Then empty ~/Library/Caches/Secondlife. 

Log in and see if things have improved.

Hopefully some of this helps. If not, I'm not sure I can come up with something else to try, but come back and tell us how things go.

- Luc -

Link to comment
Share on other sites

  • 0

After IM'ing with Molly in world, it turns out that at least a partial solution is to unplug the mouse before starting the viewer, but leaving the SpaceNavigator plugged in. After the viewer has started, the mouse can be plugged back in again. Also, in the Other device preferences, make sure 'Avatar' is checked (and build and flycam if that is interesting).

- Luc -

  • Like 1
Link to comment
Share on other sites

  • 0

I have a brand new (2 day old) iMac and have performed a clean install (i.e. I did not migrate my old data across).

 

I downloaded Firestorm Beta, and the Sapce navigator drivers. My movement is totally screwed up with the navigator. I must pull up to walk forward, press down for back. its not possible to turn or pan around.

I previously used the Phoenix viewer on my old mac and had no issues. Searching the Jara, i see a report for a problem with Linux, but nothing for the Mac.

In my case it cant be a mouse conflict, as I have a wireless connection. 

 

Link to comment
Share on other sites

  • 0

@Ona. You should be able to sort out the direction of the SN by going to preferences for the SN in System preferences and change the Zoom direction. Also, in the Application section, pan/zoom and tilt/spin should be checked. In the Advanced section of the driver config, make sure all the axis are checked.

(I haven't installed the latest driver, so this how it is in driver v. 1.6.1)

- Luc -

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 3752 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...