Jump to content

Deploy Plan for the Week of 2021-11-15


Mazidox Linden
 Share

You are about to reply to a thread that has been inactive for 213 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

  • Lindens

Hello everyone! We're doing some slightly unusual restarts on Tuesday of this week. From your perspective they should look just like a quick rolling restart for the main channel, but they're actually quite a bit more exciting than that. We're finally ready to put all Homestead and Openspace (and 1/6th of all main channel Full) regions on the same configuration change that we put out to RCs during the week of 2021-09-14. There should be some modest performance increases associated with this change in most circumstances. There isn't a version number difference associated with this change, so until we get the rest of Second Life Server's Full regions on the same configuration there will be a mixture of old and new region configurations co-existing. We anticipate that we'll finish converting everything to the new configuration in the next month or so.

Second Life Server

https://releasenotes.secondlife.com/simulator/2021-10-25.565008.html

Tuesday 2021-11-16 06:00-11:00 PST

Second Life RCs

https://releasenotes.secondlife.com/simulator/2021-10-25.565008.html (existing version)

https://releasenotes.secondlife.com/simulator/2021-11-11.565737.html (new version, replaces 2021-10-29.565204)

Wednesday 2021-11-17 07:00-9:30 PST

On Rolling Restarts

All regions will be restarted this week.

Edited by Mazidox Linden
  • Like 1
  • Thanks 6
Link to comment
Share on other sites

17 hours ago, Mazidox Linden said:

 

Second Life RCs

https://releasenotes.secondlife.com/simulator/2021-10-25.565008.html (existing version)

New Version Release Notes Coming Soon! (new version)

Wednesday 2021-11-17 07:00-9:30 PST

 

@Mazidox Linden What about the RC regions on 2021-10-29.565204 - are they staying on 565204 or rolling back to 565008?

Link to comment
Share on other sites

One of my regions that used to start at around 75% scripts run, but eventually hangs around 60% scripts run, now shows 100% scripts run. [ETA] I believe my region is on the newer configuration change.

However, there seems to still be significant scripted rez delay that used to only be seen when regions were performing poorly.  Prior to these changes, the longer a region ran, the more "tired" it got and the rez delay would increase to what seemed like a two-second cap.

After this roll, the rez delay seems to exist before a region becomes "tired".  [EDIT] Additionally, it appears that the more child prims an object has, the longer the rez delay is.  All the script rezzed objects just have one script in them, but some have several child prims ranging from 1 to 5 prims.

[SEE BELOW FOR MORE INFO]

Edited by NeoBokrug Elytis
Link to comment
Share on other sites

My  two penn'orth after today's roll is that I see no significant improvement in any parameters, indeed script run, which was routinely over 50% during several rolls is now 35-40%.

No discernible reduction in script performance on Wood of Heaven (Homestead) but definitely somewhat lower script-run percentage.  So I guess the performance improvement you were expecting is not going to be seen, regrettably.

That said, nothing seems significantly worse, at least!

Edited by Aishagain
Link to comment
Share on other sites

6 hours ago, NeoBokrug Elytis said:

[SEE BELOW FOR MORE INFO]

I did further tests -- and allow me to explain a bit of background before I go into my findings;

We have an arena in The Wastelands that rezzes different tiles for different arena configurations.  The arena is VERY old 2007 code that I did not write, and has had a few new features bolted on for expanded functionality.  But the basis for how it functions remains the same.  It has historically been a good measure of rez delays because it has to rez 81 tiles in total for a single map.

These tiles were made before llSetLinkPrimParams, and all the other beautiful functions we have now.  Due to previous rez delay issues where more scripts equals more rez delay, the arena tiles got a refactoring back in August to be a single script.  Until then, they still worked fine, so there was never a need to update them.  Now all the updated scripts share the same base code, but may have a little extra code to handle collision and timer events.  All the hazardous tiles typically have a collision and/or timer event associated with them and extra primitives as part of their link sets.  The clear tile has no such events and is a single prim.  That is why I mistakenly thought that additional prims were the cause of the rez delays.

After the Server Meeting, I decided to continue my testing.  I added another prim to the clear tile that rezzes faster.  To my surprise it rezzed just as fast as it did before; that is to say without any delay.  Which completely debunks what I thought was happening with child prims.  (And now I feel bad for wasting Server Meeting time)

Then I made the tile a single prim again however, this time I added an empty collision event to the existing script.  When the arena was told to render a new map, the delay for the clear tiles was there.  Pretty interesting!  I had thought that certain events in the script queued up the delay.  But...

I then reverted the script to its original code, recompiled, and told it to render a new map.  The delay was still there, despite the code and prim being EXACTLY the same as it was before.  The only change is that this was compiled today, where the old script was compiled back in August.

 

Anyway, the majority of everything rezzed by scripts has a solid 2 seconds delay.  This is on a freshly restarted region, and I can't figure out what is so special about the OLD clear tile, versus the "new" clear tile.

 

Edited by NeoBokrug Elytis
  • Like 1
Link to comment
Share on other sites

OK the roll is complete and my region was restarted and still on 565008, so just a restart or one of those new fancy tweaks?  Still no post from Mazidox or anyone.  @Mazidox Lindenwhy no post?

ETA:  I see the Grid Status Page is telling us that next week's Second Life Server (Main Server to us, the great unwashed) is to be on Monday, not Tuesday.  Is this some US notable Day or is there some other reason for this departure?

Edited by Aishagain
Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 213 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...