Jump to content
  • 0

I can't touch some HUDS


DMTLC
 Share

You are about to reply to a thread that has been inactive for 76 days.

Please take a moment to consider if this thread is worth bumping.

Question

I have a problem right now where I can't touch my "Necklace", My Gianni body hud my AO etc. I tried thinking about the possible reasons it could be and all I remember was joining a RP that hands you a HUD and ever since I can't touch. I have checked Avatar health and done all the options and still no luck, please help :)

Link to comment
Share on other sites

20 answers to this question

Recommended Posts

  • 0

Have you tried detaching the RP HUD yet?  That would seem like an obvious first step.  There's a good possibility that much of that HUD is actually a huge transparent prim that covers a lot of your screen.  That may be necessary for it to work, but meanwhile it could block you from being able to click on other HUDs.

Link to comment
Share on other sites

  • 0

The RP is called pandemonium and apparently the HUD cannot be detached and it only attaches when at the sim. But it for sure isn't the transparent prim because I can right click and edit my huds just not touch use them

Link to comment
Share on other sites

  • 0
1 minute ago, DMTLC said:

The RP is called pandemonium and apparently the HUD cannot be detached and it only attaches when at the sim.

Aha.  That sounds like it is temp attached by an Experience. If it's well-scripted, it should auto-detach if you teleport out of the region, but that is not necessarily foolproof.  It might not be detaching.  As sandi recommends, highlight transparent objects to see if there's stuff on the screen that you didn't know was there.

6 minutes ago, DMTLC said:

I can right click and edit my huds just not touch use them

That's a good observation.  If you can edit them, you ought to be able to click activate them too. I assume that you have tried detaching and reattaching them. If their scripts have stalled, that might restart them. You might also try making new copies of the HUDs from the original ones that you stored as backups.

Link to comment
Share on other sites

  • 0

Well after trying to copy stuff and do the other recommended tasks it still doesn't work, but I did equip a different "Necklace" and it seems to work, so I'm guessing that only the stuff i had active when joining the RP sim is now not functional. I must add that I would much prefer to use the stuff I have active

Link to comment
Share on other sites

  • 0

Did you look in your inventory to see what you are wearing?  

If you are wearing a HUD that won't come off due to an experience, have you tried banning the experience?  

Sorry if u already tried those ideas, it all i can think of atm :)

 

Link to comment
Share on other sites

  • 0

Banning the experience? Never heard or tried that, also more info. Could this problem be due to me joining a sim with limited scripts etc? 

Link to comment
Share on other sites

  • 0

Well, definitely try in a different sim to be sure.  Make sure you have rights to run scripts, (just sayin ;P)

Also, what viewer are u using?  If it is either FS or the default viewer, i can prolly tell u how to get out of experiences.  

Not sure if you tried to see transparent items, and if that showed anything?

If you are in FS, and in a sim where you have rights to run scripts, you can touch your HUDs via your inventory floater.  

Well, if you want me to explain any of all those ideas, lemmie know. :)

 

Link to comment
Share on other sites

  • 0

I would also try refreshing attachments if it happens in the future - particularly if you have something that won’t come off or won’t work and it’s not been locked by RLV to your knowledge. Sometimes the items we wear fall off in the hand crossing between regions if we teleport, especially if there’s more than one thing attached to the same point. 

  • Like 1
Link to comment
Share on other sites

  • 0

Well I already tried the transparent shortcut and I don't see anything wrong.

I tried blocking the experience and nothing changed..

I even went to a sandbox that has it allowed but there is one logo that is like a blue man standing in front of a pyramid, don't know what that means...

And I am in Fs fyi

Link to comment
Share on other sites

  • 0
9 minutes ago, DMTLC said:

It was more of a force log out, basically it told me I have too many scripts and it auto logged me out.

do
  llAttach… scripted_attachment
too many times

detecting overscripted_avatar
  llTeleportHome… 

Oh, oops?

Link to comment
Share on other sites

  • 0
1 hour ago, Qie Niangao said:

do
  llAttach… scripted_attachment
too many times

detecting overscripted_avatar
  llTeleportHome… 

Oh, oops?

Ah, so a punishing script that the landowner has decided to use to enforce his rules about not wearing too many scripted items. That makes some sense in a RP region.  Otherwise, it's a pain in the .....  whatever.  If you really want to go to that region,  all you can do is play by their rules.

Edited by Rolig Loon
typos. as always.
  • Like 2
  • Thanks 1
Link to comment
Share on other sites

  • 0
7 hours ago, DMTLC said:

And that should fix?

Sorry, I was speculating how a landowner could end up griefing visitors, possibly by accident: Imagine that something triggers an attachment-giver to go haywire and start attaching role-play HUDs and/or other script-heavy stuff on a hapless visitor. And another device, intended to protect the region from script lag, detects all those scripts and tells the visitor to get lost. And because SL bugz, maybe teleporting-home our script-heavy visitor sometimes causes a crash, and crashing while teleporting bricks their scripted attachments.

The "fix" (such as it is) was mentioned earlier: to get all your attachment scripts running again you'll need some combination of

  1. replacing them with new copies from your inventory, or
  2. redelivering them from their creators' vendor systems, or
  3. setting them to run, and maybe resetting them, or even recompiling them, from the Build/Scripts menu while the attachment is selected.

Option 3 is the quickest, but is only possible with attachments for which you have Modify permission. (Note it's the attachment object that must be modifiable, not the scripts inside.)

  • Like 1
Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 76 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...