Jump to content

Recommended Posts

Is anybody else experiencing the following?  And were you able to fix it?

I have skyboxes that frequently won't rez since the last few months. They are packed in a box inside a transport flower that flies one to the sky. You click the flower and it rezzes the box that has the skybox parts packed inside it, and the skybox then rezzes from that box.

People see the box rez from the flower briefly and then it disappears without the skybox rezzing.

This happens sometimes at my skybox demo area with the same setup. Restarting the sim (mine or other people's) does fix the problem, but if someone lives on the mainland or on a sim with an uncooperative landlord they are SOOL   :(

Oddly, some customers say their skybox system works on one sandbox and not another (perhaps because one of the sandboxes had a sim restart).

I'm not sure, but I think when LL does an update for the region this causes the problem. Then a region restart fixes it.

Link to post
Share on other sites
4 hours ago, Lucia Nightfire said:

I still see on_rez() & object_rez() randomly not trigger in certain apps of mine.

I did notice that in something a few days ago, but not in something I wrote months ago that relied on it a good deal (if memory serves, not going to dig it up at the moment). Is this a new issue?

Link to post
Share on other sites
1 hour ago, Quistessa said:

I did notice that in something a few days ago, but not in something I wrote months ago that relied on it a good deal (if memory serves, not going to dig it up at the moment). Is this a new issue?

No, it's been going on since November of 2019. That's when a change was made that introduced a series of bugs like BUG-228939.

  • Like 1
  • Thanks 1
Link to post
Share on other sites

There's a couple more events seem to be sometimes slipped or significantly delayed, moving_start and moving_end, at random intervals in regions where scripts run is less than 40%. Again, as Lucia says, it became most noticeable at the end of 2019

However, as these problems are "hard" ones, I have a suspicion that GUI inventories will be rolled out to take people's minds off the problems by giving them something new to play with :)

  • Thanks 1
  • Haha 1
Link to post
Share on other sites

Old scripts may depend on object_rez and send a message after a short delay.
That doesn't work anymore - or better - it may work sometimes 😁

For quite a while I use a handshake. The rezzed object sends a message to the rezzer. Then the rezzer knows that the object is rezzed and ready and can do further actions.

For the OP: script is garbage now - you need to get a new one.

  • Thanks 1
Link to post
Share on other sites

All I know is that I'm not redoing all those skyboxes, even if they cease to work at all. This might just be the last straw for me -- I've never even completed redoing problems from the last time they changed something (big prims intersecting avatars who don't own the prims and so not rezzing), and so some pieces of my skyboxes don't rez in my Demo area because the customer doesn't own the prims (but do work once a customer buys and owns the prims).

Strange how they work again after a region restart isn't it?

Link to post
Share on other sites
1 minute ago, Luna Bliss said:

Strange how they work again after a region restart isn't it?

So an interim solution would be to rent parcels on a private island where you at least have a chance of persuading the estate management team to restart? It's actually quite a quick process so provided there aren't a dozen other inhabitants there to protest the interruption you've a good chance of getting a restart when you need it.

I moved off such a private island and onto mainland, not realising how much harder it can be to persuade somebody at Linden to restart mainland. Unfortunately I love where I am too much to go back to a private island now.

Link to post
Share on other sites

There has been a lot of changes i thing with rezing and moving objects with animation you  can notice a lot of tie slice errors as the item is moving faster than the system allows . I have noticed this particularly with llKeyFrameMotion . If your using this then you will need to increase the time you allocate  for the action . I am wondering if things on cloud have been sped up 

Something like 

time = (float)llVecDist(l_pos,(l_dest))/(3.25/2);
if(time < 0.2) time = .2;

  • Like 1
Link to post
Share on other sites
On 6/11/2021 at 10:26 AM, Profaitchikenz Haiku said:
On 6/11/2021 at 10:21 AM, Luna Bliss said:

Strange how they work again after a region restart isn't it?

So an interim solution would be to rent parcels on a private island where you at least have a chance of persuading the estate management team to restart? It's actually quite a quick process so provided there aren't a dozen other inhabitants there to protest the interruption you've a good chance of getting a restart when you need it.

I don't think a customer would appreciate my telling them they need to relocate in order for one of my purchased products to work..

Link to post
Share on other sites
1 minute ago, Luna Bliss said:

I don't think a customer would appreciate my telling them they need to relocate in order for one of my purchased products to work..

I quite agree, but I'm in a similar situation with some script that aren't operating as anticipated in regions where the percentage scripts run is less than 40%. I didn't expect this level of performance degradation when I wrote the scripts, and I was hopeful of Linden rectifying the situation, which hasn't happened for well over a year now. I've been experimenting to see how feasible it is to amend the scripts to try and cope with delays in things occurring but it's going to be quite a major operation. All I can say to people is, go to a private island where you can get restarts more rapidly than on mainland.

  • Like 1
Link to post
Share on other sites
22 hours ago, Profaitchikenz Haiku said:
22 hours ago, Luna Bliss said:

I don't think a customer would appreciate my telling them they need to relocate in order for one of my purchased products to work..

I quite agree, but I'm in a similar situation with some script that aren't operating as anticipated in regions where the percentage scripts run is less than 40%. I didn't expect this level of performance degradation when I wrote the scripts, and I was hopeful of Linden rectifying the situation, which hasn't happened for well over a year now. I've been experimenting to see how feasible it is to amend the scripts to try and cope with delays in things occurring but it's going to be quite a major operation. All I can say to people is, go to a private island where you can get restarts more rapidly than on mainland.

Ahh, ok.

So was it moving to the cloud that caused all this?

Link to post
Share on other sites
1 minute ago, Luna Bliss said:

So was it moving to the cloud that caused all this?

No, the problems predated the move, and in fact when asking about possible fixes, the reply from Lindens at the Server User Group meeting often took the form that it would be easier to address after the move to the cloud. There was also hope held out that the upscaling from moving to more modern servers might well improve things to. I believed them, because there was no other realistic option.

With the exception of the Beta Grid I can't think of anything that the cloud move could be blamed for.

 

  • Sad 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...